locked
Windows 7 a AT modem - error 633 RRS feed

  • Question

  • Hello,

    I have a problem with Windows 7 and serial AT modem which is driving me up the wall for several days..

    I have installed a "Standard serial modem 33600 bits per second" which is using the COM1. Then I created new DialUp connection. Everytime I try to open the dialup connection I get the error 633 (The modem or other connecting device is already in use of not configured up).

    When I install the modem on WinXP, it works well.

    Note that I have searched the internet but none of the solutions helped. There is no device on my PC which could use the COM port.  I tried to install it to another computer with Win7 but the result was the same: error 633.

    Thanks for any help..

     

    Monday, October 3, 2011 8:48 AM

All replies

  • Note that it is possible to communicate with the modem using terminal (similar to XP's hyperterminal). When I send AT command to the modem, it responses normally. There is no problem...

     

    Here is a fragment of the modem log (RASAPI32.LOG):

     

    [3132] 10-03 09:37:57:109: RASCS_OpenPort

    [3132] 10-03 09:37:57:109: DwOpenPort

    [3132] 10-03 09:37:57:109: DwOpenPort: RasPortOpenEx(Standard modem 33600 b/s,0)...

    [3132] 10-03 09:37:57:125: DwOpenPort: RasPortOpenEx done(259). Flags=0x2

    [3132] 10-03 09:37:57:125: DwOpenPort done. 633 (dwSavedError 0)

    [3132] 10-03 09:37:57:125: RasDialMachine errors=633,0

     

    And a PPP.LOG:

    [2652] 10-03 09:37:57:109: IsTrustedCustomDll: pwsz=, fTrusted=0, rc=0

    [2652] 10-03 09:37:57:109: PortOpenEx: Standard modem 33600 b/s

    [2652] 10-03 09:37:57:125: PortOpenEx: port COM1 not available. 0x80000048

    [2652] 10-03 09:37:57:125: PortOpenEx: rc=0x103. DeviceFound=1

    Monday, October 3, 2011 9:06 AM
  • 1. Show the modem configuration

    AT &V

    2. Here is possible problem

        a. PortOpenEx: port COM1 not available. 0x80000048  

         b. Check settings in BIOS

         c. Check possible interrupt conflicts

    PS What type is the modem, what is its interface and what type of serial port is on W 7 computer.

     

    Monday, October 3, 2011 9:25 AM
  • I'm sure the COM1 is available. The BIOS setting is ok I think, but I'll check in again as soon as possible. As I wrote above, the modem responds on AT command when I use terminal. The terminal connects to the COM1 with no problem. 

    The serial port on the computer is physical - no virtual port, usb serial port... just common physical serial port.

    Monday, October 3, 2011 10:12 AM
  • 1. Show here the modem settings (AT &V) as well as the ppp.log file

    2. Communication port is either not accesible or blocked by another process. You should not have hyperterminal (or similar) opened, while you start other windows  communication application. 

    3. Is there any other communication device, eg. bluetooth

    4. If hyperterminal works, it does not imply that other communication programs would work. 

    5. Clean boot, removing the modem drivers and sfc /scannow may reveal corrupted system files (tapi)

    6. Have you used native Windows drivers or the vendor's ones?

    Monday, October 3, 2011 2:20 PM
  • 1. Show here the modem settings (AT &V) as well as the ppp.log file

    2. Communication port is either not accesible or blocked by another process. You should not have hyperterminal (or similar) opened, while you start other windows  communication application. 

    3. Is there any other communication device, eg. bluetooth

    4. If hyperterminal works, it does not imply that other communication programs would work. 

    5. Clean boot, removing the modem drivers and sfc /scannow may reveal corrupted system files (tapi)

    6. Have you used native Windows drivers or the vendor's ones?

    1. AT & V:

     

    AT &V

     

    Q:0 V:1 S0:000 S2:043 S3:013 S4:010 S5:008

    +CR:0 +CRC:0 +CMEE:0 +CBST:0,0,1

    +SPEAKER:1 +ECHO:0,127 &C:1 &D:2 %C:0

    +IPR:0 +ICF:3,4 +IFC:0,0

     

    OK

    --------------------------------------------------------------------------------------------------

    PPP.LOG:

     

    [3840] 10-03 14:54:21:000: GetParamsListFromLsa Default=0

    [3840] 10-03 14:54:21:000: GetParamsListFromLsa. 0x0

    [3840] 10-03 14:54:21:000: GetParamsListFromLsa Default=1

    [3840] 10-03 14:54:21:015: GetParamsListFromLsa. 0x2

    [2904] 10-03 14:54:22:312: SetEntryDialParams: Writing to fDefault=0

    [2904] 10-03 14:54:22:437: GetParamsListFromLsa Default=0

    [2904] 10-03 14:54:22:437: GetParamsListFromLsa. 0x0

    [2904] 10-03 14:54:22:437: CreateConnection: entry=IFV, pbk=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [2904] 10-03 14:54:22:437: CreateConnection: fSecureRoutingCompartment: 0 and dwConSessionId 2  old Compartment ID 1:

    [2904] 10-03 14:54:22:437: SetRasmanServiceStopControl: Enabled 0

    [2904] 10-03 14:54:22:437: CreateConnection: Created new connection. hconn=0x30000, ref=1, pConn=0x3264f10

    [2904] 10-03 14:54:22:468: IsTrustedCustomDll: pwsz=, fTrusted=0, rc=0

    [2904] 10-03 14:54:22:468: PortOpenEx: Standardní modem 33600 b/s

    [2904] 10-03 14:54:22:468: PortOpenEx: port COM1 not available. 0x80000048

    [2904] 10-03 14:54:22:468: PortOpenEx: rc=0x103. DeviceFound=1

    [2904] 10-03 14:54:22:468: ReferenceCustomCount

    [2904] 10-03 14:54:22:468: ReferenceCustomCount done. 0

    [2904] 10-03 14:54:22:468: RefConnection: 0x30000

    [2904] 10-03 14:54:22:468: refcount=0, maxports=0, ports=0

    [2904] 10-03 14:54:22:468: RefConnection: deref - freeing connection as 0 ports in this connection

    [2904] 10-03 14:54:22:468: DwSendNotificationInternal(ENTRY_DISCONNECTED) returnd 0x0

    [2904] 10-03 14:54:22:468: FreeConnection: pConn=0x3264f10, 0

    [2904] 10-03 14:54:22:468: RefConnection: pConn = NULL for 0x30000

    [2904] 10-03 14:54:22:468: PppStop: Port not found (ppcb is NULL)

    ------------------------------------------------------------------------------------------------------------------------

    RASAPI32.LOG (my dialup connection is named "IFV"):

     

    [3720] 10-03 14:54:21:000: RasGetCredentialsW

    [3720] 10-03 14:54:21:000: IsRasmanServiceRunning=1

    [3720] 10-03 14:54:21:000: GetPbkAndEntryName

    [3720] 10-03 14:54:21:000: ReadPhonebookFileEx: called for pbk C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk, flags 8

    [3720] 10-03 14:54:21:000: IsPublicPhonebook=0

    [3720] 10-03 14:54:21:000: path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:21:000: full path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:21:000:  IsVirtualizationNeeded: return value = 0

     

    [3720] 10-03 14:54:21:000: ENTRY: Reading "IFV"

    [3720] 10-03 14:54:21:000: 

    Before LoadPortsList2 in ReadEntryList()

    [3720] 10-03 14:54:21:000: LoadPortsList2

    [3720] 10-03 14:54:21:000: GetRasPorts

    [3720] 10-03 14:54:21:000: RasPortEnum...

    [3720] 10-03 14:54:21:000: RasPortEnum=603,c=10

    [3720] 10-03 14:54:21:000: RasPortEnum...

    [3720] 10-03 14:54:21:000: RasPortEnum=0,c=10

    [3720] 10-03 14:54:21:000: RasGetDevConfig

    [3720] 10-03 14:54:21:000: RasGetDevConfig=603

    [3720] 10-03 14:54:21:000: RasGetDevConfig

    [3720] 10-03 14:54:21:000: RasGetDevConfig=0

    [3720] 10-03 14:54:21:000: SanitizeUnimodemBlob: mdm prot=0

    [3720] 10-03 14:54:21:000: Port=COM1,fHw=1,fEc=0,bps=115200,fSp=0,prot=0

    [3720] 10-03 14:54:21:000: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:21:000: LoadPortsList=0

    [3720] 10-03 14:54:21:000: successfully finished LoadPortsList2 in ReadEntryList()

     

    [3720] 10-03 14:54:21:000: Reading media group "serial"

    [3720] 10-03 14:54:21:000: New link format

    [3720] 10-03 14:54:21:000: 

    DUPTEST:Port in this media

    [3720] 10-03 14:54:21:000: Port=COM1

    [3720] 10-03 14:54:21:000: 

    Trying to match the phonebook port in the system ports

    [3720] 10-03 14:54:21:000: Port configured

    [3720] 10-03 14:54:21:000: SetDefaultModemSettings(bps=115200)=1

    [3720] 10-03 14:54:21:000: Reading device group "modem"

    [3720] 10-03 14:54:21:000: Device List after deleting dupe

    [3720] 10-03 14:54:21:000: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:21:000: Device List after deleting dupe

    [3720] 10-03 14:54:21:000: ReadRasFile: ReadEntryList returned 0

    [3720] 10-03 14:54:21:000: RASSQM: In ReadPhonebookFile Number of myuse profiles set 1

    [3720] 10-03 14:54:21:000: ReadPhonebookFile returns 0

    [3720] 10-03 14:54:21:000: DuplicatePhoneNode

    [3720] 10-03 14:54:21:000: GetPbkAndEntryName. rc=0x0

    [3720] 10-03 14:54:21:000: RasGetCredentialsW

    [3720] 10-03 14:54:21:000: IsRasmanServiceRunning=1

    [3720] 10-03 14:54:21:000: GetPbkAndEntryName

    [3720] 10-03 14:54:21:000: ReadPhonebookFileEx: called for pbk C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk, flags 8

    [3720] 10-03 14:54:21:000: IsPublicPhonebook=0

    [3720] 10-03 14:54:21:000: path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:21:000: full path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:21:000:  IsVirtualizationNeeded: return value = 0

     

    [3720] 10-03 14:54:21:000: ENTRY: Reading "IFV"

    [3720] 10-03 14:54:21:000: 

    Before LoadPortsList2 in ReadEntryList()

    [3720] 10-03 14:54:21:000: LoadPortsList2

    [3720] 10-03 14:54:21:000: GetRasPorts

    [3720] 10-03 14:54:21:000: RasPortEnum...

    [3720] 10-03 14:54:21:000: RasPortEnum=603,c=10

    [3720] 10-03 14:54:21:000: RasPortEnum...

    [3720] 10-03 14:54:21:000: RasPortEnum=0,c=10

    [3720] 10-03 14:54:21:000: RasGetDevConfig

    [3720] 10-03 14:54:21:000: RasGetDevConfig=603

    [3720] 10-03 14:54:21:000: RasGetDevConfig

    [3720] 10-03 14:54:21:000: RasGetDevConfig=0

    [3720] 10-03 14:54:21:000: SanitizeUnimodemBlob: mdm prot=0

    [3720] 10-03 14:54:21:000: Port=COM1,fHw=1,fEc=0,bps=115200,fSp=0,prot=0

    [3720] 10-03 14:54:21:000: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:21:000: LoadPortsList=0

    [3720] 10-03 14:54:21:000: successfully finished LoadPortsList2 in ReadEntryList()

     

    [3720] 10-03 14:54:21:000: Reading media group "serial"

    [3720] 10-03 14:54:21:000: New link format

    [3720] 10-03 14:54:21:000: 

    DUPTEST:Port in this media

    [3720] 10-03 14:54:21:000: Port=COM1

    [3720] 10-03 14:54:21:000: 

    Trying to match the phonebook port in the system ports

    [3720] 10-03 14:54:21:000: Port configured

    [3720] 10-03 14:54:21:000: SetDefaultModemSettings(bps=115200)=1

    [3720] 10-03 14:54:21:000: Reading device group "modem"

    [3720] 10-03 14:54:21:000: Device List after deleting dupe

    [3720] 10-03 14:54:21:000: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:21:000: Device List after deleting dupe

    [3720] 10-03 14:54:21:000: ReadRasFile: ReadEntryList returned 0

    [3720] 10-03 14:54:21:000: RASSQM: In ReadPhonebookFile Number of myuse profiles set 1

    [3720] 10-03 14:54:21:000: ReadPhonebookFile returns 0

    [3720] 10-03 14:54:21:000: DuplicatePhoneNode

    [3720] 10-03 14:54:21:000: GetPbkAndEntryName. rc=0x0

    [3720] 10-03 14:54:22:312: RasSetCredentialsW

    [3720] 10-03 14:54:22:312: IsRasmanServiceRunning=1

    [3720] 10-03 14:54:22:312: GetPbkAndEntryName

    [3720] 10-03 14:54:22:312: ReadPhonebookFileEx: called for pbk C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk, flags 0

    [3720] 10-03 14:54:22:312: IsPublicPhonebook=0

    [3720] 10-03 14:54:22:312: path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:22:312: full path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:22:312:  IsVirtualizationNeeded: return value = 0

     

    [3720] 10-03 14:54:22:312: ENTRY: Reading "IFV"

    [3720] 10-03 14:54:22:312: 

    Before LoadPortsList2 in ReadEntryList()

    [3720] 10-03 14:54:22:312: LoadPortsList2

    [3720] 10-03 14:54:22:312: GetRasPorts

    [3720] 10-03 14:54:22:312: RasPortEnum...

    [3720] 10-03 14:54:22:312: RasPortEnum=603,c=10

    [3720] 10-03 14:54:22:312: RasPortEnum...

    [3720] 10-03 14:54:22:312: RasPortEnum=0,c=10

    [3720] 10-03 14:54:22:312: RasGetDevConfig

    [3720] 10-03 14:54:22:312: RasGetDevConfig=603

    [3720] 10-03 14:54:22:312: RasGetDevConfig

    [3720] 10-03 14:54:22:312: RasGetDevConfig=0

    [3720] 10-03 14:54:22:312: SanitizeUnimodemBlob: mdm prot=0

    [3720] 10-03 14:54:22:312: Port=COM1,fHw=1,fEc=0,bps=115200,fSp=0,prot=0

    [3720] 10-03 14:54:22:312: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:22:312: LoadPortsList=0

    [3720] 10-03 14:54:22:312: successfully finished LoadPortsList2 in ReadEntryList()

     

    [3720] 10-03 14:54:22:312: Reading media group "serial"

    [3720] 10-03 14:54:22:312: New link format

    [3720] 10-03 14:54:22:312: 

    DUPTEST:Port in this media

    [3720] 10-03 14:54:22:312: Port=COM1

    [3720] 10-03 14:54:22:312: 

    Trying to match the phonebook port in the system ports

    [3720] 10-03 14:54:22:312: Port configured

    [3720] 10-03 14:54:22:312: SetDefaultModemSettings(bps=115200)=1

    [3720] 10-03 14:54:22:312: Reading device group "modem"

    [3720] 10-03 14:54:22:312: Device List after deleting dupe

    [3720] 10-03 14:54:22:312: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:22:312: Device List after deleting dupe

    [3720] 10-03 14:54:22:312: ReadRasFile: ReadEntryList returned 0

    [3720] 10-03 14:54:22:312: RASSQM: In ReadPhonebookFile Number of myuse profiles set 1

    [3720] 10-03 14:54:22:312: ReadPhonebookFile returns 0

    [3720] 10-03 14:54:22:312: GetPbkAndEntryName. rc=0x0

    [3720] 10-03 14:54:22:312: IsPublicPhonebook=0

    [3720] 10-03 14:54:22:437: RasDialW

    [3720] 10-03 14:54:22:437: IsRasmanServiceRunning=1

    [3720] 10-03 14:54:22:437: _RasDial(start)

    [3720] 10-03 14:54:22:437: GetPbkAndEntryName

    [3720] 10-03 14:54:22:437: ReadPhonebookFileEx: called for pbk C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk, flags 8

    [3720] 10-03 14:54:22:437: IsPublicPhonebook=0

    [3720] 10-03 14:54:22:437: path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:22:437: full path=C:\Users\dpEGE\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

    [3720] 10-03 14:54:22:437:  IsVirtualizationNeeded: return value = 0

     

    [3720] 10-03 14:54:22:437: ENTRY: Reading "IFV"

    [3720] 10-03 14:54:22:437: 

    Before LoadPortsList2 in ReadEntryList()

    [3720] 10-03 14:54:22:437: LoadPortsList2

    [3720] 10-03 14:54:22:437: GetRasPorts

    [3720] 10-03 14:54:22:437: RasPortEnum...

    [3720] 10-03 14:54:22:437: RasPortEnum=603,c=10

    [3720] 10-03 14:54:22:437: RasPortEnum...

    [3720] 10-03 14:54:22:437: RasPortEnum=0,c=10

    [3720] 10-03 14:54:22:437: RasGetDevConfig

    [3720] 10-03 14:54:22:437: RasGetDevConfig=603

    [3720] 10-03 14:54:22:437: RasGetDevConfig

    [3720] 10-03 14:54:22:437: RasGetDevConfig=0

    [3720] 10-03 14:54:22:437: SanitizeUnimodemBlob: mdm prot=0

    [3720] 10-03 14:54:22:437: Port=COM1,fHw=1,fEc=0,bps=115200,fSp=0,prot=0

    [3720] 10-03 14:54:22:437: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:22:437: LoadPortsList=0

    [3720] 10-03 14:54:22:437: successfully finished LoadPortsList2 in ReadEntryList()

     

    [3720] 10-03 14:54:22:437: Reading media group "serial"

    [3720] 10-03 14:54:22:437: New link format

    [3720] 10-03 14:54:22:437: 

    DUPTEST:Port in this media

    [3720] 10-03 14:54:22:437: Port=COM1

    [3720] 10-03 14:54:22:437: 

    Trying to match the phonebook port in the system ports

    [3720] 10-03 14:54:22:437: Port configured

    [3720] 10-03 14:54:22:437: SetDefaultModemSettings(bps=115200)=1

    [3720] 10-03 14:54:22:437: Reading device group "modem"

    [3720] 10-03 14:54:22:437: Device List after deleting dupe

    [3720] 10-03 14:54:22:437: StringCchCopy failed due to error 0x8007007a

    [3720] 10-03 14:54:22:437: Device List after deleting dupe

    [3720] 10-03 14:54:22:437: ReadRasFile: ReadEntryList returned 0

    [3720] 10-03 14:54:22:437: RASSQM: In ReadPhonebookFile Number of myuse profiles set 1

    [3720] 10-03 14:54:22:437: ReadPhonebookFile returns 0

    [3720] 10-03 14:54:22:437: GetPbkAndEntryName. rc=0x0

    [3720] 10-03 14:54:22:437: looking up subentry 1

    [3720] 10-03 14:54:22:437: IsPublicPhonebook=0

    [3720] 10-03 14:54:22:437: RasCreateConnection...

    [3720] 10-03 14:54:22:437: RasCreateConnection(0) hrasconn=196608, ConnectionAlreadyPresent=0

    [3720] 10-03 14:54:22:437: dwIdleDisconnectSeconds=1200

    [3720] 10-03 14:54:22:437: SaveProjectionResults...

    [3720] 10-03 14:54:22:437: SaveProjectionResults: saving results (dwSubEntry=0)

    [3720] 10-03 14:54:22:437: SaveProjectionResults(0)

    [3720] 10-03 14:54:22:437: GetInstalledProtocolsEx=0xc. 

    [3720] 10-03 14:54:22:437: StartAsyncMachine

    [3720] 10-03 14:54:22:437: InsertAsyncWorkItem: Calling RasEventLogInitialize

    [3720] 10-03 14:54:22:437: InitializeContextQueue: Invalid input parameter

    [3720] 10-03 14:54:22:437: starting subentry 1

    [3720] 10-03 14:54:22:437: SignalDone: pOverlapped=0x2bcbcb4

    [3720] 10-03 14:54:22:437: AppendNewContextToQueue:

    [3720] 10-03 14:54:22:437: AppendNewContextToQueue:Set Event:

    [3720] 10-03 14:54:22:437: RasDialW done(0)

    [2496] 10-03 14:54:22:437: WaitForDialMachineEvent

    [2496] 10-03 14:54:22:437: WaitForDialMachineEvent: event from dial machine

    [2496] 10-03 14:54:22:437: GetOneContextFromQueue

    [2496] 10-03 14:54:22:437: GetOneContextFromQueue: The context is:0x02BCBCB4,type=2

    [2496] 10-03 14:54:22:437: GetOneContextFromQueue: Number of Messages left in the queue is:0

    [2496] 10-03 14:54:22:453: ValidateDmContext:

    [2496] 10-03 14:54:22:453: ValidateDmContext: hrasconn block verification passed

    [2496] 10-03 14:54:22:453: WaitForDialMachineEvent: pOverlapped=0x2bcbcb4, type=2

    [2496] 10-03 14:54:22:453: WaitForDialMachineEvent: Unblock i=1, h=0x2bcbc5c

    [2496] 10-03 14:54:22:453: NotifyCaller(nt=0x2,su=1,s=0,e=0,xe=0)...

    [2496] 10-03 14:54:22:468: NotifyCaller done (dwNotifyResult=1)

    [2496] 10-03 14:54:22:468: GetLogonUser=dpEGE

    [2496] 10-03 14:54:22:468: GetLogonDomain=dpEGE-PC

    [2496] 10-03 14:54:22:468: RASCS_OpenPort

    [2496] 10-03 14:54:22:468: DwOpenPort

    [2496] 10-03 14:54:22:468: DwOpenPort: RasPortOpenEx(Standardní modem 33600 b/s,0)...

    [2496] 10-03 14:54:22:468: DwOpenPort: RasPortOpenEx done(259). Flags=0x2

    [2496] 10-03 14:54:22:468: DwOpenPort done. 633 (dwSavedError 0)

    [2496] 10-03 14:54:22:468: RasDialMachine errors=633,0

    [2496] 10-03 14:54:22:468: RasDialMachine: SignalDone: prasconncb=0x2bcbc50

    [2496] 10-03 14:54:22:468: SignalDone: pOverlapped=0x2bcbcb4

    [2496] 10-03 14:54:22:468: AppendNewContextToQueue:

    [2496] 10-03 14:54:22:468: AppendNewContextToQueue:Set Event:

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: event from dial machine

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue: The context is:0x02BCBCB4,type=2

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue: Number of Messages left in the queue is:0

    [2496] 10-03 14:54:22:468: ValidateDmContext:

    [2496] 10-03 14:54:22:468: ValidateDmContext: hrasconn block verification passed

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: pOverlapped=0x2bcbcb4, type=2

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: Unblock i=1, h=0x2bcbc5c

    [2496] 10-03 14:54:22:468: RasDialTryNextLink...

    [2496] 10-03 14:54:22:468: RasDialTryNextLink: No more links

    [2496] 10-03 14:54:22:468: RasDialTryNextLink done(0)

    [2496] 10-03 14:54:22:468: NotifyCaller(nt=0x2,su=1,s=0,e=633,xe=0)...

    [2496] 10-03 14:54:22:468: NotifyCaller done (dwNotifyResult=0)

    [2496] 10-03 14:54:22:468: Discontinuing callbacks for hrasconn 0x30000

    [2496] 10-03 14:54:22:468: Cleared notifier for hrasconn 0x30000 subentry 1

    [2496] 10-03 14:54:22:468: Quitting s=0,e=633

    [2496] 10-03 14:54:22:468: GetLogonUser=dpEGE

    [2496] 10-03 14:54:22:468: GetLogonDomain=dpEGE-PC

    [3720] 10-03 14:54:22:468: RasHangUpW

    [3720] 10-03 14:54:22:468: IsRasmanServiceRunning=1

    [3720] 10-03 14:54:22:468: IsRasmanServiceRunning=1

    [2496] 10-03 14:54:22:468: Asyncmachine: Cleaning up

    [3720] 10-03 14:54:22:468: (HU) RasFindPrerequisiteEntry, 0x30000

    [3720] 10-03 14:54:22:468: (HU) RasFindPrerequisiteEntry, 0x30000. hConnPrereq=0x0, rc=0

    [3720] 10-03 14:54:22:468: (HUC) RasRefConnection(FALSE), 0x30000 ...

    [3720] 10-03 14:54:22:468: (HUC) RasRefConnection(FALSE), 0x30000. ref=0, rc=0

    [3720] 10-03 14:54:22:468: (HU) RasDestroyConnection(196608)...

    [3720] 10-03 14:54:22:468: (HU) RasDestroyConnection done(668)

    [2496] 10-03 14:54:22:468: RasDialCleanup...

    [2496] 10-03 14:54:22:468: CleanUpRasconncbNode

    [2496] 10-03 14:54:22:468: StopAsyncMachine

    [2496] 10-03 14:54:22:468: (CU) RasProtocolStop...

    [2496] 10-03 14:54:22:468: (CU) RasProtocolStop done

    [2496] 10-03 14:54:22:468: DeleteRasconncbNodeCommon: prasconncb=0x2bcbc50

    [2496] 10-03 14:54:22:468: CloseAsyncMachine

    [2496] 10-03 14:54:22:468: RemoveAsyncWorkItem: Calling RasEventLogUninitialize

    [2496] 10-03 14:54:22:468: FinalCleanUpRasconncbNode: deallocating prasconncb=0x2bcbc50

    [2496] 10-03 14:54:22:468: FinalCleanUpRasconncbNode: 0 nodes remaining

    [2496] 10-03 14:54:22:468: ShutdownAsyncMachine: pOverlapped=0x7364d3a0

    [2496] 10-03 14:54:22:468: AppendNewContextToQueue:

    [2496] 10-03 14:54:22:468: AppendNewContextToQueue:Set Event:

    [2496] 10-03 14:54:22:468: ShutdownAsyncMachine: PostcontextToDialMachine() succeeds!

    [2496] 10-03 14:54:22:468: CleanUpRasconncbNode done

    [2496] 10-03 14:54:22:468: RasDialCleanUp done.

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: event from dial machine

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue: The context is:0x7364D3A0,type=5

    [2496] 10-03 14:54:22:468: GetOneContextFromQueue: Number of Messages left in the queue is:0

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: pOverlapped=0x7364d3a0, type=5

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: OVTEVT_DIAL_SHUTDOWN event received

    [2496] 10-03 14:54:22:468: WaitForDialMachineEvent: Unblock i=1, h=0x2bcbc5c

    [2496] 10-03 14:54:22:468: AsyncMachineWorker:WaitForDialMachineEvent failure:0x3eb

    [2496] 10-03 14:54:22:468: AsyncMachineWorker terminating

    [2496] 10-03 14:54:22:468: CleanUpContextQueue:

    [3720] 10-03 14:54:23:531: RasGetAutodialParamW

    [3720] 10-03 14:54:23:531: RasGetAutodialParamW

    -----------------------------------------------------------------------------------------------

    2. Yes I know. I allways disconnect the COM port and close the terminal.

    3. No bluetooth, no other similar device which could use the COM (I removed the fax too, which is installed by default in the Windows). It is new clean Windows 7 installation.

    4. Yes I know. I think there is some problem between RAS and COM, but it is only my guess...

    5. No corrupted files found. Integrity is OK.

    6. I have used native Windows drivers (running hdwwiz -> modem device -> select "Standard modem 33600 bits per second")

     

    Internal modem diagnostics in device manager is OK too.

    Running Sysinternals Portmon I can't see no log if I try to dial up. 

     

    Tuesday, October 4, 2011 5:29 AM
  • Petr,

    Did you ever solve this problem?  I saw you also asked on the Czech language forum, but it seems the thread was removed.  I'm curious if anything else useful was posted there.

    I am experiencing almost exactly the same problem.  My configuration uses Windows Embedded Standard 7, but I assume all the necessary telephony components are pulled in.  I am connected to the modem manufacturer's development board via a USB to UART IC.  This same configuration connected to my Win 7 desktop works perfectly, so this eliminates the modem hardware as a source of problems.  If I move this exact connection over to WES 7, set up the modem drivers and dial-up settings exactly the same, it no longer works.  I suspect something in the TAPI layer may be wrongly blocking access to the port, so RAS never has a chance to access the HW.

    In any case, once solved, I'll keept this thread up to date.  My next step will probably be a full install of Win 7 on the embedded target.

    Larry Harris

    Wednesday, February 1, 2012 10:37 PM
  • hi i'm experiencing the same error, it's driving me through the wall.

    did you please find any solution for this damn issue?

    Thank you

     
    Wednesday, August 31, 2016 4:58 PM