none
Master Browser not working for NON Windows devices in build 1709 and 1703 RRS feed

  • Question

  • Hello,

    If you are trying to connect from other Windows devices you can ignore this thread - it is ONLY for people with non windows devices such as Oppo BluRay Players, WD, Linux devices etc that rely on the master browser from a Windows Computer to share folders.  IF you have more than one Windows device on your network you can also ignore this as a network with more than one computer may have more than one version of WIndows 10 or 7 etc and the older may be acting as the master browser so your non windows devices can still browse the network neighborhood.

    If you ONLY have one Windows 10 device and it is running 1703 or 1709 you will find out that you can't browse to the SMB shared on your Windows 10 box from a NON Windows box.    So again this excludes people with multiple computers or trying to go from one windows computer to another windows computer - if you have having issues - these are unrelated and this thread won't be able to assist.

    I have verified every combination of registry "fixes" in other threads - NONE Of them work - you won't need to post them here as those "fixes" are not for non-windows devices - they "fix" windows to windows devices.   enabling or disabling windows SMB1/CIFS support and all sub sections will not help.

    Uninstalling your network card and installing the latest drivers will not solve it.  Switching network cards will not solve it - intel, Broadcom, realtek - all have the issue.   

    Resetting your network card will not solve the issue.

    Disabling your firewall will not solve the issue - and that includes any software firewall add ons in addition to windows firewall.  This includes if your PC is on the same switch with no L2/l3 rules/routing - same subnet.

    A fresh vanilla install of windows with NO additional software, firewall disabled, shares set up - will not solve the issue.

    Looking in the mirror and saying candyman 3 times will not solve the issue.

    Turning on and off file sharing does not solve the issue.

    Changing file sharing encryption does NOT solve the issue.

    Changing NetBIOS settings does NOT solve the issue.

    Kb4025342 does NOT fix the issue.

    Running powershell - Set-SmbServerConfiguration -EnableSMB1Protocol $true  Does not fix the issue - yes as administrator.

    It is NOT and IPv4 or IPV6 issue, subnet issue, or silent number in the address.

    THis is a problem with Windows 1703 and 1709 that hasn't been fixed yet.   I notified MS when 1703 was in testing phase.  Applied all the updates during its entire cycle - NO FIX.   This is NOT I repeat NOT an SMB1 being enabled or disabled issue.  No lanman SMB1 registry item is a FIX.   So to sum it up this is a MASTER BROWSER issue.

    Yes network discovery is enabled - it works with every upgrade of Windows 10 until you get to 1703 and 1709.

    Starting services such as peer... homegroup... does NOT fix the issue.

    Another person says the contacted MS about this with 1703 and MS said they know there is an issue - no updates on this yet.

    If you think you've solved the issue - you are either running from windows to windows or you have more than one windows PC on the network and the other computer is the master browser or you've managed to get your netgear to act as the master browser.   There is no fix for just a dumb switch, a single windows PC and a non windows device.





    • Edited by boe_d Tuesday, November 7, 2017 11:31 PM
    Friday, October 20, 2017 5:08 PM

All replies

  • This is an excellent explanation of an inexplicable problem.

    I am not an expert but I have been using Windows since version 1 and know enough about it to understand the frustration that users have to endure. 

    Regarding this issue, all I want to be able to do is connect my Android devices to my Windows 10 PCs and play my music and video collections on them.

    Using ES File Explorer I can see all the folders and disks on the network but none of them will open except the "Users" folder on the PC. I have folders in the users folder, one of which is called "Public" and in this folder I have a folder called "Videos" containing a video file. I can play this on my tablet. Problem solved?

    Up to a point, but I don't want to have to copy gigabytes of video and music to this folder.

    So, if I can "see" the public folder and its contents from my tablet, why can't I do the same with the others?
    Tuesday, October 24, 2017 6:05 AM
  •  @boe_d

        That is a pretty accurate description. I agree that it is a problem with the computer browser service in version 1703 and 1709. And I agree that the only real solution is to force some other device to be the master browser.

      I would not hold my breath waiting for a fix from Microsoft. Probably there is nobody still there who really understands how the computer browser service works, even if they were interested. The documents have not been updated for years and SMB 1.0 is now disabled by default so that the computer browser service does not even appear (and as you say, enabling the computer browser service on Windows 1703 or 1709 is a waste of time anyway).

      The basic problem is that this system is well past its use by date (it ceased to be relevant to domain users when Active Directory started using DNS instead of NetBIOS over TCP/IP in Windows 2000), but nobody at Microsoft or anywhere else has come up with a replacement. Microsoft is not really interested because none of its supported systems still rely on it. Windows 7 or later can use network discovery and IPv6 or homegroups. XP and earlier are no longer supported. It is only third party devices using SMB/Samba or pre-Windows 7 which still rely on SMB 1.0 and the computer  browser service.

    @fangman69

      Sharing of public files has always been a separate function from other forms of file sharing.


    Bill

    Tuesday, October 24, 2017 6:51 AM
  • I have a WDTV that stopped working after 1703 and am looking for solutions.  I'm thinking of replacing the WDTV with something else.  Does this mean that Android TV/Android boxes what use Kodi wouldn't work either if the files are shared on a single 1703/1709 PC?

    Tuesday, October 24, 2017 7:58 PM
  • @boe-d

      The only solution I can come up with is to run some other OS in a virtual machine to act as the master browser. I don't have a NAS but I do have a network drive shared through my router which has the network name readyshare. This can be seen by XP but not normally by Windows 10.

      As a test I have XP running as a vm (using VirtualBox) with 512Mb of memory running the computer browser service. The Windows 10 host running version 1709 has SMB 1.0 and NetBIOS over TCP/IP enabled but the computer browser service disabled. It looks promising. The Windows 10 machine can now see and access readyshare from the Network display.

    BOB & LOTTIE2 are two other physical Windows 10 machines running on the network. They do not see the XP vm or readyshare because they do not have SMB 1.0 or NetBIOS over TCP/IP enabled.


    Bill

    Wednesday, October 25, 2017 1:57 AM
  • @boe-d

      The only solution I can come up with is to run some other OS in a virtual machine to act as the master browser. I don't have a NAS but I do have a network drive shared through my router which has the network name readyshare. This can be seen by XP but not normally by Windows 10.

      As a test I have XP running as a vm (using VirtualBox) with 512Mb of memory running the computer browser service. The Windows 10 host running version 1709 has SMB 1.0 and NetBIOS over TCP/IP enabled but the computer browser service disabled. It looks promising. The Windows 10 machine can now see and access readyshare from the Network display.

    BOB & LOTTIE2 are two other physical Windows 10 machines running on the network. They do not see the XP vm or readyshare because they do not have SMB 1.0 or NetBIOS over TCP/IP enabled.


    Bill

    Yeah I thought of going that route but it is just so freaking stupid when MS makes us do something like that.    It is like when they say use powershell and try to remember this 256 character arcane summoning spell because it is much easier than using a gui and clicking on a check box.

    I'd be happy if someone like the developers of classicshell made something to replace the native master browser.    Everytime MS takes a step forward they feel compelled to take a step back and we have to hope that someone like classicshell is there to pick up the debris that MS leaves in its path to the next OS.

    • Edited by boe_d Thursday, October 26, 2017 6:08 AM
    Thursday, October 26, 2017 6:05 AM
  •   I agree that the developers seem fascinated with the command line for a system called Windows.

       You should not need the computer browser service for a setup like yours with only two devices. The network location of your NAS isn't going to change. If you can manage to see the NAS in a browser list once, you can pin it to Start and never need the browser service again.

      I would not hold my breath waiting for a third party to develop a replacement for the SMB browser service.

     


    Bill

    Thursday, October 26, 2017 10:50 PM
  • I do not have a NAS. I have an Oppo 4K BD player.   It doesn't let you pin things. It doesn't let you pick IPs it only gets names from the master browser and then you click on that list and enter your info. It does not save locations, only security info. Oppo is unlikely to change this method of access.
    • Edited by boe_d Friday, October 27, 2017 1:02 AM
    Friday, October 27, 2017 1:01 AM
  • I have to ask, are all your devices on the same subnet?

    Jack

    Friday, October 27, 2017 1:07 AM
  • I do not have a NAS. I have an Oppo 4K BD player.   It doesn't let you pin things. It doesn't let you pick IPs it only gets names from the master browser and then you click on that list and enter your info. It does not save locations, only security info. Oppo is unlikely to change this method of access.

      Sorry about that. It was another poster who was having problems with a NAS. Looks like a different machine (virtual or physical)  as the master browser is your only option.


    Bill

    • Proposed as answer by Aironman Friday, October 27, 2017 4:32 AM
    • Unproposed as answer by Aironman Friday, October 27, 2017 4:32 AM
    Friday, October 27, 2017 1:41 AM
  • Yes - same subnet - dumb switch - if you look at the first post you'll find that that and many more things are covered that people think will solve the issue - and they might between two windows devices but this is strictly about the master browser issue in the newer versions of window which work fine with the previous versions.
    Friday, October 27, 2017 1:29 PM
  • To see if I have this, if I were to setup 3 Windows 10 1709 non-domain joined workstations on the same subnet, with no other devices present on that subnet, none of them should elect themselves to be the segment master browser? In effect, peer networking (by browsing "network") shouldn't show anything, is that correct? Also, you didn't mention it but I assume you have turned on "Network Discovery"?

    Jack

    Friday, October 27, 2017 8:39 PM
  •   If they are all Windows 10 machines they have no need of the computer browser service, and in fact probably don't even have it running, because SMB 1.0 is disabled by default in version 1709.

      The only people who see this problem are those using devices which depend on the (very old) method of network browsing from NT days, which depends on SMB 1.0 and NetBIOS over TCP/IP and IPv4. Windows 7, 8 and 10 use network discovery and IPv6.

     


    Bill

    Saturday, October 28, 2017 1:51 AM
  • The Computer Browser service is broken in Windows 10 1703 and is gone from future releases of Windows.  The below really applies for workgroups you may find info that helps with your issue, you should be able to remove all trace of SMB v1.0 from your network.

    Yes, that's right folks, after 25 years of being able to browse our networks Microsoft have decided Workgroup users don't need this functionality any more.  This article from Microsoft explains:

    SMBv1 is not installed by default in Windows 10 Fall Creators Update 2017 and Windows Server, Semi-annual Channel

    They are getting rid of SMB v1.0, which is fair enough, it has real security issues.  The Computer Browser service relies on SMB v1.0, rather than upgrade the Computer Browser service so Workgroup users are still able to browse their networks they are simply removing it.  From the linked article:

    For home and small business users who use Network Neighborhood to locate Windows computers, you shoud map drives to the computers so that you no longer have to browse for them.

    Not even spell checked and suggesting we only do it to access data we could map drives to, indicating a total lack of understanding as to why we need network browsing.  Network browsing is an essential tool for doing a visual check of which computing resources are available in a Workgroup.  The command "net view" allows us to quickly report which computers are available in the Workgroup and thereby use the information to run system reports and perform various tasks.  Locating and enabling printers becomes far more difficult without Computer Browsing.

    This does not affect AD users, those businesses which need to or have the luxury of being able to invest in server hardware and software.  Users who's data is in the cloud, on the internet have less issue, it may only affect attaching printer resources which can be worked around.  Of course all Microsoft staff fit into these groups so the lack of browsing functionality in Workgroups is probably insignificant to them.

    So what we need now is either a great little tool to browse our networks that doesn't rely on SMB 1.0 or an upgraded Computer Browser service.

    The service is broken in Windows 10 Creators 1703. If a 1703 PC is the Master Browser only that computer has Computer Browsing, if a non-1703 is the Master Browser all the non-1703 PCs have Computer Browsing.  This is the reason why browsing appears to work sometimes and not others, rebooting PCs forces a Master Browser election, which will change which PC is the Master Browser and can introduce the issue.

    To work around the issue involves setting one computer to be the Master Browser.  Some people have third party devices on their network they can set to be the Master Browser, all non-1703 can browse.  To identify which computer is the Master Browser you can run the command 

    nbtstat -a ComputerName

    for each computer in the Workgroup.  The computer that is the Master Browser is the only one that has the value

    __MSBROWSE__

    in the list.

    To set which computer is the Master Browser you need to make registry modifications on that computer.  Browse to the registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters

    Change the value of MaintainServerList from Auto to Yes

    If it is not there, add a new String Value IsDomainMaster and set it to True

    You may need to reboot to activate this.  If you want to be absolutely positive no other PC takes the Master Browser role you can set the value of MaintainServerList from Auto to No on all other PCs in the Workgroup.  You may even find that a non Microsoft third party device on the network attempts to take over the Master Browser role.

    I re-iterate that this is just a short term workaround, Computer Browsing for workgroups is history for Windows 10.  If you know of any great tools for browsing Workgroups that don't rely on the older protocols I'd be happy to hear from you.

    Saturday, October 28, 2017 6:27 AM
  • I don't know what vengeful god I just pissed off but this evening I got an update notice (NOT SAYING EXACTLY WHAT IT WAS UPDATING) but it popped up while I was typing and as a result I accidentally hit OK.    Now my computer was inaccessible for about 30 minutes while it applied updates (NO CANCEL OPTION) just saying your computer will be f'd up for life if you try to power it off.

    After an eternity of waiting of waiting it finally lets me log in only to say "Hi, we are finishing taking a dump on your computer this could take a few minutes."

    Now I'm stuck with this POS, worthless turd of an OS (Windows 10 1709) without a working master browser.    Thanks LOADS MS - so worth it to give up streaming to my bluray player so that I can have a "better" stick painting program that I'll never use.

    Why isn't there a simple option during the "update" process where you can please don't f' with my good OS by throwing that abortion of an OS on my computer.   Is Ballmer back in charge of MS?   This seems like the sort of stunt he would pull during his notorious administration at the helm of MS when he tried to force vista on the masses even if they wanted XP on their computers.

    I tried the rollback from settings and now my computer is unusable - can't open IE, Edge, Chrome, regedit, settings...   Thanks MS.    I think I'll go to the nearest food truck not rated for health reasons, eat 7 lbs of the Mexican Fiesta Surprise - go to Satya Nadella's house, break in pull down my pants and leave explosive diarrhea skid marks on every carpet and textured surface I can find including his fridge crisper.   If he gets upset I'd say I thought you'd like the skid features of your improved home.  No - just hire a cleaning service and rollback to the previous version.    Sorry I didn't make it easier for you to just say no to the "upgrade" in advance.

    The new Fall Update / FU addition of Windows make me start to appreciate why so many people are so in love with OSX.

    • Edited by boe_d Thursday, November 16, 2017 4:18 PM
    Thursday, November 16, 2017 6:49 AM
  • I also use a virtual machine to have the computer browser back.

    But I use a windows 10 x86 machine!!!!

    The computer browser works fine on Windows 10 1709-x86 not on x64

    !!!

    Thursday, December 28, 2017 11:16 AM
  • Hi Boe,
    Hi guys,
    dunno if you are still struggling with the issue, I would advice to have a look at these two link if they match what you are facing and if the workaround will help you

    Products requiring SMB1 (Jun 2017)
    https://blogs.technet.microsoft.com/filecab/2017/06/01/smb1-product-clearinghouse/

    How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server
    https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

    SMBv1 Not installed on W10 and W server version 1709
    https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

    Hope it helps

    Best regards


    Matteo Stagni

    Monday, January 8, 2018 11:20 AM
  • Hello!

    Another idea: there is a service Upnp in windows, maybe your device can do this protocol? AFAIR native media player streaming works on it, you could try to poke around starting service and some media servers on your 1709 PC.


    http://about.me/bromi

    Monday, January 22, 2018 11:23 AM
  • AGAIN - TO BE CLEAR - the issue is not SMB - let's try it again the issue is not SMB - SMB 1.0, 2.0, 3.0... 17.8876 is NOT the issue - let's hear it from the crowd, let's all say it together SMB versions is NOT THE ISSUE.

    The issue is what device acts as the MASTER BROWSER.  I don't know how many time someone who doesn't take 5 seconds to read the post is going to say - oh turn on SMB 1.0 or the problem is your device doesn't handle the new version of SMB.   It doesn't matter if SMB 1.0 is secure or not secure - it isn't the problem - the issue is the master browser - use SMB 52.0 when it comes out - it won't fix the issue - again the issue is the master browser not an old or new version of SMB.

    I''ll say it again the issue is the MASTER BROWSER.   MAS - TER.... BROWS... ER   Master Browser.   Try it again MASTER BROWSER.

    If you let a netgear box capable of being the master browser be the MASTER BROWSER, than your WIndows 10 CU and newer shares work fine.   If you let a Windows 7 box be the master browser than your Windows 10 UC box or newer will share fine.   If you run a VM with an older version of windows and make it the master browser, than the shares on the newer Windows 10 box work fine - THI IS NOT AN SMB issue - otherwise the shares COULD NOT WORK.   The ISSUE is the MASTER BROWSER.   MAS-TER BROWS-ER.   Say it - SAY IT! 

    I'm hoping that helps you understand the source of the issue - if you've forgotten it is the master browser.   I swear I'll raise the spirit of Sam Kinison to scream it in your ear if you haven't gotten it by now.

    I wish I was part of the partner program so I could slap Tommy around until he actually tried the issue on a non- windows device - tell me no one at MS owns a non-windows device

    https://partnersupport.microsoft.com/en-us/par_clientsol/forum/par_win/since-win10-creators-update-unable-to-do-net-view/9e9b5df5-e4b0-4c2f-8df2-c06e3ab08363?page=2

    Saturday, March 24, 2018 5:07 PM
  • How about you stop a rant and learn to read a bit too? Newest build of windows literally cant be the problem with master browser, cos, lol, the service of browser itself gets autodeleted after smb1.0 is gone. And guess why? Cos there is no such thing as master browser in new smb. So yes, it is an smb version issue. Windows 1709+ wont mess with your nonwindows master browser, hooray, its abilty to is simply gone. Happy?

    http://about.me/bromi

    Saturday, March 24, 2018 11:48 PM
  • How about you read a bit - if you let something else be the master browser - the shares work! So again - it is a master browser issue.
    Sunday, March 25, 2018 4:11 PM
  • Of course they work. Why won't they, they would work even without browser at all.

    What I was saying, is that Master browser is a part of ONLY smb 1.0, and if you use the 1709 build, which _autodeletes_, the ANY ability to participate in smb1.0 browsing (be it as a master browser, or as a client of 'net view' command) will be gone. So your problem is 'solved' -- there is no anymore ability of 1709+ to be a master browser (in default settings). And MS won't fix the code for a feature which will NOT be available anymore.

    See what I'm saying? That's why in a first comment I offered you ANOTHER browsing solution which would be possible to use on non-windows device (maybe). Forget about master browser, howewer much time you repeat, its days in windows are gone.


    http://about.me/bromi

    Sunday, March 25, 2018 9:22 PM
  •   You are certainly correct on one point. As far as Microsoft is concerned, the computer browser service is dead (and not before time). It might still be in the code, by nobody there is really interested in it. No supported Windows OS requires it (XP was the last) and it won't run without SMBv1, which Microsoft is trying hard to persuade people to give up.

      If you really need that sort of browsing, a Samba server is the best bet. Just remember that any device which still uses SMB 1.0 and has an Internet connection is at risk.

      


    Bill

    Monday, March 26, 2018 12:09 AM
  • I get what you are saying however there are many of us with environments where SMB security risk is not a risk who want it - e.g. home environment with WD, OPPO and other non windows devices that need computer browser. MS may not want to support it anymore but it would be nice if they gave you an option to enable it.
    Monday, March 26, 2018 1:59 AM
  •    They still give you the option to enable SMB 1.0. It works fine with a non-Windows 10 browse master. I would not hold my breath waiting for a fix of the computer browser service in Windows 10. It simply has zero priority for them.

      I just wish that the "new" discovery method that replaced the computer browser service from Vista on was a bit more robust and reliable.


    Bill


    • Edited by Bill Grant Monday, March 26, 2018 5:18 AM
    Monday, March 26, 2018 5:15 AM
  • It is obvious that MS is actively disabling more and more netbios ability in Windows 10 and Windows 2016 in favor of WSD. Throwing away the protocol just because of IPv6 is just lazy programmers.

    I tried to enable the master browser in my ReadyNAS and I still could not see all the network devices. I do have some workarounds for now, but not sure how long these will work.

    The real issue here is that there are many programs that require netbios to function. What we really need is an aftermarket product that can keep the browser activity on the network. I would buy it in a heartbeat and I hope someone comes out with it before MS totally eliminates netbios. Which I feel is very soon.

    Monday, April 9, 2018 10:45 PM
  • Having experienced this issue with several clients on several different networks I agree with the original poster's conclusion.

    It is the Master Browser selection that causes the problem, regardless of SMB.

    If an up to date Windows 10 PC is in your workgroup then there is always a chance that it will be elected as the Master Browser at some point, in which case "Network Neighborhood" will stop working. This can even happen randomly, after the network has been working perfectly for some time, since the Master Browser elections occur dynamically.

    The only way I have found to workaround this is as follows - 

    1. Prevent all Windows 10 PCs from becoming the Master Browser
    2. Have another device on your network than can become the Master Browser

    You can achieve (1) by using the registry edit mentioned above and setting MaintainServerList to No

    The second option depends on the other devices available on your network. Some routers will adopt this role automatically, and some NAS devices will also do this. If there is no other suitable device then you are stuck.

    You can still navigate the network by entering the PC names manually (e.g. \\MY-PC2 in the File Explorer address bar) and you can still use drive mappings by entering the share name manually (e.g.  \\MY-PC1\Share) but you won't be able to browse to the share.

    Thursday, April 12, 2018 12:28 PM
  • I found a way around MS's master browser issue for the Oppo thanks to Bill's post on avsforum.  Running winnfsd let's you share folders to my non windows device very simply with virtually no overhead compared to running another virtual machine or another device to be the master browser.

    I wouldn't recommend this for people who aren't behind a firewall but if it is in a secured environment it only takes a couple of minutes to deploy and you get back what MS broke.

    • Edited by boe_d Friday, September 7, 2018 6:13 PM
    Friday, September 7, 2018 6:11 PM