locked
After I change the WSUS default port 8530 to 80. I can't connect to the WSUS console. RRS feed

  • Question

  • I have windows server 2012 r2  installed with WSUS using port 8530 as default.  And I ran the command 'C:\Program Files\Update Services\Tools\WSUSutil usecustomwebsite false' . After that the default port has changed from 8530 to 80. UnfortunatelyI found that I can't  connect  to the WSUS console any more .  Only if I reset the IIS  ,I can  connect to the WSUS console again. But it just continued for about one minute.

    • Moved by Garth JonesMVP Sunday, February 26, 2017 3:54 PM Not a CM07 Q
    Tuesday, December 8, 2015 7:57 AM

All replies

  • and  here is the log

    The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

    Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.

    System.AppDomainUnloadedException -- Attempted to access an unloaded AppDomain.

    Source

    MMCFxCommon

    Stack Trace:

       at Microsoft.ManagementConsole.Internal.ISnapInPlatform.ProcessCommand(Command command)

       at Microsoft.ManagementConsole.NodeSyncManager.OnNodeChanged(Object sender, NodeChangedEventArgs e)

       at Microsoft.ManagementConsole.Node.NodeChangedEventHandler.Invoke(Object sender, NodeChangedEventArgs e)

       at Microsoft.UpdateServices.UI.SnapIn.Scope.BaseScopeNode.ClearActionsPaneActions()

       at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ShowUnhandledErrorMessage(ErrorOccurredEventArgs e)

       at System.EventHandler`1.Invoke(Object sender, TEventArgs e)

       at Microsoft.UpdateServices.UI.AdminApiAccess.ErrorManager.ReportUnhandledError(Exception ex, Object errorContext)

       at Microsoft.UpdateServices.UI.SnapIn.Pages.ComputersListPage.GetListScope()

       at Microsoft.UpdateServices.UI.SnapIn.Pages.BaseListPage.RefreshScope()

       at Microsoft.UpdateServices.UI.SnapIn.Pages.BaseListPage.Initialize(FormView thisScope)

    • Proposed as answer by WichardHartes Tuesday, November 1, 2016 10:50 AM
    • Unproposed as answer by Garth JonesMVP Saturday, November 19, 2016 3:09 PM
    Tuesday, December 8, 2015 7:59 AM
  • port 8530 is the recommended setting (this is also the default).

    I would recommend you leave it on port 8530, unless you need to implement SSL (use 8531 for SSL).

    Only older WSUS defaults to port 80..


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Tuesday, December 8, 2015 9:17 AM
  • Is this a CM07 question or strait WSUS question?

    Garth Jones | My blogs: Enhansoft and Old Blog site | Twitter: @GarthMJ

    Tuesday, December 8, 2015 11:45 AM
  • I deleted the wsus file under %appdata%\Microsoft\MMC\.

    That worked! Thanks very much,

    Richard.

    Tuesday, November 1, 2016 10:50 AM
  • Hi Aspirin_Yu,

    Just to check if you get any progress with the issue? Could the above reply be of help, if yes, you may mark useful reply as answer, if not, welcome to feedback.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 27, 2017 7:21 AM