locked
User access denied, sharepoint 2010 foundation and Service manager 2012 r2 RRS feed

  • Question

  • Hi,

    i have been struggling with giving users permissions to access the self service portal.

    I have checked permissions on the site a million times. I have done inheriting and individual, still no luck.

    I have checked the site contents and gone through every single item and checked and made sure the permissions were present for them. still no luck.

    I have restarted the server (three times) lol. still no luck.

    The user account who installed the service manager has permissions but no one else can log in.

    When I go to the site and get into permissions section and do a check permission, the result is "user has permission via ...." which is what should be based on permissions i have set, but when the user tries to log in, it still says "access denied".

    I really need to get this running or else I am going to be force to look for other solutions like zendesk and all. I really want this to work. Please help.

    Thanks,

    Thursday, October 2, 2014 4:36 AM

Answers

  • Hello !

    You may need to add your users to the "end user" group, on Service manager console : administration tab --> User Roles.

    Description : End users can use the self-service portal to create incidents, request a software installation, display ads and search the Knowledge Base.

    Hope this helps.



    Note: This posting is provided 'AS IS' with no warranties or guarantees, and confers no rights. Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable. This helps the community, keeps the forums tidy, and recognises useful contributions.


    • Edited by Matthias CECILLON Thursday, October 2, 2014 7:51 AM correct
    • Marked as answer by Atif7865 Wednesday, October 8, 2014 9:13 PM
    Thursday, October 2, 2014 7:51 AM

All replies

  • Hello !

    You may need to add your users to the "end user" group, on Service manager console : administration tab --> User Roles.

    Description : End users can use the self-service portal to create incidents, request a software installation, display ads and search the Knowledge Base.

    Hope this helps.



    Note: This posting is provided 'AS IS' with no warranties or guarantees, and confers no rights. Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable. This helps the community, keeps the forums tidy, and recognises useful contributions.


    • Edited by Matthias CECILLON Thursday, October 2, 2014 7:51 AM correct
    • Marked as answer by Atif7865 Wednesday, October 8, 2014 9:13 PM
    Thursday, October 2, 2014 7:51 AM
  • I had authenticated users in the list. I just added my "Domain\Domain Users" to it as well.

    But I am still getting the same error.

    Please Help

    Thursday, October 2, 2014 1:45 PM
  • any ideas? anyone?

    Thursday, October 2, 2014 7:52 PM
  • Is it the SharePoint access denied or the IIS services access denied (Web 401 error)?
    Friday, October 3, 2014 6:11 PM
  • The error I get is this one:

    <fieldset>

    403 - Forbidden: Access is denied.

    You do not have permission to view this directory or page using the credentials that you supplied.

    </fieldset>

    I think I should mention that I have changed the URL to a simpler one, instead of using the serverFQDN:444/smportal it is helpdeskURL. 

    Saturday, October 4, 2014 5:30 AM
  • Are you using a separate service account to run the ISS App Pools for the portal?  If you are, try switching them all to run under you Service Manager workflow service account.  That is what it took to get my portal to finally run as it was impossible to track down where in the Cmdb permissions were getting denied.
    Monday, October 13, 2014 1:44 PM