locked
App-V sequenzing Outlook 2003 - Mapi32.dll Error RRS feed

  • Question

  • Hi,

    I've installed a App-V Server and a App-V client. Both on a Win 2k8 R2.

    I sequenzed a new Applications: Firefox, Word 2003, Excel 2003, Notepad++ and Outlook 2003. The programs appear on clientside after sequenzing and deploying on the App-V server. On the Client all programms work correct except Outlook 2003. If I try to start Outlook 2003 the programm starts only a popup with an Error: Mapi32.dll is corrupt or the wrong version.

    I tried to sequenz Outlook again but the problem is still there. On the Server Outlook starts without any trouble in the Application Test after sequenzing.

    I had a look to the eventviewer but nothing special - I tried to set App-V logging to verbose but nothing special in it. Communication and loading seams to work correct - by the way all other applications work flawlessly. The mapi32.dll in c:\windows\system32\ is the same Version on both systems.

    You got an idea where to look next? Anybody with a similar error on mapi32.dll and Outlook2003? Thank you for your efforts. Windows Updates are installed and sequenzer is in Version 4.6.0.20200.

    Monday, September 19, 2011 2:09 PM

Answers

  • hello,

    thank you very much! I got it. I installed the sequenzer on a fresh system and did not lunch Outlook after sequenzing. After copying files to the server everything worked fine. thanks for your help!

    greets from Germany,

    Alex

    • Marked as answer by de.cyberalex Friday, September 30, 2011 4:06 PM
    Friday, September 30, 2011 4:02 PM
  • Hello,

    Package-test doesn't really exist - everything is included in the actual capture.

    Resequence the application and avoid starting Outlook at anytime


    /Znack
    • Marked as answer by de.cyberalex Friday, September 30, 2011 4:06 PM
    Friday, September 30, 2011 1:28 PM

All replies

  • Monday, September 19, 2011 2:42 PM
  • hello,

    thank you for the links.

    I renamed all mapi32.dll files according to the kb article , but the same error occurs. There is no installer lunched nor another error is appears. I had a look to the osd package and no mapi32.dll is in the virtual filesystem - so there should be no mapi32.dll on the client system now. I tried to restart the client to avoid a dll is still in memory but same result -  Mapi32.dll is corrupt or the wrong version.

    Tuesday, September 20, 2011 8:50 AM
  • Hello,

    Is there a mapi32.dll on the client-system?
    /Znack
    Tuesday, September 20, 2011 9:08 AM
  • hello,

     

    no. I renamed all versions of mapi32.dll according to http://support.microsoft.com/kb/195752 but the error still occurs. I also rebooted the system.

    Then I tried to rename the mapi32.old which is in c:\windows\system32\ back to mapi32.dll the same error occours. It is the same dll version as on the server system in the system32 directory.

    Tuesday, September 20, 2011 10:01 AM
  • Hello,

    Where is MAPI32.dll - which Outlook loads - located according to Process Monitor?
    /Znack
    Tuesday, September 20, 2011 10:47 AM
  • hello,

    there is no MAPI32.DLL loaded. I got Listdlls from sysinternals and there is no MAPI32.DLL loaded for OUTLOOK.EXE neither for any process.

    OUTLOOK.EXE pid: 5856
    Command line: "Q:\outout\OFFICE11\OUTLOOK.EXE"
    
    Base                Size      Path
    0x0000000030000000  0x31000   Q:\outout\OFFICE11\OUTLOOK.EXE
    0x0000000077210000  0x1a9000  C:\Windows\SYSTEM32\ntdll.dll
    0x0000000074c50000  0x3f000   C:\Windows\SYSTEM32\wow64.dll
    0x0000000074bf0000  0x5c000   C:\Windows\SYSTEM32\wow64win.dll
    0x0000000074bb0000  0x8000    C:\Windows\SYSTEM32\wow64cpu.dll
    0x0000000030000000  0x31000   Q:\outout\OFFICE11\OUTLOOK.EXE
    0x00000000773f0000  0x180000  C:\Windows\SysWOW64\ntdll.dll
    0x00000000766f0000  0x110000  C:\Windows\syswow64\kernel32.dll
    0x0000000076060000  0x46000   C:\Windows\syswow64\KERNELBASE.dll
    0x0000000074b90000  0x18000   C:\Windows\SysWOW64\tsappcmp.dll
    0x00000000763a0000  0xac000   C:\Windows\syswow64\msvcrt.dll
    0x00000000765f0000  0x100000  C:\Windows\syswow64\USER32.dll
    0x0000000075290000  0x90000   C:\Windows\syswow64\GDI32.dll
    0x0000000076fe0000  0xa000    C:\Windows\syswow64\LPK.dll
    0x0000000076890000  0x9d000   C:\Windows\syswow64\USP10.dll
    0x00000000769c0000  0xa0000   C:\Windows\syswow64\ADVAPI32.dll
    0x0000000076ea0000  0x19000   C:\Windows\SysWOW64\sechost.dll
    0x0000000076a60000  0xf0000   C:\Windows\syswow64\RPCRT4.dll
    0x0000000074f50000  0x60000   C:\Windows\syswow64\SspiCli.dll
    0x0000000074f40000  0xc000    C:\Windows\syswow64\CRYPTBASE.dll
    0x0000000075100000  0x15c000  C:\Windows\syswow64\ole32.dll
    0x00000000760b0000  0x60000   C:\Windows\SysWOW64\IMM32.DLL
    0x0000000076270000  0xcc000   C:\Windows\syswow64\MSCTF.dll
    0x0000000074b50000  0x3e000   C:\PROGRA~2\Citrix\System32\mfaphook.dll
    0x0000000074b00000  0x46000   C:\Program Files (x86)\Citrix\system32\mmhook.dll
    0x0000000076800000  0x5000    C:\Windows\syswow64\PSAPI.DLL
    0x0000000074ae0000  0x16000   C:\Program Files (x86)\Citrix\system32\cutildll.dll
    0x0000000074a40000  0x9b000   C:\Windows\WinSxS\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d09154e044272b9a\MSVCR80.dll
    0x0000000075070000  0x8f000   C:\Windows\syswow64\OLEAUT32.dll
    0x0000000074a20000  0x11000   C:\Windows\SysWOW64\NETAPI32.dll
    0x0000000074a10000  0x9000    C:\Windows\SysWOW64\netutils.dll
    0x00000000749f0000  0x19000   C:\Windows\SysWOW64\srvcli.dll
    0x00000000749e0000  0xf000    C:\Windows\SysWOW64\wkscli.dll
    0x00000000749d0000  0xf000    C:\Windows\SysWOW64\SAMCLI.DLL
    0x00000000749a0000  0x22000   C:\Windows\SysWOW64\LOGONCLI.DLL
    0x0000000074990000  0xd000    C:\Windows\SysWOW64\WTSAPI32.dll
    0x0000000074980000  0xd000    C:\Program Files (x86)\Citrix\system32\ctxwsapi.dll
    0x0000000074970000  0x8000    C:\Windows\SysWOW64\Secur32.dll
    0x0000000074930000  0x35000   C:\Windows\SysWOW64\ACTIVEDS.dll
    0x00000000748f0000  0x34000   C:\Windows\SysWOW64\adsldpc.dll
    0x0000000076220000  0x45000   C:\Windows\syswow64\WLDAP32.dll
    0x00000000748d0000  0x14000   C:\Windows\SysWOW64\ATL.DLL
    0x00000000748a0000  0x27000   C:\Program Files (x86)\Citrix\system32\Sfrhook.dll
    0x00000000747e0000  0xbf000   C:\Program Files (x86)\Citrix\system32\scardhook.dll
    0x00000000746c0000  0x115000  C:\Program Files (x86)\Citrix\system32\twnhook.dll
    0x00000000746a0000  0x19000   C:\Program Files (x86)\Citrix\system32\cxinjime.dll
    0x000000006d3f0000  0x10a000  C:\Windows\SysWOW64\sftldr_wow64.dll
    0x00000000723e0000  0x17000   C:\Windows\SysWOW64\USERENV.dll
    0x0000000073ce0000  0xb000    C:\Windows\SysWOW64\profapi.dll
    0x0000000070410000  0x19e000  C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.7601.17514_none_41e6975e2bd6f2b2\COMCTL32.dll
    0x0000000076340000  0x57000   C:\Windows\syswow64\SHLWAPI.dll
    0x0000000075340000  0xc4a000  C:\Windows\syswow64\SHELL32.dll
    0x0000000002570000  0x736000  Q:\outout\OFFICE11\OUTLLIB.dll
    0x000000006efb0000  0x4c000   C:\Windows\SysWOW64\apphelp.dll
    0x00000000666b0000  0x8d000   C:\Windows\AppPatch\AcLayers.DLL
    0x0000000072400000  0x51000   C:\Windows\SysWOW64\WINSPOOL.DRV
    0x00000000713f0000  0x12000   C:\Windows\SysWOW64\MPR.dll
    0x00000000661c0000  0x7b000   C:\Windows\AppPatch\AcSpecfc.DLL
    0x0000000071990000  0x84000   C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.7601.17514_none_ec83dffa859149af\COMCTL32.dll
    0x000000006d2e0000  0x79000   C:\Windows\SysWOW64\mscms.dll
    0x0000000072050000  0x32000   C:\Windows\SysWOW64\WINMM.dll
    0x00000000660d0000  0xe7000   C:\Windows\SysWOW64\DDRAW.dll
    0x00000000666a0000  0x6000    C:\Windows\SysWOW64\DCIMAN32.dll
    0x0000000076450000  0x19d000  C:\Windows\syswow64\SETUPAPI.dll
    0x0000000075040000  0x27000   C:\Windows\syswow64\CFGMGR32.dll
    0x0000000075320000  0x12000   C:\Windows\syswow64\DEVOBJ.dll
    0x000000006d1d0000  0x13000   C:\Windows\SysWOW64\dwmapi.dll
    0x0000000076810000  0x7b000   C:\Windows\syswow64\COMDLG32.dll
    0x0000000075f90000  0x35000   C:\Windows\syswow64\WS2_32.dll
    0x0000000076210000  0x6000    C:\Windows\syswow64\NSI.dll
    0x0000000074360000  0x240000  C:\Windows\SysWOW64\msi.dll
    0x0000000065eb0000  0x218000  C:\Windows\AppPatch\AcGenral.DLL
    0x000000006d870000  0x80000   C:\Windows\SysWOW64\UxTheme.dll
    0x0000000066f70000  0x14000   C:\Windows\SysWOW64\MSACM32.dll
    0x00000000745a0000  0x9000    C:\Windows\SysWOW64\VERSION.dll
    0x0000000066630000  0x3000    C:\Windows\SysWOW64\sfc.dll
    0x0000000066620000  0xd000    C:\Windows\SysWOW64\sfc_os.DLL
    0x0000000076d50000  0x137000  C:\Windows\syswow64\urlmon.dll
    0x0000000076110000  0xf5000   C:\Windows\syswow64\WININET.dll
    0x0000000076b50000  0x1fe000  C:\Windows\syswow64\iertutil.dll
    0x0000000076ec0000  0x11d000  C:\Windows\syswow64\CRYPT32.dll
    0x00000000773c0000  0xc000    C:\Windows\syswow64\MSASN1.dll
    0x00000000745f0000  0xad000   C:\Program Files (x86)\Citrix\system32\ctxsbxhook.dll
    0x00000000745b0000  0x3a000   C:\Program Files (x86)\Citrix\system32\RADEAPHOOK.dll
    0x0000000030c90000  0xba7000  Q:\outout\VFS\CSIDL_PROGRAM_FILES_COMMON\Microsoft Shared\OFFICE11\MSO.DLL
    0x000000006bbc0000  0xf000    C:\Program Files (x86)\Citrix\MetaFrame Password Manager\Helper\WinApps\ssohook.dll
    0x0000000071ad0000  0x8e000   C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCP90.dll
    0x0000000071a20000  0xa3000   C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll
    0x00000000308e0000  0x2d9000  Q:\outout\OFFICE11\1033\outllibr.dll


    Tuesday, September 20, 2011 11:22 AM
  • Hello,

    Perhaps that is the problem - can you determine where it tries to load MAPI32.dll from?
    /Znack
    Tuesday, September 20, 2011 11:28 AM
  • Hello,

    on the server Outlook.EXE loads MAPI32.DLL from C:\Program Files (x86)\Common Files\SYSTEM\MSMAPI\1033\

    ListDLL entries of the runing OUTLOOK.EXE after sequenzing on Server:

    0x00000000308e0000  0x2d9000  Q:\Outlook\OFFICE11\1033\outllibr.dll
    0x0000000035f70000  0x14d000  C:\Program Files (x86)\Common Files\System\MSMAPI\1033\msmapi32.dll
    0x0000000061dd0000  0x21000   C:\Program Files (x86)\Common Files\System\MSMAPI\1033\mapi32.dll
    0x0000000035e80000  0xc0000   C:\Program Files (x86)\Common Files\SYSTEM\MSMAPI\1033\MAPIR.DLL
    0x0000000035db0000  0xa1000   C:\Program Files (x86)\Common Files\SYSTEM\MSMAPI\1033\outex.dll

    I tried to copy the files from the server to the client, but the error still occurs. The only diffenence is the ListDLLs Output: now a mapi32.dll is loaded:

     

    0x00000000308e0000  0x2d9000  Q:\Out3\OFFICE11\1033\outllibr.dll
    0x0000000035f70000  0x14d000  Q:\Out3\VFS\CSIDL_PROGRAM_FILES_COMMON\System\MSMAPI\1033\MSMAPI32.DLL
    0x0000000061dd0000  0x21000   Q:\Out3\VFS\CSIDL_PROGRAM_FILES_COMMON\System\MSMAPI\1033\MAPI32.DLL
    It is stored  on q:\ the virtual drive from App-V. On the Server I can find the files in the Q:\Out3\VFS... directory.

     

     


    • Edited by de.cyberalex Tuesday, September 20, 2011 1:13 PM
    Tuesday, September 20, 2011 1:13 PM
  • Hello,

    Since it seems that the same file is loaded as you have on the sequencer - perhaps there is a third-party software interfering with it?

    Have you tried removing as many components from the server and run it?


    /Znack
    Tuesday, September 20, 2011 7:56 PM
  • Hello,

    The App-V Server was plain Win2k8 R2 set up for App-V and on clientside there is MS SQL 2008, VMWare Tools and Citrix installed. After the installation of App-V no other changes were done. Do you know a best-practise to determine the applications which can interfere?

    Wednesday, September 21, 2011 8:17 AM
  • Hello,

    See this for AV and TS;

    http://support.microsoft.com/kb/973366

     

    General best practice are available here;

    http://technet.microsoft.com/en-us/appvirtualization/cc843994


    /Znack
    Wednesday, September 21, 2011 8:51 AM
  • hello,

    there is no AV installed.

    I tried a fresh Win2k8 R2 Server as a client but exactly the same error. It also loads the correct MAPI32.dll on Q:\ but says Error: Mapi32.dll is corrupt or the wrong version.

    Wednesday, September 21, 2011 2:46 PM
  • Hello,

    Have you investigated if the package works on any other operating system?
    /Znack
    Wednesday, September 21, 2011 2:55 PM
  • Hello,

    Since you are sequencing Office 2003 and using it on x64 system, have you checked if this combination is even supported to begin with? What is your sequencing machine's OS, the same x64 2008 R2?

     


    br,
    Kalle Saunamäki
    http://blog.gridmetric.com/
    Thursday, September 29, 2011 2:39 PM
    Moderator
  • Hello,

    both machines are the same x64 2008 R2 with same patchlevel. The machines are not cloned and on the server Outlook is working, in the test of the sequenzer.

    I have not tried on another OS, because it is sequenzed only for Win 2008 R2 and later it should run on Win 2008 R2 Terminal Server.

    Thank you for your ideas.

    Friday, September 30, 2011 10:32 AM
  • Hello,

    Did you start Outlook during sequencing?
    /Znack
    Friday, September 30, 2011 11:39 AM
  • Hello,

    no. Only after Sequenzing in the Packagetest, where you can select executables and try to lunch them. There everything works fine.

    Friday, September 30, 2011 1:26 PM
  • Hello,

    Package-test doesn't really exist - everything is included in the actual capture.

    Resequence the application and avoid starting Outlook at anytime


    /Znack
    • Marked as answer by de.cyberalex Friday, September 30, 2011 4:06 PM
    Friday, September 30, 2011 1:28 PM
  • Hello,

    okay, I give it a try on a new fresh system Win2k8 R2.

    Friday, September 30, 2011 1:59 PM
  • hello,

    thank you very much! I got it. I installed the sequenzer on a fresh system and did not lunch Outlook after sequenzing. After copying files to the server everything worked fine. thanks for your help!

    greets from Germany,

    Alex

    • Marked as answer by de.cyberalex Friday, September 30, 2011 4:06 PM
    Friday, September 30, 2011 4:02 PM