locked
picture/image library: how to recover deleted view "selected pictures" (selected.aspx) WSS3.0 RRS feed

  • Question

  • Hi

    I've deleted the view "selected pictures" (selected.aspx).

    I did it in a customized picture library with about thousands pictures. So it's not quite possible to quickly create another library. Is there a way (maybe with sharepoint designer) to recreate the view or to copy it from another library and modify it?


    Thx for help.

    Best regards
    Tom

    Friday, April 29, 2011 10:15 AM

Answers

  • I've tried this before posting on this forum.


    The same thing happened to me when I first created the view using the selected pictures template, but then going into 'Modify View' and making sure the proper fields are selected and clicking OK should fix the issue. 

    (Selection Checkbox)

    (Picture Size)

    (File Size)

    (Name)

    (Required Field {must be selected for picture library details view})

    (Type)


    - Xenox G.
    • Marked as answer by Tom8750 Saturday, April 30, 2011 12:36 PM
    • Edited by Mike Walsh FIN Saturday, April 30, 2011 1:25 PM Never use full quote
    Friday, April 29, 2011 3:29 PM

All replies

  • Hi Tom,

    Check the recycle bin using the UI (http://YOURSITEURL/_layouts/recyclebin.aspx)

    You should see an item in there with (no title).  Just restore it and it should bring your deleted view back.


    - Xenox G.
    Friday, April 29, 2011 1:03 PM
  • Hi Xenox

     

    I've deleted it a long time ago (when I didn't know the use of it), so it's no longer in the recyclebin.

    Can I recreate it manually?

     

    Best regards

     

    Tom

    Friday, April 29, 2011 2:17 PM
  • Hi Tom,

    Have you tried going to the Picture Library Settings page?

    There is an option to 'Create View' at the very bottom.  Once you click this, you will see an option to Start from a view template.

    Just below that you will see 'Selected Pictures'  Click on this to recreate your selected pictures view.

    After creating the view this way, you may have to go back in and Modify the view and click OK (just to make sure the proper ViewFields are selected)

     


    - Xenox G.
    • Edited by XenoxMicrosoft employee Friday, April 29, 2011 2:50 PM Clarification on possibility of having to modify the view
    Friday, April 29, 2011 2:42 PM
  • Hi Xenox

     

    I've tried this before posting on this forum.

    This method doesn't seem to work (don't know why).

    No images show up when I select this view (first selected a few)

     

    Any ideas?

    Best regards

     

    Tom

    Friday, April 29, 2011 3:22 PM
  • I've tried this before posting on this forum.


    The same thing happened to me when I first created the view using the selected pictures template, but then going into 'Modify View' and making sure the proper fields are selected and clicking OK should fix the issue. 

    (Selection Checkbox)

    (Picture Size)

    (File Size)

    (Name)

    (Required Field {must be selected for picture library details view})

    (Type)


    - Xenox G.
    • Marked as answer by Tom8750 Saturday, April 30, 2011 12:36 PM
    • Edited by Mike Walsh FIN Saturday, April 30, 2011 1:25 PM Never use full quote
    Friday, April 29, 2011 3:29 PM
  • Hi Xenox

    This is pretty weird.  I just went into modify view, all those fields were selected by default and pushed the OK-button and it works.

    I think I just closed the window or pushed the cancel-button before, since I didn't change any setting.

     

    Best regards

     

    Tom

    Saturday, April 30, 2011 12:37 PM