locked
Dreaded lock over icons RRS feed

  • Question

  • I've been reading the forums, and find all sorts of people having the same/similar problem, yet none of the solutions that have been posted have any sort of effect.

     

    Like everyone else, I'm having an issue with certain files having a lock symbol over icon after buying a computer with Windows 7.  Specifically, I'm running a simulation program, and any simulation files I save to a subfolder of the program are marked with this lock.  If I download files from the internet of this type, they are also marked the same way.

    I'm the only user on my laptop, and am not part of a homegroup.  This should be reason enough to rule out file-sharing as an issue.

     

    Any advice appreciated

    Wednesday, June 16, 2010 4:31 AM

Answers

  • You mean this type of lock?

    http://social.technet.microsoft.com/Forums/en/w7itprosecurity/thread/e8347f6f-e835-42e1-8509-eee38f83bb05

    If yes, this simply signals that the security settings of the file differ from the security settings of the parent folder this way that some users or user groups that are part of the security settings of the parent folder probably won't have access to the file. So let's say John Doe has "full access" to the parent folder and there is a single file within this folder that can only be accessed by local group "Administrators", the file will get the lock sign.

    This regularly happens when programs create files within a restricted area (e.g. your personal temp directory where only you, the user SYSTEM and Administrators have access), moving them to a public area (e.g. where the parent folder grants access to "Users") afterwards without adjusting the security settings. Remember that windows explorer automatically adjusts those settings whilst moving a file.

    As a last resort, you can reset the file security settings to the settings of the parent folder through command line or batch file. E.g.

    icacls c:\folder /reset /T
    icacls c:\file /reset

    Run icacls /? for more information.

    • Marked as answer by Magon Liu Friday, July 2, 2010 7:14 AM
    Saturday, June 19, 2010 11:02 AM