locked
Word citations and bibliography crashes - UNDO STACK issues. Any way to disable word 2007 (and up) UNDO? RRS feed

  • Question

  • The problem:

    Word 2007 crashes when user attempts to "update citations and bibliography" in large documents with many bibliography sources (roughly 900).

    Several users have posted this issue on a variety of fora. Other posts suggest citations and XSL handling are not significantly changed in Office 2010 or 365, so this probably applies to all 3 versions.

    the symptom:

    Watching the amount of memory the winword process uses, it creeps up until it gets to around 1.8Gb - that's when it falls over. memory is still only 60% utilized, eventviewer shows the following error logged:

    Faulting application winword.exe, version 12.0.6668.5000, stamp 5083137f, faulting module wwlib.dll, version 12.0.6668.5000, stamp 5083146b, debug? 0, fault address 0x002fe190.

    Same issue occurs even if all other applications (icluding virus protection and backup) have been disabled. Occurs in Office safe mode. Occurs in Windows safe mode. Office and windows patched and up to date. Office diagnostics run and clear. Configuration: word 2007 on win 7 64bit. i5 processor, 6Gb RAM 280Gb free disk.

    The diagnosis:

    It appears to be caused by Word's UNDO handling.

    Basically for every single citation update it seems to create an undo entry in the undo stack. In my case each one of these is between 8Mb and 14Mb (I'm guessing the difference relates to the number of times a source is cited in the document). So for 900+ sources, we are looking at an undo stack of 7 to 13 Gigs. Add in the application and document and we are talking about another 45Mb on top. I don't know if there's a finite addressable limit of a 32bit app, but it looks like what's happening is that as the update citations and bibliography proceeds, it just creates a HUGE UNDO STACK which eventually exceeds either some internal address limit or operating system limit or physical resources limit. Then it falls over. Since it falls over when Task Manager shows I still have plenty of memory left - I think it's an internal WORD CODE limit.

    How did I come to this conclusion?

    I monitored the memory use by the process winword.exe while manually updating my citations one at a time. The app with a blank doc takes about 25Mb. Add in my doc and it rises to 45Mb. Edit the first citation - rises to 57Mb, edit next - 69Mb, and so on. I quickly get to 150 or 170Mb before I chicken-out, exit "manage sources," and save the doc. I verify sources.xml is also updated. 

    SAVE does NOT clear the undo stack - there's no change in memory before and after SAVE.

    On the ribbon, the Undo button offers multiple instances of "select bibliography style" even after save.

    In older versions of word you could turn off the UNDO function, but it appears from Word 2007 and up you can't. If anyone knows of a way to disable UNDO in Word, that should solve this issue.

    On other fora I hear that there has been no significant change in Word 2010 or 2013 in this area.

    It's a diagnosis but not a solution.

    Howard

    Wednesday, September 4, 2013 3:10 PM

All replies

  • FIXED (kinda) in 64 bit edition of word!

    I eventually found a phone number and got through to MS tech support. Uninstalled office 365. Re installed the 64 bit edition of Office 365 (MS hide this under the "languages and advanced options" link). Ran Update citations and bibliography on the problem doc. It ran for 3 hours and I watched the winword process go up to 3.2 Gb for a while. 

    But it completed WITHOUT CRASHING!!

    Therefore it is the memory limit in the 32 bit app that is making it fall over, BUT there has to be a smarter way to code this transaction both from a memory use standpoint and a performance standpoint.

    Along the way, MS confirmed that the renaming the undo via a macro does not in fact disable the undo stack in word versions post 2003, so I was on-the-money blaming the bloated undo stack.

    Howard

    Tuesday, December 10, 2013 4:59 PM