locked
'Edit Document' Requires error. Think ActiveX control is being blocked. RRS feed

  • Question

  • I have a user that is receiving the error 'Edit Document' Requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater.

    The user is on Windows 7 with IE 9.  The server is MOSS 2007 SP2.  The web application is using a host header and appears as "local intranet" for the user.

    Things I have Tried

    I was able to have some sucess by logging in as the local admin.  Under that account I replicated the error and then reset IE 9.  When I went to the sharepoint site I was prompted to install the ActiveX control and I installed it.  It worked from there.

    I then logged on using the users network account and tried to replicate the fix.  After resetting IE, I went to the SharePoint site and was not prompted to install the ActiveX control.

    I checked the manage add-ons menu and nothing SharePoint related is listed.

    From what I can tell, the settings on this users computer and IE are identical to my own and other users on the network.  Most of IE is locked down because of Group Policies, so I am not sure why she is the only one experiencing problems.

    Any ideas on how to fix this?

    Monday, February 4, 2013 8:08 PM

Answers

  • Hi,

    I understand that one of the users cannot open the documents in client application. Are you using 64-bit office products?

    As you said you can open the document after installed an Active X control. You can ask the user to edit  Internet Options. Under Security tab click Custom Level. Enable ‘Automatic prompting Active x controls’. Then ask the user to login to site to see whether he can see an active x prompt. If not, you can ask him to disable Active X filtering.

    For more information, please refer to this site:

    "‘Edit Document’ requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater.": http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/d800d764-750c-4a06-8bc3-d0ff1923fd68

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming
    TechNet Community Support

    • Marked as answer by GreenWaterBoy Tuesday, February 5, 2013 8:03 PM
    Tuesday, February 5, 2013 9:42 AM
    Moderator

All replies

  • Hi,

    I understand that one of the users cannot open the documents in client application. Are you using 64-bit office products?

    As you said you can open the document after installed an Active X control. You can ask the user to edit  Internet Options. Under Security tab click Custom Level. Enable ‘Automatic prompting Active x controls’. Then ask the user to login to site to see whether he can see an active x prompt. If not, you can ask him to disable Active X filtering.

    For more information, please refer to this site:

    "‘Edit Document’ requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater.": http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/d800d764-750c-4a06-8bc3-d0ff1923fd68

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming
    TechNet Community Support

    • Marked as answer by GreenWaterBoy Tuesday, February 5, 2013 8:03 PM
    Tuesday, February 5, 2013 9:42 AM
    Moderator
  • The issue was 64 bit related.  She was using the 64 bit version of IE and I switched it to the 32 bit.
    Tuesday, February 5, 2013 8:04 PM