none
Option to chose a wireless display gone from win 8.1? RRS feed

  • Question

  • Hi All,

    I am trying to get a surface Pro to connect to a netgear via miracast. With a fresh out the box surface pro, with all the updates on both devices (surface & netgear) it works perfectly every time.

    BUT,

    I have now joined the surface to the school network domain which works well, but the option when I swipe from the side to project has changed. I still get the option to project, I press, but whereas I should get a list available devices to connect to and a small hyperlink to add a wireless display, but this has no gone and instead displays only the four options of how to display (PC Screen only, duplicate etc).

    Does anyone know any ideas or issues that maybe causing this?

    Regards

    Aaron

    Monday, December 9, 2013 10:39 AM

All replies

  • Hi,

    Have a look at the guide on this site: http://winsupersite.com/windows-8/windows-81-miracast


    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    MCSE:Server Infrastructure, MCSE:Desktop Infrastructure, MCSA Server 2012, Citrix CCIA & CCEE, Cisco CCNA, VMware VCP 3/4/5 Twitter: @dnyvandam http://www.dannyvandam.net


    Monday, December 9, 2013 2:45 PM
  • Hi Danny,

    Thank you for the link, but that only states what I already know and have working on a "out of the box" surface.

    I am trying to the get a surface, that is connected to the work domain, so I have access to the various network drives and network based software i.e. SIMS student register software. to connect to the netgear PTV 3000, but since the joining the domain and being able to log into my profile, the second menu below had disappeared. (Add wireless display)

    I can press project but I go straight  to the screen below:

    I do not understand how a profile can change the windows display "charm" bar?

    So I was wondering if any MS Windows engineers have tried this feature since joining windows 8.1 to a domain?

    Monday, December 9, 2013 4:36 PM
  • Hi,

    Did you mean that you can't see "Add a wireless display" in Project after join surface into domain, isn't it?

    Based on my search, I found some reason as below that may caused this problem:

    Wireless display is available on most new Windows 8.1 PCs, but some PC manufacturers might choose not to include it on some new and upgraded PCs. Specifically, your PC needs WDDM 1.3 display and NDIS 6.4 Wi-Fi drivers, enabled by the IHV and OEM for Miracast. If you don’t see “Add a wireless display” when you tap the Devices charm and tap Project, try going to Windows Update and downloading all available updates (including optional drivers). If you still don’t see it, check for additional updates on your PC manufacturer’s support site, or contact them to ask how you can get this feature on your PC.

    You also can refer to the link below for more details:

    http://blogs.windows.com/windows/b/windowsexperience/archive/2013/11/12/windows-8-1-on-your-big-screen-with-miracast.aspx

    If I misunderstand what you mean, please feel free let us know.


    Roger Lu
    TechNet Community Support

    Thursday, December 12, 2013 7:02 AM
    Moderator
  • Hi Roger,

    I'm using the Surface Pro. It has all the latest updates (including optional) and the netgear has all the updates.

    The surface did work perfectly when it was a stand alone, but since joining the domain the whole second menu with "add wireless display" and where it should show a list of devices, if it sees any, has completely gone.

    Any ideas why a workplace domain would change the charm bar?

    Thursday, December 12, 2013 3:05 PM
  • Hi,

    Sorry for my dilatory reply. if this problem indeed caused by join computer to domain, you can try to contact domain administrator to check whether there is any Group Policy that restrict this feature.


    Roger Lu
    TechNet Community Support

    Monday, December 23, 2013 9:51 AM
    Moderator
  • Hello Roger,

    Thank you for your reply.  I am also having the exact problem.  I have a MICROSOFT Surface Pro running MICROSOFT Windows 8.1 (with all possible Windows Updates as of 14-JAN-2014) and I am missing the "Add a wireless display" when I select the Devices/Project charm.  I have only seen this option once prior to a Windows Update in October.

    How do I restore this option to my MICROSOFT Surface Pro (original, model one) running MICROSOFT Windows 8.1 updated with all possible updates as of 14-JAN-2014?

    Thank you,

    Randy

    Wednesday, January 15, 2014 12:07 AM
  • Hi,

    I think this issue is really caused by GPO in domain.

    You can refer to the answers from OP in this thread:

    http://social.technet.microsoft.com/Forums/en-US/8a1060b2-2e79-49b4-bcca-76c15a639513/miracast-broke-after-connecting-to-domain?forum=w8itprogeneral


    Kate Li
    TechNet Community Support

    Thursday, January 23, 2014 1:43 AM
    Owner
  • I too have the same problem. I have a HP Envy 17, on which WiDi worked perfectly before updating to win 8.1, now I too am missing the option to "add a wireless display".

    This has nothing to do with domains or anything else but the win 8.1 update.

    Someone must be aware of a fix surely.

    thanks in advance

    Jim

     
    Friday, January 31, 2014 5:33 PM
  • I too have the same problem. I have a HP Envy 17, on which WiDi worked perfectly before updating to win 8.1, now I too am missing the option to "add a wireless display".

    This has nothing to do with domains or anything else but the win 8.1 update.

    Someone must be aware of a fix surely.

    thanks in advance

    Jim

     

    I have the same issue.. I have a Lenovo Thinkpad x220 with Windows 8.1 Enterprise (work computer). I also have T400 that with Windows 8.1 that is not in a domain, but still have the exact same issue..

    Really hoping for a fix for this issue..

    -Martin

    • Proposed as answer by blokg Wednesday, July 16, 2014 1:57 PM
    • Unproposed as answer by blokg Wednesday, July 16, 2014 1:57 PM
    Saturday, February 1, 2014 10:30 PM
  • I had exact same issue, ended up being our VPN Client.  We use Juniper Junos Pulse VPN.  I found others who had same issue with Cisco VPN.

    https://communities.intel.com/message/214964#214964

    I removed our VPN client, and it worked perfect.  This isn't a solution, as we need VPN, so Hopefully Intel / Microsoft fix this.

    As a follow up, I was also able to get it working by just unchecking the Juniper Network Agent box under the Wi-Fi Properties. Unfortunately, this requires elevated rights, so my users can't do this themselves.

    • Edited by blokg Wednesday, July 16, 2014 2:44 PM
    Wednesday, July 16, 2014 1:58 PM
  • We use Aruba VIA VPN client and I was having the same issue with my Surface Pro 3 and the MS Wireless Adapter.  Disabled VPN on the Wi-Fi Properties, and now it works.  Thanks blokg.
    Wednesday, December 3, 2014 9:27 PM
  • Thank you "blokg".

    Have been struggling with this problem for a couple of days and was about to give up after trying several display and wireless drivers, WiDi software (both Intel and Samsung proprietary sw), disabling fast boot, enabling and disabling services, joining workgroup, adding devices manually (Control Panel - Devices), disabling firewall and almost considering going back to 8.0 just to see if it would work, as suggested in some forums.

    I am not in a domain and I do not use a VPN, but I do have Virtualbox and VMware, which show up under the WiFi properties.

     After disabling both, I got the interface back to what I used to have and I now have the option "add wireless device".

    I started to believe this could be related to the OEM version of the drivers, as I was unable to install some of the WiDi and wireless sw/drivers from Intel's site, but in the end I ran into this thread and thought this could be related - it was :-)

    No idea why this would affect Windows interface and drastically change the options, but glad I found your answer.

    Samsung XE700T1C now working perfectly with LG smart tv (Miracast/Intel Widi)

    Tuesday, December 16, 2014 1:00 AM
  • In WiFi properties it ended up being the "Deterministic Network Enhancer" that was preventing the Miracast connection. 
    Friday, February 13, 2015 8:46 PM
  • VPN was the issue for me, spent days looking for this answer...
    Tuesday, February 24, 2015 8:06 PM
  • I'll add my "solution" to this problem... As others mentioned that it may be VPN clients stopping wireless display options to not work (or not show), I started digging and found another similar problem. I have Oracle VirtualBox installed and I was able to restore the missing 'Add Wireless Display' option to the 'Project' menu by unchecking the "VirtalBox Bridged Network Driver" option within the Wireless Network Adapter's Properties window. Hope that helps others.

    Friday, April 3, 2015 8:21 PM
  • This was also my exact problem, disabling virtualbox bridged network driver, worked for me.
    Thursday, June 18, 2015 6:36 PM
  • this was my solution, i have vpn from cisco and also anyconnect vpn with wmware workstation and vsphere client, so many things to go wrong.

    This was my solution to get the option again of adding wireless monitor, was disabling  "Deterministic Network Enhancer"  on wireless proprieties card


    Thursday, February 1, 2018 12:09 PM