locked
Public Folders - can`t stop replication RRS feed

  • Question

  • Hello

    I have a problem with Public Folders in Exchange 2007/2010 I just can`t seem to figure out. Configuration:

    EXC01 (Exchange 2007 SP3), EXC02 (Exchange 2007 SP3), EXC03 (Exchange 2010 SP2).

    EXC01 is on discontinued hardware and my customer wants to virtualize it (P2V it). Don`t ask, this is what he wants to do, and then later decomission it.

    All servers have a 100 GB Public Folder (PF) database replicated between them and to decrase the time it takes to P2V EXC01 he wants to delete the CONTENT of the PF database on EXC01 which means less data to P2V.

    I have basically done all the steps in this article: http://memphistech.net/?p=147 (not OAB yet) to prepare EXC01 for PF deletion but I still have a major problem; whenever I make a change to a PF on EXC01 (rename, delete, recover, add) the change is replicated to EXC02 and EXC03. This means that if I start deleting PF`s on EXC01 they will also be deleted on the two other servers.

    All PF`s on all three servers points to EXC03 under PF Properties -> Replication -> Replicate content to these public stores. I have tried to set replication interval to NEVER REPLICATE on both a folder, on a top folder and on the database, still changes appear on all three servers. I have even deleted EXC03 from "Replicate content to these public stores" so that there is nothing in there, still changes appear on all three servers. I have also tried to remove replicas with this command .\RemoveReplicaToPFRecursive.ps1 –Server EXC01 –TopPublicFolder \ –ServerToRemove “EXC03” to try to remove all replicas to to avail (and many more commands as well from both EXC03 and EXC01....basically there should be no replication between the EXC01 and the two other servers)

    What am I not understanding here? Is the only way to get rid of the public store on EXC01 to actually dismount the database, rename it, and mount an empty one (note: I will not be able to delete the store in a proper fashion since it contains PF`s ......and if I delete the PF`s they will be deleted on all three servers!)....and all I want is to get rid of the CONTENT of the public store on EXC01 and leave it on EXC02 and EXC03.

    What am I missing?

    Wednesday, December 19, 2012 8:49 PM

Answers

All replies

  • Hello,

    Thank you for your post.
     
    This is a quick note to let you know that we are performing research on this issue.

    Thanks,


    Simon Wu
    TechNet Community Support

    Thursday, December 20, 2012 4:10 PM
    Moderator
  • Hello Simon

    Could it be that I have misinterpreted the whole Public Folder concept? Since I have moved all content to EXC03 is it actually just the Folder structure I see on EXC01 since Public Folders are present in the organization level not on per server level?

    Maybe it is just the folder structure I see in Public Folder Management Console on EXC01, a structure that has no content?

    Maddas69


    Maddas69, Norway

    Thursday, December 20, 2012 4:17 PM
  • Ran a offline defrag on the database and shrunk it to 3 GB. Problem solved :-)

    Maddas69, Norway

    Thursday, December 20, 2012 4:59 PM