IE11 Windows 7 SP1 Home Premium - frequent waits RRS feed

  • Question

  • IE11 with current Windows 7 SP1 Home Premium 64bit - Yesterday I allowed Windows Update to upgrade IE10 to IE11.  Since that upgrade, when I'm using IE11, my fast desktop PC has MANY frequent little "waits", where the little spinning circle appears on the screen.  I think the spinning circle replaced the old hourglass.  Anyway, when the circle is on the screen, things are frozen.  Even as I type this posting, the keyboard has frozen for a second or two every few seconds.  This NEVER happened with previous versions of IE and it never happens now with Firefox or Chrome.   Reboot does not fix the problem.   Only freezes when IE11 is open.  Freezes/waits also are happening without the circle appearing. What to do?  
    Saturday, November 23, 2013 11:32 PM

All replies

  • First thing you should do is rid your computer of the Comp-view list from Microsoft,

    After that Delete your browser history to get rid of the prior downloaded lists,

    Gear symbol and Internet options/ Delete browser history button/ Uncheck the top box and check All others/ Delete.

    Close Internet explorer and re-open.

    Sunday, November 24, 2013 2:31 AM
  • OK.

    Deleted the comp-view lists and also deleted the browser history as you suggested.  Then I recycled IE11 and found that the problem was not totally fixed.  I still get some of those waits/freezes.  Froze several times just writing these few sentences.  I NEVER had this problem prior to IE11.  The Google search page with looks OK, btw.  When I click on the only/original tab to start a new tab, the new blank page does launch OK but I have to wait about 3 seconds for the little circle to quit before I can start using the new page.  

    Next idea?  


    Sunday, November 24, 2013 3:08 AM
  • The freezes happen several times per minute but they are random.  Task Manager shows almost no CPU usage before, during, and after the mini-waits (because I'm really not running anything or doing anything).  During the freezes the hard drive does not get active.  Freezes sometimes happen with no mini-circle showing. The mini-wait circles appear and leave even when I'm not touching the keyboard or mouse. 
    Sunday, November 24, 2013 12:28 PM
  • Hi,
    You may try to reset Internet Explorer settings to check the result.
    Reset internet explorer settings and check if it helps.
    Please understand that reset Internet Explorer to its default configuration. This step will also disable any add-ons, plug-ins, or toolbars that are installed.
    If it does not work, based on my experience, this is usually caused by 3rd party add-ons. Please launch IE 11 in No add-ons mode for a test. Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons). 
    If the issue does not occur, refer to the following link.
    Slow five tips to boost performance
    If starting Internet Explorer with no add-ons resolves the problem, isolate the browser add-on that is causing the issue. To do this, follow these steps :
    1. Click Start , and then click Internet Explorer.
    2. Click the Tools button, and then click Manage add-ons.
    3. Click an add-on in the Name list, and then click Disable.
    4. Repeat step 3 until you identify the add-on that is causing the issue.
    You may also back to use IE 10 as a workaround to check this issue.
    For more information, you may refer to:
    Fix Internet Explorer issues to make IE fast, safe and stable
    Tips for solving problems when Internet Explorer crashes or stops working
    Hope it works.
    Blair Deng

    Blair Deng
    TechNet Community Support

    Tuesday, November 26, 2013 4:59 PM
  • OK - now I'm in trouble.

    I did bring up IE11 from System Tools with all add-ons disabled and saw none of that waits problem..

    So then I used the add-on manager thing in the regular IE11 and disabled each one of the add-ons, one at a time, and then re-enabled each one as it proved to not cause any waits.  None of them caused any waits.  I did not recycle IE as I went thru this.

    So then I rebooted and started the regular IE11.  As soon as IE tries to load the 1st page, whether Google or my Yahoo home page (doesn't matter which one) IE quits loading the page and kicks a pop-up box that says that scripts have quit working on the page and do I want to continue without scripts.  Says something about "member not found".  I think whether I click yes or no, IE is locked up and when I click anywhere on the screen it does not do anything except makes a "ding" sound, and I can only get past that by killing the iexplore task using Task Manager. 

    I did the IE "reset" hoping that it would at least fix the "scripting" problem, but it did not help.

    So - what to do now?

    • Edited by cwr64 Tuesday, November 26, 2013 7:25 PM update for "reset"
    Tuesday, November 26, 2013 7:17 PM
  • - what to do now?

    Try using the Developer Tools, Console tab to see if there are any more clues about your script problem.  Even better would be to run ProcMon and see what it captures from the same events.

    Robert Aldwinckle

    Tuesday, November 26, 2013 8:51 PM
  • My son came in from work & I launched IE11 to show him how it was totally broken and for whatever reason (I have no clue) IE11 came up working again.  The original mini-waits problem is still there, but there was no lockup of the browser because of script or whatever.  Also, add-on manage shows the normal add-ons that are enabled & disabled, while I thought that "reset" was supposed to have gotten rid of the add-ons.  So now what? 
    Wednesday, November 27, 2013 12:49 AM
  • Also, add-on manage shows the normal add-ons that are enabled & disabled, while I thought that "reset" was supposed to have gotten rid of the add-ons. 

    I think it depends on how you used RIES.  There is a checkbox which says Delete personal settings which apparently by default is unchecked.  That probably makes our caveat now redundant.  It once was that there was no such checkbox and RIES just reset everything, including stored passwords.   I can imagine just about everything being expendable except those.   <eg>

    Robert Aldwinckle

    Wednesday, November 27, 2013 6:16 PM
  • Robert,

    I don't know what you really mean in terms of my IE11-caused waits problem.  Whether I checked the "personal settings" check-box or not, it was to have disabled the add-ons.  But as I said, when IE11 did come up (after that script problem mysteriously went away), the add-ons were not all disabled - they were as normal - some enabled and some disabled.  I'm beginning to wonder whether the IE11 that gets launched from System Tools | start IE with add-ons disabled is a different copy of IE from which I launch from the quick-launch bar. 

    Anyway, I still have that mini-waits problem which was the reason I originally posted.  I was hoping some Microsoft wizard might already know the answer & might reply.  

    Wednesday, November 27, 2013 7:22 PM
  • Did this get resolved?  I have the same issue.  For no apparent reason, spinning wheel and "not responding" message appear multiple times per day. 
    Thursday, December 19, 2013 6:16 PM
  • Did this get resolved?  I have the same issue.  For no apparent reason, spinning wheel and "not responding" message appear multiple times per day. 

    No - the "waits" never got resolved.  I was going to uninstall and then re-install IE11 to see if that might help but did not ever get around to it.  And I don't expect the re-install will fix anything.  I've been using Firefox and Chrome.  In Firefox I hit some online videos that will not play - and I have not found a fix for that either. 
    Thursday, December 19, 2013 10:08 PM
  • Hi cwr64,

    Based on the current situation, I would like to suggest you install latest version of Adobe Flash Player for IE to check the issue.

    Please also check if the other plugins are up to date.

    Hope it helps.


    Blair Deng

    Blair Deng
    TechNet Community Support

    Wednesday, December 25, 2013 11:04 AM
  • "Based on the current situation, I would like to suggest you install latest version of Adobe Flash Player for IE to check the issue."


    I will check out your Adobe Flash suggestion later today after the family does the Christmas thing.  But I think I already have the latest Flash installed in IE11.  Further, I think I disabled that add-on when trying to determine my IE11 waits problem.

    Wednesday, December 25, 2013 11:37 AM
  • Well, I did not re-install IE11. I disabled some of the add-ons and (I think) by doing that I "broke" IE11 again where it put out a script error message and locked up IE11 totally every time I tried to launch/run it.  I thought I had narrowed down the waits problem to LastPass but alas, LastPass is enabled and IE is functioning perfectly after I reset IE11 to "factory" and enabled back most of my add-ons.  I'm totally confused by what fails when enabled and then what doesn't fail when enabled - the same things.  My AVAST AV and LastPass are both enabled right now and I don't see any of the "waits", so I guess I'll just let things ride until IE11 breaks again.

    BTW - I do have the latest Flash installed and enabled so I just do not know why certain videos won't play in IE that play just fine in other current browsers.

    Friday, December 27, 2013 3:26 AM
  • Hi cwr64:

    Thank you for your update.

    As I known, many websites use add-ons such as Adobe Flash, Microsoft Silverlight. or QuickTime to play video or audio files.

    Please make sure that add-ons are installed and enable and all the add-ons are up to date.

    Some websites may have been designed for earlier versions of Internet Explorer. Switch to Compatibility View, and then see whether the video plays.

    If you are using ActiveX Filtering or Tracking Protection, some games or videos might be disabled. You may turn off ActiveX filtering and Tracking Protection

    Hope it helps.


    Blair Deng

    Blair Deng
    TechNet Community Support

    Monday, December 30, 2013 11:16 AM