none
Package Transfer Manager failed RRS feed

  • Question

  • Hi guys,

    I am having trouble setting up new distribution point at a site office.
    The new DP seems to setup ok - according to Distribution Point Configuration Status, however content keeps failing to transfer - this include the ConfigMgr Client Package, boot images.

    Checking the Content Status in the GUI for the packages shows:

    "Failed to update package"
    Possible cause: Site server does not have sufficient rights to update the package. (The primary site server is a member of the local admin group on this remote DP, and the NAA is a member of domain admins)
    Possible cause: There is not enough disk space available (there is around 1TB free space)

    Inside the PkgXferMgr.log shows:
    CContentDefinition::GetFileProperties failed; 0x80070003
    CContentDefinition::TotalFileSizes failed; 0x80070003
    CSendFileAction::SendFiles failed; 0x80070003

    There was a NO_SMS_ON_DRIVE.sms file put in place AFTER ConfigMgr was setup but this has now been removed.
    I have also tried to follow these steps but with the problem continues:

    • removed the DP role
    • removed the WDS service
    • rebooted the server
    • deleted SMSPKG$, SMSPKGx$, SMSPKGSIG, SMSSIG$, SCCMContentLib, RemoteInstall folders on all drives
    • removed no_sms_on_drive.sms files
    • reconfigured the DP

    I have also tried via PowerShell as suggested here, but no change: http://social.technet.microsoft.com/Forums/en-US/11df0f63-d146-434d-91f3-c4e826fee92c/redistribute-configuration-manager-client-upgrade-package-xxx00003?forum=configmanagermigration

    Any help on this issue would be appreciated.

    Regards,
    Locust12

    Tuesday, March 4, 2014 12:54 AM

Answers

  • Hi,

    After opening a case with MS Support I was informed that this is a known bug with SP1.
    This was caused by using the ContentLibrary Transfer tool.

    A WMI flag change was needed. Not sure exactly where as the engineer made this change.

    Recreating and redistributing the files after this then succeeded.


    Regards,
    Locust12

    • Marked as answer by Locust12 Wednesday, March 12, 2014 2:13 AM
    Wednesday, March 12, 2014 2:12 AM

All replies