locked
PACKAGEINSTALLATIONROOT with APP-V 5.2 for RDP RRS feed

  • Question

  • Hi

    Having some problems to publish APPV applications to Xenapp 6.5 users.

    AppData is redirected since it is supported with APP-V 5.2  http://technet.microsoft.com/en-us/library/dn508408.aspx

    Running MDOP for software Assurance 2013 R2

    Installed APP-V 5.2 for RDP on Citrix windows 2008R2.  Followed guide on http://technet.microsoft.com/en-us/library/jj713463.aspx   and change registry key

    In HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Streaming\PackageInstallationRoot from %programdata%\App-V  to %appdata%\App-V

    App-v Publishing server is working. Package  is published to %APPDATA%.  Access rights for the package is Domain users

     

    "%LOCALAPPDATA%\Microsoft\AppV\Client\Integration\1FF7B2AC-0230-422B-875B-0767C9678C77\Root\VFS\AppVPackageDrive\MY_App\My_App.exe"

    Note:  the folder 1FF7B2AC-0230-422B-875B-0767C9678C77 is displayed as a shortcut

    When logged onto the Citrix Terminal server as an Admin I can run the application from the shortcut that was created with no problems

    C:\Users\admin\AppData\Local\Microsoft\AppV\Client\Integration\1FF7B2AC-0230-422B-875B-0767C9678C77\Root\VFS\AppVPackageDrive\My_App.exe

    When a client is logged onto the Citrix Terminal server the following folders are created:

    C:\Users\dawa\AppData\Local\Microsoft\AppV\Client\Integration   (empty)                                                                                                                                                                  

    C:\Users\dawa\AppData\Local\Microsoft\AppV\Client\VFS\1FF7B2AC-0230-422B-875B-0767C9678C77

    Subfolders: (all empty)

     

    APPV_ROOT

    APPV_ROOTS

    AppVPackageDrive

    AppVPackageDriveS

    AppVSystem32Logfiles

    Programs

    Windows

     

     

    The error I am getting is this when the user logs on.  I have also disabled AppData re-direction but I get the same error.

     

    Event 19105: Part or all packages un-publish failed.  un-published: 0  failed: 2  Please check the error events of 'Unpublish Package' before this message for the details of the failure.

     

     

    Can anyone point me in the right direction or which section in advanced debugging should I look at (46 sections)

     

    Thanks

    David


    Wednesday, December 18, 2013 12:53 PM

Answers

All replies