locked
Client won`t push through Client Wizard RRS feed

  • Question

  • Hello,


    i am having a problem with pushing clients using wizard.

    SCCM installation went fine, deployment consists of central administration and primary sites running on separate servers.

    Primary site so far contains only management role. According to documentation that`s sufficient for pushing.

    AD scheme is extended and discovery works well.


    Pushing wizard quickly flashes on progress step and reports successful client push installation, but actually it`s not installed.

    No errors SCCM server or target.


    SCCM runs on W2008 R2 SP1, and targets too.


    1. Primary site computer account is local admin on target. 

    2. FW is disabled

    3. target ADMIN$ share is accessible

    4. Boundary and boundary group created.

    What still could be wrong? Thanks for ideas.


    Wednesday, June 6, 2012 11:27 AM

Answers

  • There's nothing wrong with the above log snippet -- all is normal and as expected. If you are still having issues, you need to look at the ccmsetup.log on the client as the install process is owned by the client system after the ccmsetup service is installed and started.

    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Saturday, June 9, 2012 2:47 AM
  • ConfigMgr is a complex product. Have you added the computer account of the site server to the local admins on the remote DP? What error is logged in distmgr.log?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, June 19, 2012 11:54 AM

All replies

  • First you should check if you can ping the client (and verify you get the right IP adress).
    Then you should check the CCM.log file for errors related to Client Push.


    Ronni Pedersen | Microsoft MVP - ConfigMgr | Blogs: http://www.ronnipedersen.com/ and SCUG.dk/ | Twitter @ronnipedersen

    Wednesday, June 6, 2012 11:41 AM
  • What's in ccm.log? Do the clients show up as "assigned = yes"?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, June 6, 2012 12:03 PM
  • ip connectivity is fine,

    cmm log contains WMI errors:

    Execute query exec [sp_IsMPAvailable] N'SLT'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.001-180><thread=3436 (0xD6C)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.001-180><thread=3436 (0xD6C)>
    ---> Attempting to connect to administrative share '\\IMOLA\admin$' using account 'ACTIVEDIR\scadmin'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.002-180><thread=3436 (0xD6C)>
    ---> Connected to administrative share on machine IMOLA using account 'ACTIVEDIR\scadmin'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.039-180><thread=3436 (0xD6C)>
    ---> Attempting to make IPC connection to share <\\IMOLA\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.039-180><thread=3436 (0xD6C)>
    ---> Searching for SMSClientInstall.* under '\\IMOLA\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.040-180><thread=3436 (0xD6C)>
    CWmi::Connect(): ConnectServer(Namespace) failed. - 0x80070005~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.048-180><thread=3436 (0xD6C)>
    ---> Unable to connect to WMI on remote machine "IMOLA", error = 0x80070005.  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.048-180><thread=3436 (0xD6C)>
    ---> Deleting SMS Client Install Lock File '\\IMOLA\admin$\SMSClientInstall.SLT'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-07-2012 10:57:26.048-180><thread=3436 (0xD6C)>

    seems to be internal OS problem, as FW is disabled



    Thursday, June 7, 2012 8:05 AM
  • while investigating have found that SMS agent service is installed,

    so client seems to be installed, i have thought it would then appear in add/remove programs,

    seems it shouldn`t be there?

    Thursday, June 7, 2012 11:12 AM
  • still digging, somehow while experimenting managed to push to few servers,

    but other fail on the same error,

    DCOM, and WMI permissions seems correct, contains local administrators gruop.

    But when trying to connect remotely using wmimgmt.msc "Win32: access denied." is showed.

    Thursday, June 7, 2012 12:53 PM
  • No, the ConfigMgr client agent does not appear in Add/Remove programs.

    The easy way to check for it is to look for the ConfigMgr Control Panel applet in the System sectoin.


    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Thursday, June 7, 2012 2:27 PM
  • found out that error CWmi::Connect(): ConnectServer(Namespace) failed. - 0x80070005

    was caused by server firewall, connections were made using IPv6 addresses, firewall scope includes only IPv4, so i deleted v6 DNS records and connections initiate using v4.

    Right now pushing stuck on another error

    ======>Begin Processing request: "2097152027", machine name: "FRESH"  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.872-180><thread=3124 (0xC34)>
    Execute query exec [sp_IsMPAvailable] N'SLT'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.872-180><thread=3124 (0xC34)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.873-180><thread=3124 (0xC34)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.873-180><thread=3124 (0xC34)>
    ---> Attempting to connect to administrative share '\\FRESH\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.873-180><thread=3124 (0xC34)>
    ---> Connected to administrative share on machine FRESH~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.878-180><thread=3124 (0xC34)>
    ---> Attempting to make IPC connection to share <\\FRESH\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.878-180><thread=3124 (0xC34)>
    ---> Searching for SMSClientInstall.* under '\\FRESH\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.879-180><thread=3124 (0xC34)>
    ---> System OS version string "6.1.7601" converted to 6,10  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.948-180><thread=3124 (0xC34)>
    CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.951-180><thread=3124 (0xC34)>
    ---> Unable to connect to WMI (root\ccm) on remote machine "FRESH", error = 0x8004100e.  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.951-180><thread=3124 (0xC34)>
    ---> Creating \ VerifyingCopying exsistance of destination directory \\FRESH\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.953-180><thread=3124 (0xC34)>
    ---> Copying client files to \\FRESH\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.957-180><thread=3124 (0xC34)>
    ---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "MobileClient.tcf"  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.958-180><thread=3124 (0xC34)>
    ---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "ccmsetup.exe"  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:05.969-180><thread=3124 (0xC34)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:07.482-180><thread=2736 (0xAB0)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:07.482-180><thread=2736 (0xAB0)>
    Waiting for change in directory "C:\Program Files\Microsoft Configuration Manager\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout).  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:07.482-180><thread=2736 (0xAB0)>
    ---> Updated service "ccmsetup" on machine "FRESH".  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:20.988-180><thread=3124 (0xC34)>
    ---> Started service "ccmsetup" on machine "FRESH".  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:21.019-180><thread=3124 (0xC34)>
    ---> Deleting SMS Client Install Lock File '\\FRESH\admin$\SMSClientInstall.SLT'~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:21.036-180><thread=3124 (0xC34)>
    Execute query exec [sp_CP_SetLastErrorCode] 2097152027, 0~  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:21.038-180><thread=3124 (0xC34)>
    ---> Completed request "2097152027", machine name "FRESH".  $$<SMS_CLIENT_CONFIG_MANAGER><06-08-2012 14:27:21.040-180><thread=3124 (0xC34)>

    Friday, June 8, 2012 12:02 PM
  • There's nothing wrong with the above log snippet -- all is normal and as expected. If you are still having issues, you need to look at the ccmsetup.log on the client as the install process is owned by the client system after the ccmsetup service is installed and started.

    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Saturday, June 9, 2012 2:47 AM
  • was away with other problems...


    ccmsetup.log on the client contains such error:

    <![LOG[Failed to get DP locations as the expected version from MP 'SCAMMON.activedir.vu.lt'. Error 0x0]LOG]!><time="12:52:24.829-180" date="06-19-2012" component="ccmsetup" context="" type="2" thread="2396" file="ccmsetup.cpp:9542">
    <![LOG[Next retry in 10 minute(s)...]LOG]!><time="12:52:24.829-180"


    i suppose i should install distribution point then, but i have tried to install it earlier, role installation goes fine,

    but error appears in event viewer:


    On 2012.06.19 12:47:36, component SMS_DISTRIBUTION_MANAGER on computer SCAMMON.activedir.vu.lt reported:  Distribution Manager failed to install distribution point ["Display=\\SCAMMON.activedir.vu.lt\"]MSWNET:["SMS_SITE=SLT"]\\SCAMMON.activedir.vu.lt\ on computer SCAMMON.ACTIVEDIR.VU.LT.

    Possible cause: Distribution Manager does not have sufficient rights to the computer.
    Solution: Verify that the site server computer account is administrator of the computer.

    both installation user and computer has local admin rights, i guess i should start a new topic

    SCCM is really complicated :))


    Tuesday, June 19, 2012 10:52 AM
  • ConfigMgr is a complex product. Have you added the computer account of the site server to the local admins on the remote DP? What error is logged in distmgr.log?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, June 19, 2012 11:54 AM