locked
Windows VPN Server RRS feed

  • Question

  • Hey.

    Have tried to setup a VPN on a corporate server, without success.

    have followed this guide.
    http://www.thomasmaurer.ch [...]

    I can easily get access to the server, but at the Client when I run ipconfig / all of them tells me that my VPN server's default gateway is 0.0.0.0 and it has the  IP 10.10.10.8

    On the server it says it have the IP 169.254.xx - server has internet access,and NOT connected to any DHCP server to get IPs from, so have given the VPN an Address pool - this seems also to be working, but how do I VPNens default gateway for clients?
    Thursday, April 26, 2012 8:53 PM

Answers

  • The gatway for this PPP connection appears 0.0.0.0 because you are not using the gateway on the remote server, instead you are using the local gateway. Click properties on the vpn connection, Networking, IPv4, Advanced, and click use remote gateway...

    Hope it helps.


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    Friday, April 27, 2012 3:42 PM
  • In addition to Marius' suggestion, did you setup NAT on the server? Reason why I ask is you are providing a static 10.10.10..x IP range for VPN clients, but it appears the internal network is 192.168.1.x. It must be able to NAT internally, which will provide internet access from the internal network, because of the private IPs.

    Also, it appears the DHCP server's IP address is the gateway/router. Is this correct? 

    .

    You may want to try to disable and re-configure RRAS on your server, and follow Marius's link.

    .

    Also, see if the following helps, including the videos.

    ================================
    ================================
    Configure RRAS, Configure NAT and VPN for 2008/2008 R2:

    Technet thread: "Internet Access through VPN server - need help please"  6/28/2010
    http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/8db49948-1962-408b-9996-4a9584b3500d/

    Quoted solution from above link:
    1.Open Server Manager
    2.Network Policy and Access Services
    3.Routing and Remote Access
    4.IPv4
    5.NAT
    6.Right mouse, New Interface
    7.Choose a NIC (in my case the options were 'Local Area Connection 3' and 'Internal', so I went with the first one)
    8.On the NAT tab, selected "Public Interface connected to the internet"
    9.Ticked "Enable NAT on this interface"
    10.Click OK
    11.All done - now test your VPN connection from the client


    How To Install and Configure RRAS NAT & VPN (YouTube Video):
    How to install routing and remote access server and test the installation with a VPN connection.
    http://www.youtube.com/watch?v=wpt2z3LA0dQ 

    Remote Access Deployment – Part 2: Configuring RRAS as a VPN server
    http://blogs.technet.com/b/rrasblog/archive/2009/03/25/remote-access-deployment-part-2-configuring-rras-as-a-vpn-server.aspx

    Routing and Remote Access Service on Windows 2008 & Windows 2008 R2
    http://technet.microsoft.com/en-us/library/cc754634(WS.10).aspx


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Saturday, April 28, 2012 5:40 PM

All replies

  • Hello,

    What operating system is the server?

    Please post an ipconfig /all from both server and client.

    In the future try following official Microsoft articles such as this.


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    Thursday, April 26, 2012 9:28 PM
  • Hello.

    Its Windows Server 2008 R2 (standard) 

    Friday, April 27, 2012 2:31 PM
  • The gatway for this PPP connection appears 0.0.0.0 because you are not using the gateway on the remote server, instead you are using the local gateway. Click properties on the vpn connection, Networking, IPv4, Advanced, and click use remote gateway...

    Hope it helps.


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    Friday, April 27, 2012 3:42 PM
  • In addition to Marius' suggestion, did you setup NAT on the server? Reason why I ask is you are providing a static 10.10.10..x IP range for VPN clients, but it appears the internal network is 192.168.1.x. It must be able to NAT internally, which will provide internet access from the internal network, because of the private IPs.

    Also, it appears the DHCP server's IP address is the gateway/router. Is this correct? 

    .

    You may want to try to disable and re-configure RRAS on your server, and follow Marius's link.

    .

    Also, see if the following helps, including the videos.

    ================================
    ================================
    Configure RRAS, Configure NAT and VPN for 2008/2008 R2:

    Technet thread: "Internet Access through VPN server - need help please"  6/28/2010
    http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/8db49948-1962-408b-9996-4a9584b3500d/

    Quoted solution from above link:
    1.Open Server Manager
    2.Network Policy and Access Services
    3.Routing and Remote Access
    4.IPv4
    5.NAT
    6.Right mouse, New Interface
    7.Choose a NIC (in my case the options were 'Local Area Connection 3' and 'Internal', so I went with the first one)
    8.On the NAT tab, selected "Public Interface connected to the internet"
    9.Ticked "Enable NAT on this interface"
    10.Click OK
    11.All done - now test your VPN connection from the client


    How To Install and Configure RRAS NAT & VPN (YouTube Video):
    How to install routing and remote access server and test the installation with a VPN connection.
    http://www.youtube.com/watch?v=wpt2z3LA0dQ 

    Remote Access Deployment – Part 2: Configuring RRAS as a VPN server
    http://blogs.technet.com/b/rrasblog/archive/2009/03/25/remote-access-deployment-part-2-configuring-rras-as-a-vpn-server.aspx

    Routing and Remote Access Service on Windows 2008 & Windows 2008 R2
    http://technet.microsoft.com/en-us/library/cc754634(WS.10).aspx


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Saturday, April 28, 2012 5:40 PM