none
Cannot download Windows 10 LTSB

All replies

  • Despite choosing LTSB repeatedly, I do not get the LTSB .ISO

    How did you know you did not have the LTSB iso ? You saw Cortana, the Store etc in your system ?

    Did you use this link ?
    https://www.microsoft.com/en-us/evalcenter/evaluate-windows-10-enterprise

    You are required to register first. Once that is done, you will be offered the choices as shown in my screenshot.

    Was that how you did your iso download ?

    Screenshot...........



    Friday, March 3, 2017 12:30 PM
  • Hi TobieV,

    Where did you download the LTSB iso?

    Usually we could download the LTSB iso here.
    Windows 10 LTSB
    https://msdn.microsoft.com/en-us/subscriptions/downloads/#searchTerm=ltsb&ProductFamilyId=0&Languages=en&PageSize=10&PageIndex=0&FileId=0

    LTSB is only available for Enterprise version and it is only available for subscription customers. Please ensure you have logon with the subscription account.

    If you testing the LTSB version, we could download the iso from the link as david hk129 posted.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 6, 2017 6:01 AM
    Moderator
  • I used this link and selected ISO-LTSB. I then selected English 64bit. When I installed it today, it was a full blown Enterprise version.

    File name was 14393.0.160715-1616.RS1_RELEASE_CLIENTENTERPRISEEVAL_OEMRET_X64FRE_EN-US.ISO

    Thinking maybe I had selected the wrong option I download again and got the same file. I went back and selected ISO - Enterprise, to only get the same file.

    Am I missing something?

    Thursday, March 9, 2017 12:42 AM
  • Hi Wizard2475,

    I have tried to download the LTSB version from the Evaluation website without success, too.

    I will submit the issue on my side. If you are a volume license user, you could try to download it from the MSDN subscriber website.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 10, 2017 5:59 AM
    Moderator
  • I used this link and selected ISO-LTSB. I then selected English 64bit. When I installed it today, it was a full blown Enterprise version.

    File name was 14393.0.160715-1616.RS1_RELEASE_CLIENTENTERPRISEEVAL_OEMRET_X64FRE_EN-US.ISO

    Thinking maybe I had selected the wrong option I download again and got the same file. I went back and selected ISO - Enterprise, to only get the same file.

    Am I missing something?

    Somehow I was given an iso with slightly file name.
    I was given this:14393.0.160715-1616.RS1_RELEASE_CLIENTENTERPRISE_S_EVAL_X64FRE_EN-US.ISO

    Yours : 14393.0.160715-1616.RS1_RELEASE_CLIENTENTERPRISEEVAL_OEMRET_X64FRE_EN-US.ISO

    Mine does not have OEMRET. Wonder if that makes a difference or relevant at all.



    Friday, March 10, 2017 7:52 AM
  • Since you have already installed, please use the following to verify which version you have.......

    Open Command Prompt > type or copy/paste this.......

    wmic os get caption

    > Enter.

    It will tell you which version you have.


    Friday, March 10, 2017 9:10 AM