locked
Selected Item in Context Menu stays visible forever RRS feed

  • Question

  • I've had this problem since the Beta. I ignored it in the Beta, but now I have it in the released version as well.

    1) Right-click to bring up a context menu (it does not seem to matter what application you are using. I've had this happen in VS2008, VS2010B2, IE8, and Word 2007).
    2) Click on an item from the context menu.
    3) The item appears selected (highlight changes).
    4) The context menu disappears
    5) The selected item does not.

    I have a screen shot if that helps.
    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.
    Thursday, January 7, 2010 6:35 AM

Answers

  • Hi,

    You can also try changing to a classic theme from Personalizaiton-> Basic and High contrast Themes as a test.
    Monday, January 11, 2010 10:30 AM

All replies

  • Hey Chris, I've seen this happen a lot on my XP machines (never really tracked it down, I usually just ignored it until I was able to reboot and get on with my day).

    Just out of curiosity, do you have Aero (Transparency and effects) enabled?







    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 8, 2010 2:04 AM
  • Hi,

    What is the model of your graphic card and your PC?

    Does the issue reoccur right after switching to windows 7 RTM? According to the symptom, this is similar to a slightly screen crash. I would suggest install the latest graphic card driver.

    Go to device manager->right click on the graphic card->propertise->update the driver software.

    Meanwhile, test it in clean boot for troubleshooting:

    This method will disable loading program or service from start up to avoid conflict
     
    1. Click "Start",and type "msconfig" (without the quotation marks) in the open box to start the System Configuration Utility.
    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".
    4. Click "OK" to restart your computer to Selective Startup environment.
    5. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.
    6. Check whether or not the issue still appears in this environment.

    • Marked as answer by Linda Yan Tuesday, January 12, 2010 5:31 AM
    • Unmarked as answer by Chris B. Snyder Friday, January 15, 2010 5:15 PM
    Friday, January 8, 2010 5:00 AM
  • The machine is a Dell Precision M6300 with an NVIDIA Quadro FX 1600M. I have the latest drivers installed already. I will test in clean boot and post back.

    Thanks for the help.
    Chris
    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.
    Friday, January 8, 2010 7:55 AM
  • Hi Chris

    If the clean boot mode does not resolve the problem, it's very common for third party applications that add context menu handlers to cause the type of problem you are seeing.

    There is a good, free utility available that makes removing unwanted third party, Context Menu items as easy as removing the check mark for that item. Here is the link.

    ShellExView - Shell Extension Manager For Windows

    This utility makes it easy to remove and replace context menu items to track down the culprit.

    Let us know what you find.

    Thank You for using Windows 7

    Ronnie Vernon MVP
    • Marked as answer by Linda Yan Tuesday, January 12, 2010 5:31 AM
    • Unmarked as answer by Chris B. Snyder Friday, January 15, 2010 5:15 PM
    Friday, January 8, 2010 7:17 PM
  • The reason I inquire if you are using Aero, is that I've only seen this issue when the computer is rendering the desktop in GDI mode, instead of DWM.



    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 8, 2010 11:11 PM
  • Hi,

    You can also try changing to a classic theme from Personalizaiton-> Basic and High contrast Themes as a test.
    Monday, January 11, 2010 10:30 AM
  • Sorry I haven't been back in a while, I wanted to see what the results of Magon-67's MSCONFIG idea was. Unfortunately, it didn't work. It took a while for it to happen again though.

    I'll try the other suggestions now, and see if I can give you any more feedback.

    Chris
    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.
    Friday, January 15, 2010 5:15 PM
  • OK, pr Magon's request, I changed from my Aero theme to a basic theme AFTER the problem occurred again. And it seemed to have fixed it.

    So, at this point, I would say it has something to do with running an Aero theme.

    Any further ideas?

    Chris
    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.
    Monday, January 18, 2010 8:19 AM
  • You mean the issue reoccurs once after changing Aero theme, then it never occurs again?

    It might has something to do with the UI components. The steps to disable Aero refresh the settings.
    Tuesday, January 19, 2010 10:22 AM
  • Here's the steps:

    While running an Aero theme, I r-clicked on a context menu and selected some item. The item stayed visible on the screen even after the context menu was closed. It is now on top of everything (right now, I have a menu item that says "Open in New Tab" stuck in the middle of my screen).

    When I switch to a "Classic" theme, the menu item gets cleared.

    If I then switch back to an Aero theme, the menu item stays cleared.
    I'm not sure I understand what UI components you mean. I've been trying to figure out a way to reproduce this, so that I can submit a bug report to MS, but it is just too intermittent.

    Chris


    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.
    Wednesday, January 20, 2010 6:29 AM
  • Chances are it was a third party app that was causing the issue. I was having the exact same issue on my machine for work, when I would click run as a different user I would be left with a rectangle piece of the context menu floating in the middle of my screen that stayed on top of all other windows. 

    I uninstalled the last piece of software I had installed before I started having this issue and now it is resolved. Try uninstalling different pieces of software, I'm sure one of them is the culprit. 

    Thursday, May 6, 2010 2:45 PM
  • You can also open task manager and kill the desktop window manager process: DWM.EXE,

    How Do I do this you ask?

    1. open task manager. (Hit CTRL-SHIFT-ESC, or CTRL-ALT-DEL and choose task manager)

    2. Click the processes tab, and select the one with the Image name of "dwm.exe", with the description "Desktop Window Manager"

    3. Click end process.

    DWM.exe it should immediately restart itself, Causing the stuck context menu to disappear.

    --Toastee

     

     

    • Proposed as answer by pointernil Thursday, December 2, 2010 10:21 PM
    Wednesday, August 11, 2010 11:31 PM
  • That's correct, it works on me. I thought the major cause was Internet Explorer 9.

    The contextual menu can't fade and when you select one choice, it stays visible. It happens on the desktop too.. What could be the cause?
    Wednesday, November 3, 2010 8:33 PM
  • Wow, thanks you're awesome!
    Monday, December 27, 2010 6:49 AM
  • You can also open task manager and kill the desktop window manager process: DWM.EXE,

    How Do I do this you ask?

    1. open task manager. (Hit CTRL-SHIFT-ESC, or CTRL-ALT-DEL and choose task manager)

    2. Click the processes tab, and select the one with the Image name of "dwm.exe", with the description "Desktop Window Manager"

    3. Click end process.

    DWM.exe it should immediately restart itself, Causing the stuck context menu to disappear.

    --Toastee

     

     

    That works for a little bit, but then the next menu item I click on will be stuck on the screen (about 50% opacity).

    Doesn't matter where the menu comes from.  It could be IE9, photoshop, dreamweaver or even the desktop.

    So what is the solution, some kind of script to restart DWM every time a menu item is selected?  Sounds like bull to me.

    Friday, June 17, 2011 8:26 PM
  • The machine is a Dell Precision M6300 with an NVIDIA Quadro FX 1600M. I have the latest drivers installed already. I will test in clean boot and post back.

    Thanks for the help.
    Chris
    Chris Snyder: The opinions and statements in this post do not reflect the opinions and statements of YOUR boss.

    Hmmm, funny you say that because I have Dell Precision M6400 Covet w/ the NVidia Quadro FX 3700M with the latest drivers and I have this issue.  I tried restarting the DWM.exe and that does work for me though.
    Tuesday, July 5, 2011 3:26 PM
  • I have the same problem on Windows 7 Enterprise x64 since the last Live Essentials Update of yesterday! This has never happened for the last 1 year I had it installed.

    The only solution I found is to disable 'Fade out menu items after clicking' in the performance options of Windows. But the question would be, why do I need to disable this option? This should work no?

    • Proposed as answer by Emil Gueorguiev Thursday, February 13, 2014 11:43 PM
    Friday, August 5, 2011 8:10 AM
  • I can assure you it wasn't related to the Windows Live Essentials update.  More than likely, it downloaded a driver update at the same time.  Head to your manufacturer's website (nVidia, ATI, Intel, Dell, HP or whomever built your video card) and get the latest drivers, reinstall them, and you'll be good.
    Shawn Keene
    Friday, August 5, 2011 2:44 PM
  • Drivers installed from Windows Update are WHQL drivers that are usually limited in functionality and compatibility, and typically months behind the ones vetted by the manufacturer.  You'll get better performance, reliability, and less bugs if you go get the latest driver, not the one that got installed with your automatic updates.  Please give it a try,

    If you suspect you have the latest, you can see in Device Manager that the drive you do have matches the version number of your manufacturer's latest posted version.  However even in that case I would recommend you reinstall from your manufacturer's download anyway.

    Remember that you came here to ask for suggestions.  I'm only telling you what has worked for me personally and hundreds of customers I've supported.  You don't have to take my advise if you don't choose to.

     


    Shawn Keene
    Friday, August 5, 2011 4:55 PM
  • So you don't want to even bother checking to see if there's a new driver?

    Let me just nod my head, wave my magic wand, and fix your issue.  How's it working now?

     

    Seriously, what do you want me to say?  You probably are on a 6-month old driver that finally got pushed by WHQL that has a bug.  Or your chipset is out of date, but you just want what?  A download that fixes it for you?  A one-click link?  Nothing but sympathy?  I've helped helped thousands of customers, hundreds of whom have had this problem, and no one but you has ever said "I don't want to bother checking, I just want to complain".

     

    Either give it a try or don't, but I'm unsubscribing from this thread.  Someone else might help you, if you ever bother to check.

     


    Shawn Keene
    Friday, August 5, 2011 5:24 PM
  • You can also open task manager and kill the desktop window manager process: DWM.EXE,

    How Do I do this you ask?

    1. open task manager. (Hit CTRL-SHIFT-ESC, or CTRL-ALT-DEL and choose task manager)

    2. Click the processes tab, and select the one with the Image name of "dwm.exe", with the description "Desktop Window Manager"

    3. Click end process.

    DWM.exe it should immediately restart itself, Causing the stuck context menu to disappear.

    --Toastee

     

     

    Thanks works for me
    Thursday, July 11, 2013 8:14 PM
  • All of sudden, this is happening to me all over the place (where I don’t think was happening before) and doing so consistently (i.e. any Context Menu on my Windows 7 Desktop or Windows Explorer but not 2010 Word / Excel or VS 2008). 

    If you've checked "Show location of pointer when I press the CTRL key" (via temporary flashing concentric circles) in "Mouse Properties" -> "Pointer Options" (which IMHO should always be checked), when you tap the Ctrl key, the menu option will disappear.

    Although, I’ve also noticed one of the circles displayed by this option recently started remaining on screen (until I press Esc key).  I suspect this coincided with the appearance of the Menu Items problem.

    Restarting got rid of both the menu item and Ctrl-key circle being stuck as well, but those are workarounds for if you don't have time or don't feel like restarting Windows.

    Wednesday, July 17, 2013 10:36 PM
  • Douchebag says what...
    Thursday, September 26, 2013 8:28 PM
  • Hi,

    This just started happening to me.

    Killing DWM fixes it, but it would be good if someone from MS could look into fixing it, since it seems to have been happening for the last 3 years!

    Sunday, December 8, 2013 8:31 AM
  • This started happening again recently for a bunch of our users. It's a nice easy fix. Also noticed it wasn't on this article (which is one of the top results) so just throwing it in here despite it being 4 years old.

    It's fade out in the Aero settings, gets stuck for some unknown reason.

    1. Go to Start
    2. Right Click on Computer and go to Properties
    3. Click Advanced System Settings on the left
    4. Change to the Advanced Tab
    5. Under the Performance Section click Settings
    6. Uncheck Fade out menu items after clicking.
    7. Click Apply

    This has fixed the issue for me personally and a number of our users.

    • Proposed as answer by Emil Gueorguiev Thursday, February 13, 2014 11:42 PM
    Wednesday, January 22, 2014 9:10 AM
  • I got these instruction from a post in Super User and it worked for me. I am using Windows 7 64. Here are the instructions:

    1. Control Panel > All Control Panel items > Performance Information Tools
    2. choose Adjust visual effects from the side menu.
    3. Uncheck "Fade out menu items after clicking"

    I hope this will help.


    • Edited by YonaB Sunday, February 1, 2015 4:46 PM
    Sunday, February 1, 2015 4:43 PM
  • This worked for me also. Using Windows 7 64bit
    Sunday, February 1, 2015 4:45 PM
  • I noticed after posting that Cewda has posted the same solution below. This really works well.
    • Edited by YonaB Sunday, February 1, 2015 4:49 PM
    Sunday, February 1, 2015 4:48 PM