none
Project Server 2016 - Content databases do not have Project Server Schema RRS feed

  • Question

  • Hello everyone,

    after an installation with the usual scripts of Project Server 2016 Preview, everything was there (web application, profiles, search, project server service & service application, etc.) and I was ready to create the PWA site.

    However, Enable-feature PWA failed because all content databased were missing the Project Server schema extension.

    Recreating content databases, web application etc. did not resolve the issues.

    Finally, I ended upscrapping and rebuilding the farm with the wizards, and the schemas were there and the PWA instance was created.

    Did anyone experience something similar?

    Thank you and best regards,
    Adrian

    PowerShell reply:

    Enable-SPFeature : The Project content database extension has not been
    provisioned for this content database.
    At line:1 char:1
    + Enable-SPFeature pwasite -URL http://server.domain.us/PWA
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:
       SPCmdletEnableFeature) [Enable-SPFeature], SPException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
       ature

    Thursday, September 10, 2015 9:15 AM

All replies

  • Yes, I have exactly the same problem! Maybe it's because of the "Single Server Farm" minrole that I chose when installing SharePoint. I found that I could not start the Project Server Application Service, and had to convert to the Custom role in able to start the service.

    Erik


    Erik RHS

    Friday, September 18, 2015 8:40 PM
  • Hi Erik,

    I did the steps you mentioned - convert role, start service and create service application. They were shown as running correctly. However, I was not able to create the content DBs correctly. I'll report to SP 2016 Preview forums.

    Best regards,
    Adrian

    Monday, September 21, 2015 4:31 AM
  • Thanks Adrian, I'll check that forum for your post!

    Erik RHS

    Monday, September 21, 2015 8:40 PM
  • Fixed in RTM
    Sunday, July 3, 2016 7:55 PM