locked
OWA Error After .Net 3.0 update RRS feed

  • Question

  • This is what comes up when I try and go to webbased outlook. any ideas?

     

    HTTP Error 500.0 - Internal Server Error

    Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" failed

    <fieldset><legend>Detailed Error Information</legend>
    Module IIS Web Core
    Notification Unknown
    Handler AboMapperCustom-88333
    Error Code 0x800700c1
    Requested URL http://10.240.116.1:80/exchange
    Physical Path \\.\BackOfficeStorage\cmha-east.on.ca\MBX
    Logon Method Not yet determined
    Logon User Not yet determined
    </fieldset>

     
    Thanks, Peter Labelle


     
     
     

    Monday, May 30, 2011 6:15 PM

Answers

  • UPDATE ok If i change these two isapifilters in the applicationhost.config it fixes my problem.

    <isapiFilters>
                    <clear />
                    <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64"/>
                    <filter name="Exchange ActiveSync ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\sync\bin\AirFilter.dll" enabled="true" preCondition="bitness64"/ />
                </isapiFilters>

    I needed to add a bitness64 precondition

    • Marked as answer by Peter Labelle Tuesday, June 7, 2011 3:33 PM
    Tuesday, June 7, 2011 3:33 PM

All replies

  • Open IIS Manager, go to application pools, select the one used for OWA, right click sele ct advanced properties, Set enable 32 bit applications to True, restart IIS
    With kind regards
    Krystian Zieja
    http://www.projectnenvision.com
    Follow me on twitter
    My Blog
    Monday, May 30, 2011 6:35 PM
  • I have done as you said. enable 32 bit applications was already set to true.

    under general I have

    .NET Framwork version = V2.0

    Enable 32 bit applications = True

    Managed Pipeline mode = Classic

    Name = MSExchangeOWAAppPool

    Queue Length = 1000

    Start Automatically = True

     

    Any other Ideas?

     

    Peter


    Monday, May 30, 2011 7:25 PM
  • Hi Peter,

     

    Make sure you use 32 bit dll for 32 bit application pool, and 64 bit for 64 bit application pool.

     

    After confirm your setting is right, please have a look for this similar threads, hope can give you some help:

     

    Thread: HTTP Error 500.0 - Internal Server Error in owa

    http://forums.iis.net/t/1163198.aspx

     

    exchange 2007 sp1 kills my iis application how to fix?

    http://forums.iis.net/t/1149050.aspx

     

    I also suggest you paste the related information (in your event log) in your next post.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 31, 2011 7:26 AM
  • UPDATE ok If i change these two isapifilters in the applicationhost.config it fixes my problem.

    <isapiFilters>
                    <clear />
                    <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64"/>
                    <filter name="Exchange ActiveSync ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\sync\bin\AirFilter.dll" enabled="true" preCondition="bitness64"/ />
                </isapiFilters>

    I needed to add a bitness64 precondition

    • Marked as answer by Peter Labelle Tuesday, June 7, 2011 3:33 PM
    Tuesday, June 7, 2011 3:33 PM
  • I have resolved the owaauth.dll" and AirFilter.dll" erros by adding the bitness64 precondition to the applicationhost.config file. now if I go to http://10.240.116.1/owa/ it asks me to login then throws up a blank page with a blue line down the left side of the page. where the separator between mail folders and emails would be.

    if I go to localhost/exchange i get what is below.   any ideas?

    HTTP Error 500.0 - Internal Server Error

    The page cannot be displayed because an internal server error has occurred.

    Detailed Error Information
    Module IsapiModule
    Notification ExecuteRequestHandler
    Handler AboMapperCustom-88333
    Error Code 0x800700c1
    Requested URL http://10.240.116.1:80/exchange
    Physical Path \\.\BackOfficeStorage\cmha-east.on.ca\MBX
    Logon Method Negotiate
    Logon User cmha\labellep
    Tuesday, June 7, 2011 4:09 PM
  • Hi Peter,

     

    For this issue, I suggest you follow these steps to troubleshoot the problem:

     

    1.       Please follow this kb to check for your issue (resolution 4).

     

    Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 500.0 – Internal Server Error"

    http://support.microsoft.com/kb/942031#top

     

    2.       Since you have changed “Enable 32-Bit Applicantions” to true, I suggest you change it back and then check for the issue. (restart the IIS after you change the value)

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, June 8, 2011 3:24 AM