locked
WAP server throwing--> Connection to the bachend server failed. Error: 0x80072ee2 RRS feed

  • Question

  • Hello Experts,

    I have a client who is running WAP 2012R2 and have an onprem app federated with ADFS. Auth is working fine. But the WAP servers throwing lot of "Connection to the bachend server failed.  Error: 0x80072ee2".

    We disabled URL translation as both Application External and Backed URL is same.

    Published Application External URL: https://abcd.xyz.com/
    Published Backend URL: https://abcd.xyz.com/

     

    But still no hope, on the network captures we saw that WAP is sending RST to the Application.

    Kindly suggest!

    Thank you,

    Regards,

    CreedHameed


    CreedHameed

    Tuesday, January 8, 2019 9:15 PM

All replies

  • Hello, can you go to the event log on the WAP server and post the error/warning ID an message? Are there other ADFS Relying party trust on the server and are they having the same issue? This seem like your WAP server is not able to connect to the ADFS server. Did you add the primary ADFS IP to the host file of the WAP?

    Isaac Oben MCITP:EA, MCSE,MCC <a href="https://www.mcpvirtualbusinesscard.com/VBCServer/4a046848-4b33-4a28-b254-e5b01e29693e/interactivecard"> View my MCP Certifications</a>

    Wednesday, January 9, 2019 5:02 AM
  • All relying parties works fine including this one but it generates a lot of 13006 and 13015 events like 10000 in one hour.  Kindly suggest!

    Event 13015

    Web Application Proxy received a request with an expired access cookie. 
    The access cookie expired at: ‎2018‎-‎08‎-‎22T16:26:02.000000000Z.

    Details:
    Transaction ID: {2a8d5dd2-2736-0000-c1a1-ce2b3627d401}
    Session ID: {2a8d5dd2-2736-0000-f5e7-c92b3627d401}
    Published Application Name: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Published Application ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Published Application External URL: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Published Backend URL: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    User: <Unknown>
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
    Device ID: <Not Applicable>
    Token State: NotFound
    Cookie State: Expired
    Client Request URL:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Backend Request URL: <Not Applicable>
    Preauthentication Flow: <Not Applicable>
    Backend Server Authentication Mode: 
    State Machine State: Idle
    Response Code to Client: <Not Applicable>
    Response Message to Client: <Not Applicable>
    Client Certificate Issuer: <Not Found>
    Response Code from Backend: %21
    Frontend Response Location Header: %22
    Backend Response Location Header: %23
    Backend Request Http Verb: %24
    Client Request Http Verb: %25

    Event 13006

    The following information was included with the event: 

    (0x80072ef1)
    EV_RenderedValue_1.00
    EV_RenderedValue_2.00
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
    <Not Applicable>
    NotFound
    OK
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/xxxxxxxxxxxxx.css
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/xxxxxxxxxxxxxxxxxxxx.css
    PreAuthBrowser
    PassThrough
    FEBodyWriting
    200
    OK
    <Not Found>

    the message resource is present but the message is not found in the string/message table


    CreedHameed

    Tuesday, January 22, 2019 6:20 PM