locked
Server 2016 - Unable to Add RSAT Role - The Referenced Assembly could not be found. Error: 0x80073701 RRS feed

  • Question

  • Hi there, 

    After some outside opinion on this one as i'm finding lots of resources online but none are a close enough fit for the solutions to work. 

    In short we have a Server 2016 template which is working fine, we can deploy VMs from it add roles, apply windows updates and everything is fine. If we then revisit and try and add new roles we have issues and get the error: The Referenced Assembly could not be found. Error: 0x80073701. 

    Now in the case of my current server i've narrowed it down to just being the Remote Server Administration Tools > DNS Server Tools that is the problem role. 

    Other instances i've found online mention checking the language packs of files that have been installed and see if these are both installed, being reported in error logs (CBS.log) and even look to removing from registry. 

    I've tried running the following commands (that both complete without issue):

    DISM.exe /Online /Cleanup-image /Restorehealth

    sfc /scannow

    Another solution suggested checking the following location in the registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect) for language packs referenced in the CBS.log, however i only seem to fine 'Native' rather than a specific region referenced. 

    I've attempted to install via GUI, Powershell and Command line, all of which fail with the same (or a variation of) error code.

    Section in the CBS log that i believe relates to the issue is below:

    2019-02-28 11:39:43, Error                 CSI    00001a8e (F) STATUS_SXS_ASSEMBLY_MISSING #5012934# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
    2019-02-28 11:39:43, Error                 CSI    00001a8f (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #5008383# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = 8d9d8d12592c2db7420f8ca8682e1c85, version 10.0.14393.953, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35}, cb = (null), s = (null), rid = 'Package_4458_for_KB4088787~31bf3856ad364e35~amd64~~10.0.1.2.4088787-8692_neutral', rah = '2', manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
    2019-02-28 11:39:43, Info                  CBS    Failed to pin deployment while resolving Update: Package_4458_for_KB4088787~31bf3856ad364e35~amd64~~10.0.1.2.4088787-8692_neutral from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2019-02-28 11:39:43, Info                  CBS    Failed to bulk stage deployment manifest and pin deployment for package:Package_4967_for_KB4480961~31bf3856ad364e35~amd64~~10.0.1.3 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2019-02-28 11:39:43, Info                  CBS    CommitPackagesState: Started persisting state of packages
    2019-02-28 11:39:43, Info                  CBS    CommitPackagesState: Completed persisting state of packages
    2019-02-28 11:39:43, Info                  CSI    00001a90@2019/2/28:11:39:43.480 CSI Transaction @0x187ea4cd930 destroyed

    I attempted to start uninstalling the KB packages referenced (with a view to manually reinstall) but after 4 packages removed and not being able to directly install them again manually (only WSUS package being shown) i haven't removed any more as yet.

    I have been able to add the 'DNS Server' role without issue so at the moment its purely the RSAT tools, again i've tried looking for a manual download/install/source file for these specifically for Server 2016 to no avail. 

    Any help would be greatly appreciated as most of the links i'm now finding in Google are purple. Let me know if any more logs / info is needed for information / troubleshooting. 

    Thanks, Wayne

    Monday, March 4, 2019 9:04 AM

All replies