locked
Microsoft App-V Client service fails to start RRS feed

  • Question

  • Hi Everyone,

    We have App-V client installed on Windows 2012 R2 RDS session host server. Since one week, the App-V client service is not starting with the below error:

    The Microsoft App-V Client service terminated with the following service-specific error:
    One or more arguments are invalid

    Any help will be greatly appreciated!

    Regards,
    Ankur Mazumdar.

    Sunday, April 24, 2016 7:40 PM

All replies

  • What version of App-V Client are you using? Try with the latest Hotfixes.If not try re-installing.

    Any traces in the eventviewer logs?


    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, April 25, 2016 4:09 AM
  • Please take a look HERE. Just want to check if you have removed any of the AppV packages from the Package Cache. If yes, please also remove the appropriate registry entries under the hive HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Packages.

    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Thursday, April 28, 2016 6:28 PM
  • What is your PackageInstallationRoot set to and what are the NTFS permissions?

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Saturday, May 21, 2016 5:00 AM
  • Please provide us with the associated EventIDs that are being generated.  Thanks!
    Friday, May 27, 2016 1:26 AM
    Moderator