none
Unable to open performancepoint designer dashboard RRS feed

  • Question

  • Hi All

    We are facing an issue in our project server 2013 environment, where users are unable to open PerformancePoint designer dashboard on their PCs. Client OS is windows 7 SP1. When they click on PerformancePoint designer, it initiates a pre-requisites check, and then fails. Below is the error message:

    OPERATION PROGRESS STATUS
     * [4/30/2015 5:51:56 PM] : Activation of http://pwa.contoso.com/_layouts/15/ppsma/1033/designer.application?Operation=OpenWebsite&SiteCollection=http://pwa.contoso.com/PWA&SiteLocation=pps%20demo has started.
     * [4/30/2015 5:51:58 PM] : Processing of deployment manifest has successfully completed.
     * [4/30/2015 5:51:58 PM] : Installation of the application has started.

    Following errors were detected during this operation.
     * [4/30/2015 5:51:59 PM] System.InvalidCastException
      - Specified cast is not valid.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.DownloadManager.VerifyRequestedPrivilegesSupport(String requestedExecutionLevel)
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
       at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    Designer opens fine on the servers, where the project farm is configured. Any pointers or ideas why this is happening, would be appreciated.

    Thanks

    Mohit

    Friday, May 1, 2015 9:41 AM

Answers

  • Hi All

    We opened a ticket with Microsoft Support for this issue. We seem to have found the blocking issue. In local security policy, there is a UAC setting named “User Account Control: Turn on Admin Approval Mode”. It describes itself as “This policy setting controls the behavior of all User Account Control (UAC) policy settings for the computer. If you change this policy setting, you must restart your computer.”

    This setting was left undefined for some reason. If we enable or disable this setting, we can open PPS designer fine.


    Thanks Mohit

    • Marked as answer by mohit.goyal Tuesday, June 2, 2015 9:49 AM
    Tuesday, June 2, 2015 9:32 AM