locked
Cannot open exe files on external hard drive RRS feed

  • Question

  • I am running Windows 10 Anniversary update via BootCamp on an iMac.

    Any time I try to open an exe file from my external hard drive I get the following error message:

    "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

    I can open any other file type on the external (pdf, jpg, doc, docx, html, etc.) the issue exists ONLY with exe files. This is why I don't think this is a permissions issue. I can open exe files stored on my C: drive, so the issue isn't global. If I move a folder containing the exe file from the external to the C: drive I can open the files, this confirms they are not corrupt. 

    Things I have already tried before coming here:

    • In spite of my better judgement I have changed the ownership of the drive to my admin account, and to everyone. This doesn't make any difference. 
    • I have dismounted the drive and changed the drive letter.
    • I have scanned for viruses and malware.
    • I have tried a couple of exe registry edits
    • I am in the process of running a scan with the SFC but I doubt this will have a positive effect

    I have this sneaking suspicion that this is tied to Windows Defender or some Windows application creating a security policy somewhere that prevents exe files from running from external drives. If anyone knows where I could look to check for something like that, I'd greatly appreciate the info so I can put that suspicion to bed.

    Update:

    I have since tried Command prompt: 

    • takeown /r /d y /f H:
    • icacls H: /t /grant Everyone:F

    Neither of the above resolved the issue and I am still getting the original error message. However I noticed today, right clicking the drive and selecting properties provides me with the same options, tabs, and buttons that are available for the root directory's properties. Is it possible my drive has somehow been converted to / inherited properties of a bootable drive?

    Smart Screen Filter is: Off
    Sunday, August 21, 2016 10:03 PM

All replies

  • kindly go through the following kb article:

    https://support.microsoft.com/en-us/kb/2669244


    S.Sengupta, Windows Insider MVP

    Sunday, August 21, 2016 10:54 PM
  • Well do not get this, can be enable by Group Policy, so on the off chance check that is not set,

    Computer > Administrative Templates > System > Removable Storage Access > Removable Disks: Deny Execute Access (source How can I stop .exe's being ran from removeable media, such as USB drives? needed a reboot to active that on my system)

    That does get set in the registry, HKLM\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}!Deny_Execute  (source Removable Disks: Deny execute access )

    If this device is in domain check 'rsop' (resultant set of polices) to see if it is being set.


    • Edited by -Mr Happy- Sunday, August 21, 2016 11:04 PM
    Sunday, August 21, 2016 11:03 PM
  • Thank you for your suggestion but I have been through these steps more than once.
    Thursday, August 25, 2016 1:08 PM
  • Thank you for this recommendation, I found that article moments after creating my post. Sadly, this did not resolve the issue.
    Thursday, August 25, 2016 1:10 PM
  • The external hard drive is not perhaps connected via Ethernet (a NAS)?
    Thursday, August 25, 2016 4:11 PM
  • No. USB 3.0
    Saturday, August 27, 2016 9:39 PM