locked
Trying to install software to a mapped network drive. RRS feed

  • Question

  • I got a task to upgrade a software for one of my user. The software has been installed on a mapped network drive but when running the setup to start the upgrade I can only get the option to choose C: and not the mapped network drive as installation directory.

    I have checked via CMD with net use that the drive is mapped and it is visable in Windows Explorer. I have also tried to run the setup as administrator with an user account that has admin rights on the computer.

    I've started CMD as admin with the same account and mapped the correct network map but when I run the Setup.exe i still only can see the C: and not manually choose or write in the S: which the mapped network drive has been given.

    I have also tried to logon to the computer with an admin account, mapped the networkdrive to S: and run the setup but not the S: is not shown in the installation setup.

    Would be greatful if someone can have suggestions if it is possible or if it could be the installation setup that is limited to only show C:

    When they did the same upgrade of the same software 6-7 months ago they apparently got the installation to end up on the S: network drive but this time around it seems impossible.

    Wednesday, April 24, 2019 2:48 PM

Answers

All replies

  • When the window pops-up that asks you to choose the path, I'm assuming it isn't a file explorer window that let's you type in the UNC path into the address bar?
    Wednesday, April 24, 2019 3:09 PM
  • If I write the UNC path I only get an error message that the drive or path can't be found. 
    I can click browse but then I can only choose to browse in C: not the mapped network drives. Those are not shown.

    Wednesday, April 24, 2019 3:17 PM
  • Does the folder you are trying to access have a space in the name?  For example: \\server\folder\This folder.  If so, make sure to put a "\" at the end, because Windows could be seeing it as \\server\folder\This.
    Wednesday, April 24, 2019 3:33 PM
  • Does the folder you are trying to access have a space in the name?  For example: \\server\folder\This folder.  If so, make sure to put a "\" at the end, because Windows could be seeing it as \\server\folder\This.

    Nope, no spaces in the path.

    I tried to run the setup again and it is not possible to write the path manually, you can only click browse and browse for folders. 

    The mapped drive should be shown along with C: according to the information i have gathered. The person who did this upgrade last time is no longer at the company and didn't create any documentation.

    Wednesday, April 24, 2019 3:43 PM
  • did you run the admin console elevated, then mapped the drive, then called the setup from the elevated console?
    Mapped Network Drive Not Showing in the Elevated Apps
    Wednesday, April 24, 2019 4:41 PM

  • Thank you EckiS

    When I executed the setup.exe from the console I get the option to choose the mapped drive instead of C: so that solved the problem. Why I didn't consider this myself, i dont know.

    Thursday, April 25, 2019 12:58 PM
  • Hi,

    I am glad to hear that your issue was successfully resolved. If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,
    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 26, 2019 8:53 AM