locked
AutoPlay does not work for USB devices in Windows 7 RRS feed

  • Question

  • When I insert a usb memory stick or usb hard disc Autoplay does not run although the devices are shown in My Computer
    Saturday, February 27, 2010 4:42 PM

Answers

  • Windows 7 removes Autoplay for USB devices. Only CD/DVD has Autoplay! This was changed by MS to make Windows more secure. Conficker used USB device autoplay to infect a lot of PCs.

    Read more in the following blog:
    http://blogs.msdn.com/e7/archive/2009/04/27/improvements-to-autoplay.aspx

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, February 27, 2010 6:39 PM

All replies

  • Hi,

    Have you installed W7 virtual PC, if yes it disables Autoplay.
    Please bear in mind, that my answer is based on the details given in your post. The more I get the better the answer, Slan go foill, Paul
    Saturday, February 27, 2010 5:28 PM
  • Try accessing the group policy settings:

    Start>gpedit.msc

    >Computer Configuration
    >Administrative Templates
    >System

    You will see an item in the right side pane called “Turn off Autoplay”

    Double click this item and see if it is enabled.
    I want to be a MVP! | Computer Technician
    • Proposed as answer by banmenau Saturday, February 27, 2010 6:33 PM
    Saturday, February 27, 2010 6:33 PM
  • Windows 7 removes Autoplay for USB devices. Only CD/DVD has Autoplay! This was changed by MS to make Windows more secure. Conficker used USB device autoplay to infect a lot of PCs.

    Read more in the following blog:
    http://blogs.msdn.com/e7/archive/2009/04/27/improvements-to-autoplay.aspx

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, February 27, 2010 6:39 PM
  • No I have not installed W7 virtual PC
    Sunday, February 28, 2010 4:54 PM
  • read my answer ;)
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, February 28, 2010 10:49 PM
  • Try accessing the group policy settings:

    Start>gpedit.msc

    >Computer Configuration
    >Administrative Templates
    >System

    You will see an item in the right side pane called “Turn off Autoplay”

    Double click this item and see if it is enabled.
    I want to be a MVP! | Computer Technician

    I used the same way to get my autoplay to show up. I followed the rule that you wrote, but it was not there. I kept exploring and found out how to enable it.

    Start>gpedit.msc

    >Computer Configuration

    >Administrative Templates

    >Windows Components

    >AutoPlay Policies

    "Turn off Autoplay"=set to "Not configured", "Don't set the always do this checkbox"=set to "Enabled", Turn off Autoplay for non-volume devices"=set to "Not configured", "Default behavior for AutoRun"=set to "Not configured"

    This helped me get AutoPlay back for my USB Drives.

    Saturday, November 24, 2012 3:38 AM