locked
winrm config readonly? RRS feed

  • Question

  • when i do this:
    PS C:\Windows\system32> Set-WSManInstance  -ResourceURI winrm/config/service/DefaultPorts -Value @{HTTP="8172"}
    I get that exception:
    Set-WSManInstance : The WinRM client cannot process the request because it is trying to update a read-only setting. Rem
    ove this setting from the command and try again.
    At line:1 char:18
    + Set-WSManInstance <<<<   -ResourceURI winrm/config/service/DefaultPorts -Value @{HTTP="8172"}
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManInstance], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManInstanceCommand
    Monday, September 12, 2011 1:16 PM

Answers

  • I used this command with another port and works fine...

    set-item wsman:\localhost\listener\listener*\port -value 8173

    but, the most strange is the fact: there aren't anything running in that port!!!

    but this serer have message queue services... I don't know if this bring problems in that port.

    thx guys

    • Marked as answer by Eduardo Spaki Monday, September 12, 2011 6:31 PM
    Monday, September 12, 2011 6:31 PM

All replies

  • When I do it:
    C:\Windows\system32>winrm set winrm/config/Listener?Address=*+Transport=HTTP @{Port="8172"}
    I get this:
    WSManFault
        Message
            ProviderFault
                WSManFault
                    Message = The function: "HttpSetServiceConfiguration" failed une
    xpectedly. Error=183.
    Error number:  -2147024713 0x800700B7
    Monday, September 12, 2011 1:59 PM
  • Try - winrm create winrm/config/Listener?Address=*+Transport=HTTP @{}
    Monday, September 12, 2011 2:15 PM
  • C:\Windows\system32>winrm create winrm/config/Listener?Address=*+Transport=HTTP
    @{}
    WSManFault
        Message
            ProviderFault
                WSManFault
                    Message = The WS-Management service cannot perform the configura
    tion operation. A listener with Address=* and Transport=HTTP configuration alrea
    dy exists. You have to delete the existing listener first in order to be able to
     create it with the same Address and Transport values.
    Error number:  -2144108493 0x80338033
    The WS-Management service cannot create the resource because it already exists.
    Monday, September 12, 2011 2:18 PM
  • Show - winrm enumerate winrm/config/listener
    Monday, September 12, 2011 2:23 PM
  • C:\Windows\system32>winrm enumerate winrm/config/listener
    Listener
        Address = *
        Transport = HTTP
        Port = 5985
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 10.11.12.132, 127.0.0.1, 187.61.9.xxx, ::1, 2002:bb3d:9a4::bb3
    d:9a4, fe80::100:7f:fffe%15, fe80::5efe:10.11.12.132%12, fe80::200:5efe:187.61.9
    .xxx%13
    Monday, September 12, 2011 2:25 PM
  • Are you run as administrator?
    • Edited by Kazun Monday, September 12, 2011 2:43 PM
    Monday, September 12, 2011 2:41 PM
  • run as administrator:
    C:\Windows\system32>winrm set winrm/config/Listener?Address=*+Transport=HTTP @{P
    ort="8172"}
    WSManFault
        Message
            ProviderFault
                WSManFault
                    Message = The function: "HttpSetServiceConfiguration" failed une
    xpectedly. Error=183.
    Error number:  -2147024713 0x800700B7
    Cannot create a file when that file already exists.
    Monday, September 12, 2011 2:43 PM
  • are you running the prompt elevated? (if its win7/2k8)
     
    not sure that’s the problem, but worth checking.
     
     

    Justin Rich
    http://jrich523.wordpress.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, September 12, 2011 2:44 PM
  • yes, I click in "run as administrator"
    Monday, September 12, 2011 2:47 PM
  • winrm delete winrm/config/Listener?Address=*+Transport=HTTP
    winrm create winrm/config/Listener?Address=*+Transport=HTTP
    winrm set winrm/config/Listener?Address=*+Transport=HTTP @{Port="8172"}
    


    Monday, September 12, 2011 2:49 PM
  • C:\Windows\system32>winrm delete winrm/config/Listener?Address=*+Transport=HTTP
    C:\Windows\system32>winrm create winrm/config/Listener?Address=*+Transport=HTTP
    ResourceCreated
        Address = http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous
        ReferenceParameters
            ResourceURI = http://schemas.microsoft.com/wbem/wsman/1/config/listener
            SelectorSet
                Selector: Address = *, Transport = HTTP
    C:\Windows\system32>winrm set winrm/config/Listener?Address=*+Transport=HTTP @{P
    ort="8172"}
    WSManFault
        Message
            ProviderFault
                WSManFault
                    Message = The function: "HttpSetServiceConfiguration" failed une
    xpectedly. Error=183.
    Error number:  -2147024713 0x800700B7
    Cannot create a file when that file already exists.
    Monday, September 12, 2011 2:52 PM
  • I used this command with another port and works fine...

    set-item wsman:\localhost\listener\listener*\port -value 8173

    but, the most strange is the fact: there aren't anything running in that port!!!

    but this serer have message queue services... I don't know if this bring problems in that port.

    thx guys

    • Marked as answer by Eduardo Spaki Monday, September 12, 2011 6:31 PM
    Monday, September 12, 2011 6:31 PM
  • I think there is a config file some place that has that info (SPN perhaps)
    and that’s whats preventing you from doing it?
     
     

    Justin Rich
    http://jrich523.wordpress.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, September 12, 2011 6:56 PM
  • when i do this:
    PS C:\Windows\system32> Set-WSManInstance  -ResourceURI winrm/config/service/DefaultPorts -Value @{HTTP="8172"}
    I get that exception:
    Set-WSManInstance : The WinRM client cannot process the request because it is trying to update a read-only setting. Rem
    ove this setting from the command and try again.
    At line:1 char:18
    + Set-WSManInstance <<<<   -ResourceURI winrm/config/service/DefaultPorts -Value @{HTTP="8172"}
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManInstance], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManInstanceCommand

    Hi there, hope it helps many people.

    I recently have made winrm + HTTPS.

    LOT's of errors on this step is realted with the following : the certificate installed in the system MUST have private key. it can by checked as so: mmc certificates - local machine - personal . look at the icon of the certificate - it MUST have key sign on it.

    Thursday, November 20, 2014 12:41 PM