none
Add Enterprise Custom Field to Project Schedule Template in Project Server 2010 RRS feed

  • Question

  • I have created a new Enterprise Custom field in Project Server 2010 called "tracking_nbr". I want to add this new Enterprise Custom Field to an exisiting schedule template I have on PS 2010.

    I have added the field to the Enterprise Global template & it appears on the EGT when I open it in Project Pro 2010. So I added the new "tracking_nbr" field to the enterprise globabl template and when I open the EGT I can see the "tracking_nbr" field on the schedule.

    However, when I open the existing schedule template in Project Pro 2010 that I want to modify & add the new field, I get the following message "Edits will not be saved. Any edits made to the Enterprise Global Template items are only available during this session. Make edits in checked-out enterprise global to make them available to all users of this Project Server". This error confuses me because I have added the Enterprise Custom field to the enterprise global template.

    Any help would be appreciated. I may be totally misunderstanding the use Enterprise Custom fields & their relevance to Project Schedule templates.

    Friday, April 20, 2012 3:05 PM

Answers

All replies

  • Hi there,

    Have you added the new field to the required views in the Enterprise Global? Once these have been added to the required views in the EG you will not need to insert the field when you open the Project and switch to that view in Project Pro 2010.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Friday, April 20, 2012 3:50 PM
    Moderator
  • Check the view in the Enterprise Global like Paul mention.

    If it is OK, you can also try cleaning the cache.


    Juan Pablo.
    surpoint.blogspot.com
    jpussacq.me
    @jpussacq

    Friday, April 20, 2012 8:20 PM
  • As some background info:

    The field you added was available to be added to views as soon as you added it in the Server Settings in PWA. You did not need to open the global and 'add' it there.

    the reason you are getting this message is that you have opened a project and are now trying ot add the field to an Enterprise View in Project Pro. those views can only be edited while you have the Enterprise global checked out.

    So as Paul mentioned, open the Enterprise Global again, go to the Enterprise view you were trying to edit when you got that error, add your new field, save and close and then close Project Pro.

    Now that field will be visible in that Enterprise view for ALL projects. You will NOT need to go add it to any specific project templates because it will be part of the view itself.


    Brian Kennemer - Project MVP
    DeltaBahn Senior Architect
    endlessly obsessing about Project Server…so that you don’t have to.
    Blog | Twitter | LinkedIn

    Saturday, April 21, 2012 4:02 PM
    Moderator
  • Thank you Paul, Juan & Brian. It was indeed the view in the Enterprise Global that was tripping me up. I changed the view in Enteprise Global. I am new to Project Server & still trying to figure out how all of the pieces fit together. This helps clear up how the views relate to future projects.
    Monday, April 23, 2012 1:48 PM
  • Hi there,

    No problem, glad to have helped :)

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Monday, April 23, 2012 1:57 PM
    Moderator
  • :-) you're welcome!

    Juan Pablo.
    surpoint.blogspot.com
    jpussacq.me
    @jpussacq

    Monday, April 23, 2012 3:45 PM