locked
010000001D "Internal AppV Integration error: Package not integrated for the user" RRS feed

  • Question

  • 
    

    HI

    We're using VDI environment with App-V 5.0 SP2 HF4

    Our problem is that sometimes clients just don't get an application shortcut and I can't figure out why.

    it doesn't happen with a specific package or on a specific master image, but if I didn't get the package on a certain image I can sometimes get it on another image

    • Server sync finishes successfully
    • There is no error in the event viewer
    • user is local admin
    • I tried to delete all the current packages and "reset cache" and get all the packages again - same result
    • when I check the package details on powershell - I see it! and it says IsPublishedToUser=True

    when I try to repair the package I get the folowing error:

    Internal AppV Integration error: Package not integrated for the user. please ensure the package is added to the machine and published to the user.
    Opration Attempted: Repair Package
    AppV Error Code: 01000001D

    another thing I should mention, we use folder redirection for APPDATA

    I tried to run procmon while repairing the package and I saw this:

    
    
    

    When I go to the process details of this action, it is done with the NT Authority\SYSTEM account, who obviously doesn't have permissions on our profiles' storage!

    don't if it is related to the error I see in powershell but I figured it is important to get all the details


    Tamir Levy

    Wednesday, November 26, 2014 3:13 PM

Answers

  • Might I suggest redirecting the App-V Client Configuration item IntegrationRootUser in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\Integration to another location?

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Wednesday, November 26, 2014 6:19 PM

All replies