none
dhcp server error on sbs 2011

    Question

  • Dhcp server cannot start on sbs 2011.

    We have 2 dhcp error

    event id 1050--The DHCP/BINL service on the local machine encountered a network error. The error was: 0x 2.

    event id 1054-

    The DHCP/BINL service on this computer is shutting down. See the previous event log messages for reasons.


    gary zhou

    Tuesday, March 13, 2012 11:23 PM

Answers

  • Hi gary,

    Thank you for the post.

    Please try suggestions below to troubleshooting:
    1.Ensure no DHCP enabled on the router or another server, run the "Connect to the Internet" wizard in SBS2011 console
    2.Run "fix my network" wizard in SBS2011 console to fix other network error
    3.Ensure you NIC configuration set correctly, please post ipconfig/all result to us for analysis

    If there are more inquiries on this issue, please feel free to let us know.

    Regards


    Rick Tan

    TechNet Community Support

    Wednesday, March 14, 2012 8:54 AM
    Moderator
  • Hi Gary,

    Just incase if you want to run the Connect to the internet wizard, creating this registry will help in running the wizard

    To enable rogue detection

    1. Click Start, type regedit in Start Search, click Yes in User Account Control if prompted, and then press ENTER.

    2. In the registry tree, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\DHCPServer\Parameters.

    3. Right-click DisableRogueDetection and then click Modify…

    4. In Value Data type 0 and then click OK.

    Alternatively you can check the following link

    http://technet.microsoft.com/en-us/library/ee941207(v=ws.10).aspx

    Thanks

    Wednesday, March 14, 2012 4:10 PM

All replies

  • Can you post back complete events?

    0x2 generally refers to file not found

    Can you also take a procmon trace while starting the service and up until it crashes and then share it via public interface of your sky drive?

    http://technet.microsoft.com/en-us/sysinternals/bb896645

    Wednesday, March 14, 2012 3:56 AM
  • Hi gary,

    Thank you for the post.

    Please try suggestions below to troubleshooting:
    1.Ensure no DHCP enabled on the router or another server, run the "Connect to the Internet" wizard in SBS2011 console
    2.Run "fix my network" wizard in SBS2011 console to fix other network error
    3.Ensure you NIC configuration set correctly, please post ipconfig/all result to us for analysis

    If there are more inquiries on this issue, please feel free to let us know.

    Regards


    Rick Tan

    TechNet Community Support

    Wednesday, March 14, 2012 8:54 AM
    Moderator
  • Hi Gary,

    Just incase if you want to run the Connect to the internet wizard, creating this registry will help in running the wizard

    To enable rogue detection

    1. Click Start, type regedit in Start Search, click Yes in User Account Control if prompted, and then press ENTER.

    2. In the registry tree, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\DHCPServer\Parameters.

    3. Right-click DisableRogueDetection and then click Modify…

    4. In Value Data type 0 and then click OK.

    Alternatively you can check the following link

    http://technet.microsoft.com/en-us/library/ee941207(v=ws.10).aspx

    Thanks

    Wednesday, March 14, 2012 4:10 PM