none
Robocopy bug

    Question

  • I am runing  window 7 32bit.  I run  robocopy to backup  files and dirs  – I noticed lately that the process is coping files that are not subject to copy, ie the source and target files are exactly the same – I use the /mir robocopy switch  

    When  roboopy copies a file from the source to the target, it will tag the copy in the log, ie “newer” “new files” “older”   - etc – in this case there is no tag on the copy log  and the summary at the end of the job reports all the source being copied. 

    I have windows 7 on other computer and this  operation works  correctly on those computers  – the only difference were this is not working it seems that version of windows 7 has fix  KB2639043 installed. 

    I went  as far as to write a program to show the 64 bit time stamp (both the modified and create times) and an compare them  on the source and target files and they are EXACTLY the same (the file size is also the same in both files) 

    Lastly, I tried “synctoy” and that “did the right thing” – so there is some sort of bug with robocopy  – How can I report this issue?   
    Tuesday, September 26, 2017 6:07 PM

All replies