locked
AppFabric-Induced Problems RRS feed

  • Question

  • My troubles started with trying to install AppFabric (not the Azure version) on VS Premium (On a 64-bit Windows 7 with 8 gig of memory).

    Not only it did not install (rror 0x80070643), but also put .Net 3.5.1 out of action. I cannot use Control Panel to turn features for WCF on, and cannot enable ".Net Environment" in "Windows Process Activation Service".

    I have spent the past few days to find a solution on the Web (including MSDN forums), to no avail. I have seen some hard-to-believe solutions (such as "too many language packs" or MS Live) which did not apply.

    Nevertheless, I tried some common-sense solutions (uninstall/repaire/install all dev-related components), but the problems refuse to go go away.

    Is there a solution beyond wiping out the OS and start all over again? This computer is rather new and chances of "long-use corruptions" are low. (I have run all MS diagnistics that I could find: Clean bill of health.) And even if I do re-install the OS and the myriad of applications, what is to guarantee that it would not happen again, since the cause is not clear in the first place?

    Appreciate any help.


    Hessam Ashrafi
    Tuesday, November 22, 2011 1:26 PM

All replies

  • Hi,

     

    Regarding the issue, please refer the following link and let me know whether you installed this AppFabric on your machine?

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=15848

     

    Since some component of AppFabric is based on Microsoft .NET Framework 4, I suggest that you may install it first. Then try to reinstall AppFabric again. Here is a link for Microsoft .NET Framework 4.

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17851

     

    If the problem persists, you please use “SFC /scannow” to scan the system file on your machine
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, November 24, 2011 10:31 AM
  • Thanks.

    1. I downloaded WindowsServerAppFabricSetup_x64_6.1.exe from exactly the site that you have identified.

    2. .Net framework 4 was there before I attempted AppFabric installation. I have been using it through Visual Studio (full version) for quaite a while.

    3. The machine (and .Net) is updated regularly, whenever Microsoft has an update.

    4. I run “SFC /scannow” regularly and it has yet to find any problems. I ran it again after your reply. Still "No integrity violation".

    5. I have unistalled/installed/repaired .Net 4, with the same results.

    Maybe I should uninstall every development-related item (VS, SQL Server, etc.) and re-install them. But I am not sure about (1) the order and (2) effect on applications that rely on .Net and I don't know about.


    Hessam Ashrafi
    Thursday, November 24, 2011 2:12 PM