none
Visio 2007 Error 126

    Question

  •  

    The exact error I am getting is:

    "An error (126) occurred during th eaction Save As.

    Visio cannot save the file you selected."

    whenever a user tries to do a "Save As" of a file into a network directory. They can do a save as if it's on their own computer, then move the file to the correct network location, but this can be an annoyance if you are working with many Visio files.

    I've checked the permissions on the folders, ran the program as an Administrator, turned off my firewall and anti-virus program, but nothing seems to work. I have also found no information on error 126.

     

    I noticed that there is a fix on Experts-Exchange, but I don't have a subscription.

     

    Here is the link to it:http://www.experts-exchange.com/Microsoft/Applications/Microsoft_Visio/Q_23089010.html

     

    Thanks!

    Wednesday, June 25, 2008 6:04 PM

Answers

  • Excluded vsd files on the server in Etrust.

     

    Go under:

    Client

    Policies

    Realtime, eTrust Antivirus

    Selection

    Regular Files, All Except the Specified Extensions (in the drop down box)

    Edit list

    type in vsd in the "Enter a new file extension" box

    click ok

    apply

     

     

    Seemed to work.

     

    Peter

     

     

     

    Thursday, July 3, 2008 7:31 PM

All replies

  • We have this same issue.  We have found that if you turn off the anti-virus real time monitor on the file server then it works.  We are using Etrust ITM 8.1.  We are currently talking to CA about this.  It would help if anyone at Technet could help us with this.

    Friday, June 27, 2008 8:26 AM
  • Excluded vsd files on the server in Etrust.

     

    Go under:

    Client

    Policies

    Realtime, eTrust Antivirus

    Selection

    Regular Files, All Except the Specified Extensions (in the drop down box)

    Edit list

    type in vsd in the "Enter a new file extension" box

    click ok

    apply

     

     

    Seemed to work.

     

    Peter

     

     

     

    Thursday, July 3, 2008 7:31 PM
  •  

    This is not an option as I want these files scanned for viruses.
    Friday, July 4, 2008 8:19 AM
  •  

    I am having the same problem also.  We use SpySweeper w/ Antivirus instead of eTrust.  I tried adding .vsd to the exclusion list, but I'm still having a problem.  I even made sure the network location was a trusted source in Office 2007.  Anyone ever find out anything from MS?  I'll take any help I can get!

    Thursday, August 7, 2008 1:25 PM
  • We have not got an answer yet, but CA have been looking into this and have even tried giving us a patch that worked temporarily, but failed after rebooting our file server.

    Thursday, August 7, 2008 1:28 PM
  • This is just a work around but what we did was save it locally and then copy it over to the network share.

    Worked for us.

    I also have a ticket in with CA.  I should not have to exclude the extension in order for it to save.

    Hope that helps.

    Thursday, August 6, 2009 2:46 PM
  • I had the same problem, the issue was caused due to lack of disk space in the server.
    • Proposed as answer by 002D Friday, October 26, 2018 4:14 PM
    Thursday, June 17, 2010 5:31 PM
  • I'm having the same issue where I get an error 126 when I save.   But I don't have eTrust on my server.   Saving the files to my local disk and then copying them over doesn't not sound fun at all.   Is there a better solution yet?  
    Thursday, October 21, 2010 11:54 PM
  • This solution worked for me as well - deleting some files made enough room, no more error.

    Wednesday, February 2, 2011 2:26 AM
  • I have someone getting this same error when she's working from home.  As far as I can tell it's because the uplink provided by DISH is only 700k and she's in a contract for another year and a half.
    Tuesday, April 15, 2014 3:13 PM