locked
Port Change for Gateway still using 443 when changed to another port RRS feed

  • Question

  • I have a weird issue. I changed the port from the default of 443 to 660. We port forward 660 to our remote desktop gateway server. This has been running for over a year with no issues. I have 443 still going to our mail server. We have just deployed a new Windows 2012 Exchange 2013 mail server. The old one was a Small business server with Exchange 2010. In the old setup all clients could connect to our RDweb site and connect through the gateway and start Personal Virtual Desktops. No issues. After deploying the new mail server, I moved the port forward for 443 to the new server. Upon doing this, the remote clients get an error that the gateway is not available. If I put 443 back to the old mail server it works again. I have found that there is a -CustomRdpProperty you can add through powershell and set gatewayhostname:s:<RDGW-FQDN>:<yourport>.  According to the post, RDMS does not change the default port for published Desktops.  So they were still going to 443.  What I am not sure about, is how in the heck did it still work with an older mail server, to forward the traffic to the Remote Desktop Gateway server.

    I have tried adding the customrdpproperty.  It didn't work.  I get an error about computer could not be found. 

    Has anyone dealt with this port issue with a Personal Virtual Desktop deployment?  Any help with the correct syntax for the powershell would be appreciated.

    Thanks

    Rick

    Friday, October 23, 2015 4:07 PM

Answers

All replies

  • I have a weird issue. I changed the port from the default of 443 to 660. We port forward 660 to our remote desktop gateway server. This has been running for over a year with no issues. I have 443 still going to our mail server. We have just deployed a new Windows 2012 Exchange 2013 mail server. The old one was a Small business server with Exchange 2010. In the old setup all clients could connect to our RDweb site and connect through the gateway and start Personal Virtual Desktops. No issues. After deploying the new mail server, I moved the port forward for 443 to the new server. Upon doing this, the remote clients get an error that the gateway is not available. If I put 443 back to the old mail server it works again.

    Hi Rick,

    To better troubleshoot this issue, I need more information regarding the scenario.

    On the firewall, only the port forwarding setting for the Exchange server, which is port 443 has been changed, and nothing has changed for the port 660, is that correct?

    Only the Exchange server was replaced, nothing related to RD Gateway was modified, is that right?

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 27, 2015 12:51 PM
  • We also moved ports 80 and 25 to the new mail server for mail flow purposes.  But to make the RDWeb connections work again, all I have to do is put 443 back to the old mail server and it starts working again.  Nothing on the RD Gateway server was modified. 

    thanks,

    Rick

    Tuesday, October 27, 2015 1:28 PM
  • Hi Rick,

    What’s the Operating System of your RDS server/servers?

    It is not supported to customize RD Gateway listening port on Windows Server 2008 R2 and previous systems, we can customize the port starting from Windows Server 2012.

    In addition, remote desktop clients must support RDP 8.0 or above for this to work.

    If all requirements are met, but it doesn’t work, please:

    1. verify modified RD Gateway listening port setting is applied through registry

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal  Server\CentralPublishedResources\PublishedFarms\<farmname> \DeploymentSettings

    2. unpublish all RemoteApp programs or desktops, then re-publish them.

    More information for you:

    Running RD Gateway on a different port then 443 (Windows Server 8)
    http://microsoftplatform.blogspot.com/2011/10/running-rd-gateway-on-different-port.html
    Changing the Default Port of RD Gateway in Windows Server 2012
    http://social.technet.microsoft.com/wiki/contents/articles/10972.changing-the-default-port-of-rd-gateway-in-windows-server-2012.aspx
    Remote Desktop Gateway Port
    https://social.technet.microsoft.com/forums/windowsserver/en-US/6ed0845a-1a51-4c05-8331-ece9c0eb73fa/remote-desktop-gateway-port

    Best Regards,
    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Amy Wang_ Monday, November 9, 2015 9:52 AM
    • Marked as answer by Amy Wang_ Monday, November 9, 2015 3:52 PM
    Wednesday, October 28, 2015 8:46 AM