locked
Service Manager HTML5 Self Service Portal opens on local host only RRS feed

  • Question

  • Service Manager HTML5 Self Service Portal opens on local host only.  The website will not open from another computer.  "This page cannot be displayed"

    Factors:

    Brand new install of Service Manager and HTML5 Self Service Portal on server 2012 R2 

    Portal virtual directory is C:\inetpub\wwwroot\SelfServicePortal with name IT Portal, bound to port 8080.  The Application Pool account has the Service Manger Admin role and administrator permissions.

    I imported the Portal.mpb management pack and installed the hotfix KB3124091.  I customized the name, email and phone information. 

    The Portal opens fine locally.  Why cant I open it from another computer?

    thank you,  KACouillard


    KACouillard

    Monday, January 4, 2016 1:04 PM

Answers

All replies

  • Hi,

    Is it ok for the default IIS web site ? (on port 80)

    Are you try with the FQDN and the IP adress ?

    Another thing : is it an Error 404 ?

    If not,

    Turn off the friendly error message option in the browser as follows:
    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. On the Advanced tab, under the Browsing section, click to clear the Show friendly HTTP error messages check box, and then click OK.
    3. Close the browser.


    Remy BOVI

    Monday, January 4, 2016 1:36 PM
  • Thank you for your response!

    1. yes, the default on port 80 works on another computer

    2. no, neither the FQDN or IP works. 

    3. no, not 404

    4. tried this, no change.  the error is "page cannot be displayed"

    Other ideas?


    KACouillard

    Monday, January 4, 2016 2:05 PM
  • Are you try to bind the default web site to another port and use the port 80 to SCSM portal ?

    Remy BOVI

    Monday, January 4, 2016 2:11 PM
  • No.  Default bound to 80.  SCSM portal bound to 8080

    c:\Windows\SysWOW64\inetsrv>appcmd list site

    SITE "Default Web Site" (id:1,bindings:http/*:80:,state:Started

    SITE "IT Portal" (id:2,bindings:http/*:8080:,state:Started)


    KACouillard

    Monday, January 4, 2016 3:16 PM
  • try to remove default IIS web site and change the SCSM portal binding from 8080 to 80 ...
    Silly question but : Do you have any firewall enable to the server ?


    Remy BOVI

    Monday, January 4, 2016 3:19 PM
  • Not silly at all, double checked, no firewall on.

    I changed the default to 8080, the SCSM to 80 and restarted IIS on both. 

    Default - works

    SCSM results:

    http://it%20portal/ - page cannot be found

    http://csd168.csd.local/it%20portal/ - The resource cannot be found.              Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.            

    Requested URL: /it portal/


    KACouillard

    Monday, January 4, 2016 3:30 PM
  • And just http://csd168.csd.local ?

    Remy BOVI

    • Proposed as answer by BOVI Rémy Monday, January 4, 2016 4:07 PM
    Monday, January 4, 2016 3:54 PM
  • Bingo! http://csd168.csd.local/ works, thank you!

    Now is this a clue to get http://it%20portal/ working?

    The SDKServerName is csd168.csd.local


    KACouillard


    • Edited by KACouillard Monday, January 4, 2016 4:05 PM
    Monday, January 4, 2016 3:59 PM
  • DNS entry necessary?


    KACouillard

    Monday, January 4, 2016 4:00 PM
  • Yes ! ;)

    Remy BOVI

    Monday, January 4, 2016 4:06 PM
  • ok!  Is it advisable to remove the space from the name?

    itportal instead of it portal, or does it matter?


    KACouillard

    Monday, January 4, 2016 4:16 PM
  • If you want only to change the display name on the top you can edit the web.config file here : C:\inetpub\wwwroot\SelfServicePortal (http://www.buchatech.com/2015/10/early-look-service-manager-html-5-portal/ )

    If you want to change the DNS name you can add a CNAME to your DNS :

    A
    11.22.33.444
    itportal
    CNAME


    Remy BOVI

    • Proposed as answer by BOVI Rémy Monday, January 4, 2016 4:31 PM
    • Marked as answer by KACouillard Monday, January 4, 2016 4:53 PM
    Monday, January 4, 2016 4:31 PM
  • Got it, problem solved!  Thank you Remy, this may have been the most productive TechNet experience I have ever had!

    KACouillard

    Monday, January 4, 2016 4:52 PM