none
DPM 2012 R2 SMB VM Backup (ID 2033 Details: A required privilege is not held by the client (0x80070522)) RRS feed

  • Question

  • Hi,

    I am encountering an error when trying to backup a VM in SMB share. The error was (ID 2033 Details: A required privilege is not held by the client (0x80070522)). 

    There is no VSS event logged on the host.

    Does anyone face this error before? Appreciate if anyone could help to enlighten.

    Thanks.

    Wednesday, November 26, 2014 9:22 AM

Answers

  • Hi Mike,

    It appears that the problem was due to DPM computer$ doesn't have rights on the SMB share. Once DPM computer$ assigned with rights to the SMB share, the problem immediately resolved.

    Thanks for your assistance. 

    • Marked as answer by RalphKoh Thursday, November 27, 2014 6:33 AM
    Thursday, November 27, 2014 6:04 AM
  • Hi,

    I don't recall ever bumping into that error before, but check all of the following.

    If trying to back up a VM data source that resides on the Server 2012 SMB, please check the following.

    Configure DPM backup for virtual machines using SMB storage
    http://technet.microsoft.com/en-us/library/hh757866.aspx#bkmk_protectvmwithsmb

    Make sure the Remote SMB file server prereqs are met:

    1) DPM Agent is required on all computers involved (Hyper-V server(s) and the SMB share server.
    2) You must Enable the "File Server VSS Agent Service" role on Remote SMB File server
    Add the role via Server manager\Tools\Add Role.  On the server role selection, expand:


         File and iScsi Services
               File and iScsi Services
                     File Server VSS Agent Service


    3) Hyper-V nodes and DPM server machine$ account should have full permissions on the specific Remote SMB File share.
    4) The cluster service account should have full permission on the specific Remote SMB file share
      NOTE: Accounts should be explicitly added and not embedded in other accounts as odd behavior has been observed when using groups. 
            This is not a requirement but simply something we have seen.

    Unsupported scenarios
    ===============

     Deployments where some components of the virtual machine are on local volumes and some on remote volumes.
     Using an IPv4 or IPv6 address for storage location file server is not supported.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by RalphKoh Thursday, November 27, 2014 6:02 AM
    Wednesday, November 26, 2014 6:44 PM
    Moderator

All replies

  • Hi,

    I am encountering an error when trying to backup a VM in SMB share. The error was (ID 2033 Details: A required privilege is not held by the client (0x80070522)). 

    There is no VSS event logged on the host.

    Does anyone face this error before? Appreciate if anyone could help to enlighten.

    Thanks.

    • Merged by Elton_Ji Thursday, November 27, 2014 7:13 AM duplicated
    Wednesday, November 26, 2014 9:15 AM
  • Hi,

    I don't recall ever bumping into that error before, but check all of the following.

    If trying to back up a VM data source that resides on the Server 2012 SMB, please check the following.

    Configure DPM backup for virtual machines using SMB storage
    http://technet.microsoft.com/en-us/library/hh757866.aspx#bkmk_protectvmwithsmb

    Make sure the Remote SMB file server prereqs are met:

    1) DPM Agent is required on all computers involved (Hyper-V server(s) and the SMB share server.
    2) You must Enable the "File Server VSS Agent Service" role on Remote SMB File server
    Add the role via Server manager\Tools\Add Role.  On the server role selection, expand:


         File and iScsi Services
               File and iScsi Services
                     File Server VSS Agent Service


    3) Hyper-V nodes and DPM server machine$ account should have full permissions on the specific Remote SMB File share.
    4) The cluster service account should have full permission on the specific Remote SMB file share
      NOTE: Accounts should be explicitly added and not embedded in other accounts as odd behavior has been observed when using groups. 
            This is not a requirement but simply something we have seen.

    Unsupported scenarios
    ===============

     Deployments where some components of the virtual machine are on local volumes and some on remote volumes.
     Using an IPv4 or IPv6 address for storage location file server is not supported.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by RalphKoh Thursday, November 27, 2014 6:02 AM
    Wednesday, November 26, 2014 6:44 PM
    Moderator
  • Hi Mike,

    It appears that the problem was due to DPM computer$ doesn't have rights on the SMB share. Once DPM computer$ assigned with rights to the SMB share, the problem immediately resolved.

    Thanks for your assistance. 

    • Marked as answer by RalphKoh Thursday, November 27, 2014 6:33 AM
    Thursday, November 27, 2014 6:04 AM
  • Old thread but there aren't that many around so for the next person that finds this...reboot the DPM server after adding the share permissions or you will be troubbleshooting in vain.
    Thursday, June 23, 2016 9:49 AM
  • Thanks. This helped for me too. You need to reboot the SMB (SOFS) servers for the computer object permission to take effect.

    Tuesday, July 5, 2016 1:41 PM