locked
WS 2016 TP4 (10586) Qualcomm Atheros AR9485 Wireless Network Adapter driver install error RRS feed

  • Question

  • Hardware driver error

    WS2016 driver INF file

    A Service installation section is invalid.

    Please just take the working driver from Windows 10 November (build 10240 to 10582) and get this working

    Wireless support is REALLY important. Its not to clever using version 3.0.1.181(C) 2001!

    error Reinstall the drivers for this device. (Code 18)

    Thursday, December 3, 2015 9:25 PM

Answers

  • Hi there. I just ran into the same problem today, and solved it instaling the Windows feature "Wireless LAN Service", rebooting the machine and after that, the network adapter showed as installed on device manager.I also manually started the "WLAN AutoConfig" service. Qualcomm Atheros AR9485 Wireless Network Adapter working fine on WS2016TP4.


    Rafael Monteiro

    • Proposed as answer by rafael9908 Tuesday, April 19, 2016 8:46 PM
    • Marked as answer by jims.halo10 Wednesday, April 20, 2016 1:35 PM
    Tuesday, April 19, 2016 7:53 PM
  • Hi,

    The window server 2016TP4 is a new operating system for window server.

    You could contact the NIC manufacturer to get more help.

    Thanks for your understanding.

    Best regards

    Andy_Pan


    • Edited by Hello_2018 Friday, December 4, 2015 9:58 AM
    • Marked as answer by jims.halo10 Friday, December 4, 2015 6:23 PM
    Friday, December 4, 2015 9:58 AM
  • Thanks

    Now it can work on WS2016

    I ignore reinstall driver

    because I think start the "WLAN AutoConfig" service after that the Network Adapter can working on WS2016

    Now I reinstall driver it can working on WS2016

    Moreover, my WS2016 is up to date,and BIOS isn't up to date,it can working.


    • Marked as answer by jims.halo10 Saturday, November 26, 2016 10:59 AM
    Saturday, November 26, 2016 6:46 AM

All replies

  • Drivers come from the NIC vendors, or from the OEM using the NIC. If you want this NIC to be supported on Windows Server 2016 you will need to contact Qualcomm.

    . : | : . : | : . tim

    Thursday, December 3, 2015 9:56 PM
  • Hi,

    The window server 2016TP4 is a new operating system for window server.

    You could contact the NIC manufacturer to get more help.

    Thanks for your understanding.

    Best regards

    Andy_Pan


    • Edited by Hello_2018 Friday, December 4, 2015 9:58 AM
    • Marked as answer by jims.halo10 Friday, December 4, 2015 6:23 PM
    Friday, December 4, 2015 9:58 AM
  • Thanks for that. The file win10-10.0.0.318-whql.zip works on Windows 10 64bit and probably would install on WS2016TP4 but for some sort of symbol declaration in the line.

    "ServiceBinary   = %12%\athw10x.sys" the %12% should be "Windows\System32\drivers" I think its the path to the other OS drivers that's translating wrongly

    If you try and alter the file a checksum error occurs. So leaving to WHQL to get this working

    Thanks again

    Friday, December 4, 2015 6:33 PM
  • Hi jims,

    Thanks for your post.

    Your reply will be great help to others.

    Best regards,


    Andy_Pan

    Monday, December 7, 2015 1:23 AM
  • Hi there. I just ran into the same problem today, and solved it instaling the Windows feature "Wireless LAN Service", rebooting the machine and after that, the network adapter showed as installed on device manager.I also manually started the "WLAN AutoConfig" service. Qualcomm Atheros AR9485 Wireless Network Adapter working fine on WS2016TP4.


    Rafael Monteiro

    • Proposed as answer by rafael9908 Tuesday, April 19, 2016 8:46 PM
    • Marked as answer by jims.halo10 Wednesday, April 20, 2016 1:35 PM
    Tuesday, April 19, 2016 7:53 PM
  •  hi there,

    I from taiwan,so my english is not well

    I try your suggeut but can't start Qualcomm Atheros AR9485 Wireless Network Adapter working  on WS2016TP4.

    1.instaling the Windows feature "Wireless LAN Service"

    2.and restart the computer

    3.started the "WLAN AutoConfig" service

    but my Qualcomm Atheros AR9485 Wireless Network Adapter can't working

    Wednesday, November 23, 2016 2:17 PM
  • You should not be using TP4.  Use the released software - it was released a couple months ago.  https://www.microsoft.com/en-us/evalcenter/evaluate-windows-server-2016

    You still need to contact Qualcomm to get their Windows Server 2016 driver. Also make sure your BIOS and firmware are up to date.


    . : | : . : | : . tim

    Wednesday, November 23, 2016 2:31 PM
  • Thanks

    Now it can work on WS2016

    I ignore reinstall driver

    because I think start the "WLAN AutoConfig" service after that the Network Adapter can working on WS2016

    Now I reinstall driver it can working on WS2016

    Moreover, my WS2016 is up to date,and BIOS isn't up to date,it can working.


    • Marked as answer by jims.halo10 Saturday, November 26, 2016 10:59 AM
    Saturday, November 26, 2016 6:46 AM