none
East Asia custom dictionary not available! RRS feed

  • Question

  • I create custom0404.lex and custom0804.lex step by step. 

    http://technet.microsoft.com/en-us/library/gg130820.aspx

    Index still use default tokenization,custom dictionary not avaliable.

    Please help me.Thank you.

    Tuesday, January 25, 2011 7:37 AM

Answers

  • Just to be sure:

    1. You put the file in the correct place and restarted the qrserver (stop and start often works better than restart)

    2. You saved the file in UTF-16 with byte order mark

    3. You wrote "#CUSTOMER_WB" on the first line of the file

    4. You re-indexed the content

    5. Your  query language is simplified or traditional chinese - Click the preferences link beside the search box in the search center. Default it uses the language from your browser, but try to set it explicit.

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    • Marked as answer by Tommy_Wang Sunday, February 6, 2011 2:07 AM
    Tuesday, January 25, 2011 12:42 PM

All replies

  • Just to be sure:

    1. You put the file in the correct place and restarted the qrserver (stop and start often works better than restart)

    2. You saved the file in UTF-16 with byte order mark

    3. You wrote "#CUSTOMER_WB" on the first line of the file

    4. You re-indexed the content

    5. Your  query language is simplified or traditional chinese - Click the preferences link beside the search box in the search center. Default it uses the language from your browser, but try to set it explicit.

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    • Marked as answer by Tommy_Wang Sunday, February 6, 2011 2:07 AM
    Tuesday, January 25, 2011 12:42 PM
  • Thank you for your reply!

    I follow your guide step by step.

    I saved the file in UCS-2 LE.

    Content of Dictionary is

    #CUSTOMER_WB

    電/光源

     

    But custom dictionary still not avaliable.

    Wednesday, January 26, 2011 8:37 AM
  • I did a test right now.

    I indexed a html file with the word: 是維基媒體基金會的商標 (a wikipedia page)

    Without adding a custom word breaker I could search for 是 and get a hit, but if I tried to search for 是維 or 維 I didn't get a hit.

    I then added a custom file with the following word-breaker file:

    是/維/基/媒/體/基/金/會/的/商/標

    After re-indexing the document I get a hit for both 是維 and 維. And I changed the preferences of the search page to search in simplified Chinese.

    I don't know any Chinese at all so I have no idea if the breaking in my file is correct, but it proves it works. So maybe you have just defined the file incorrect according to the original word in your indexed content?

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Saturday, January 29, 2011 10:55 AM
  • Thank you very much. I test it many times.I'm sure that it needs restart "FAST Search Server 2010 for SharePoint Dictionary Compilation Job" before re-crawled content. Thanks a lot!!
    Wednesday, February 2, 2011 6:22 AM
  • I only restarted the qrserver and the docprocs, but I'm happy to hear that you got it working :)

    Regards,
    Mikael Svenson


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Wednesday, February 2, 2011 8:59 AM