none
Exchange 2010 SP2 and enable-remotemailbox

    Question

  • After I installed SP2 for my Exchange 2010 on-premise, I now get the following error when I try to do an enable-remotemailbox (If I do a new-remotemailbox it works fine)  I cannot do new-remotemailbox because our AD admins and E-Mail admins are controlled seperatly, and the AD account needs to be created first.

    he address '@service.domain.com' is invalid: "@service.domain.com" isn't a valid SMTP address. The domain name
    can't contain spaces and it has to have a prefix and a suffix, such as example.com.
       + CategoryInfo          : NotSpecified: (0:Int32) [Enable-RemoteMailbox], DataValidationException
       + FullyQualifiedErrorId : 79C2CC69,Microsoft.Exchange.Management.RecipientTasks.EnableRemoteMailbox
    Wednesday, April 11, 2012 6:40 PM

Answers

  • Yeah, after a lot of debugging, I have found the same issue.  However it is more it than that.  Enable-RemoteMailbox no longer supports pipelining either.  and, I need the -alias parameter too.
    • Marked as answer by Xiu Zhang Friday, May 04, 2012 6:53 AM
    Monday, April 30, 2012 5:42 PM

All replies

  • Hi,

    I understand that we  can use the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service for an existing user in the on-premises Active Directory.


    Xiu Zhang

    TechNet Community Support

    Thursday, April 12, 2012 9:40 AM
  • I am sorry, I meant enable-RemoteMailbox returns that error.
    Friday, April 13, 2012 7:02 PM
  • Hi,

    Please verify whether you have created a user in Active Directory, and the user has already been sync’ed to online.

    Note: We need have recipient sync'ed from on-premises to online services.

    If yes, please try to Get-user xxx|Enable-remoteMailbox at on-premises side.

    Exchange Online + Exchange On Premises = Shared Namespace, How About Mail Routing?

    http://blogs.technet.com/b/ilvancri/archive/2011/08/24/exchange-online-exchange-on-premises-shared-namespace-how-about-mail-routing.aspx

    By the way, what is your domian name? Please run get-emailaddresspolicy |fl and then post here.


    Xiu Zhang

    TechNet Community Support

    Monday, April 16, 2012 6:01 AM
  • Yes, I have verified all of that and have run the above piped command.  I have opened a ticket with Office 365 support because Exchange Support said it's not their issue.  But the resolution is coming very slow.
    Monday, April 16, 2012 11:01 PM
  • Welcome to update here if you get any news there.

    Xiu Zhang

    TechNet Community Support

    Tuesday, April 17, 2012 6:38 AM
  • there has been no updates, it still DOES NOT WORK and Office 365 support has been worthless on this issue.
    Monday, April 23, 2012 8:40 PM
  • By the way, do you have space inside the domain name? Please double check it.

    You can run get-acceptdomain |fl and get-emailaddresspolicy |fl. Please post the result here.


    Xiu Zhang

    TechNet Community Support


    • Edited by Xiu Zhang Tuesday, April 24, 2012 7:07 AM
    Tuesday, April 24, 2012 7:02 AM
  • Hi Adam,

    I've just seen the same issue. Try the following

    Enable-RemoteMailbox <username> -RemoteRoutingAddress <alias>@service.domain.com

    Or for anyone else experiencing this with a SP2 Hybrid-Wizard setup:

    Enable-RemoteMailbox <username> -RemoteRoutingAddress <alias>@<tenantName>.mail.onmicrosoft.com

    Let me know if that helps,

    Steve


    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    Thursday, April 26, 2012 8:56 AM
  • Yeah, after a lot of debugging, I have found the same issue.  However it is more it than that.  Enable-RemoteMailbox no longer supports pipelining either.  and, I need the -alias parameter too.
    • Marked as answer by Xiu Zhang Friday, May 04, 2012 6:53 AM
    Monday, April 30, 2012 5:42 PM