locked
Transport Rule Question - Multiple Recipient Domains RRS feed

  • Question

  • Hi,

    I have set a transport rule on my Exchange 2010 server to prevent users from sending messages of more than a specific attachment size to somedomain.com . Problem is that now when a user sends messages with two or more recipients one of them being from the restricted somedomain.com and other domains with no restrictions, the rule rejects the message as a whole and does not send the messages to those domains without restriction rule.

    I mean when a message has more than one recipient in different domains, Exchange rules which apply to one of recipients apply to whole message and prevent message delivery to other domains as well.

    Is any work around to this?

     

    Regards,

    Vad


    Saturday, April 16, 2011 6:53 AM

All replies

  • Forget the transport rule and do this (for a 30MB maximum message size):

    New-SendConnector -Internet -AddressSpaces "SMTP:somedomain.com;1" -MaxMessageSize 30MB

    Add a smart host or other settings if you need them.  Transport will use this send connector in preference to your default one with address space * because it is a more specific match for the domain in question.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Marked as answer by Lasse Pettersson - Sunday, April 17, 2011 8:24 AM
    • Unmarked as answer by Vadood Thursday, May 12, 2011 5:41 AM
    Sunday, April 17, 2011 2:27 AM
  • Thank you Ed

    I created a new send connector as below, but it does not seem to work, I still can send large messages to this domain.

    [PS] C:\Windows\system32>Get-SendConnector -identity "test jv" | fl
    
    
    
    AddressSpaces    : {SMTP:*.mydomain.com;5}
    
    AuthenticationCredential  :
    
    Comment      :
    
    ConnectedDomains    : {}
    
    ConnectionInactivityTimeOut : 00:10:00
    
    DNSRoutingEnabled   : True
    
    DomainSecureEnabled   : False
    
    Enabled      : True
    
    ErrorPolicies    : Default
    
    ForceHELO     : False
    
    Fqdn       :
    
    HomeMTA      : Microsoft MTA
    
    HomeMtaServerId    : Edge01
    
    Identity      : test jv
    
    IgnoreSTARTTLS    : False
    
    IsScopedConnector   : False
    
    IsSmtpConnector    : True
    
    LinkedReceiveConnector  :
    
    MaxMessageSize    : 207 KB (211,968 bytes)
    
    Name       : test jv
    
    Port       : 25
    
    ProtocolLoggingLevel   : Verbose
    
    RequireOorg     : False
    
    RequireTLS     : False
    
    SmartHostAuthMechanism  : None
    
    SmartHosts     : {}
    
    SmartHostsString    :
    
    SmtpMaxMessagesPerConnection : 20
    
    SourceIPAddress    : 0.0.0.0
    
    SourceRoutingGroup   : Exchange Routing Group (DWBGZMFD01QNBJR)
    
    SourceTransportServers  : {Edge02, Edge01}
    
    TlsAuthLevel     :
    
    TlsDomain     :
    
    UseExternalDNSServersEnabled : False
    
    

    I also have this default send connector:

    [PS] C:\Windows\system32>Get-SendConnector -identity "*poonak t*" | fl
    
    
    
    
    
    AddressSpaces    : {smtp:*;100}
    
    AuthenticationCredential  :
    
    Comment      :
    
    ConnectedDomains    : {}
    
    ConnectionInactivityTimeOut : 00:10:00
    
    DNSRoutingEnabled   : True
    
    DomainSecureEnabled   : True
    
    Enabled      : True
    
    ErrorPolicies    : Default
    
    ForceHELO     : False
    
    Fqdn       :
    
    HomeMTA      : xxxx.net/Configuration/Deleted Objects/Microsoft MTA
    
            DEL:df5687f3-4955-4446-83a1-d5cecf19f36f
    
    HomeMtaServerId    : xxxx.net/Configuration/Deleted Objects/Microsoft MTA
    
            DEL:df5687f3-4955-4446-83a1-d5cecf19f36f
    
    Identity      : EdgeSync - Poonak to Internet
    
    IgnoreSTARTTLS    : False
    
    IsScopedConnector   : False
    
    IsSmtpConnector    : True
    
    LinkedReceiveConnector  :
    
    MaxMessageSize    : 50 MB (52,428,800 bytes)
    
    Name       : EdgeSync - Poonak to Internet
    
    Port       : 25
    
    ProtocolLoggingLevel   : Verbose
    
    RequireOorg     : False
    
    RequireTLS     : False
    
    SmartHostAuthMechanism  : None
    
    SmartHosts     : {}
    
    SmartHostsString    :
    
    SmtpMaxMessagesPerConnection : 20
    
    SourceIPAddress    : 0.0.0.0
    
    SourceRoutingGroup   : Exchange Routing Group (DWBGZMFD01QNBJR)
    
    SourceTransportServers  : {Edge02, Edge01}
    
    TlsAuthLevel     :
    
    TlsDomain     :
    
    UseExternalDNSServersEnabled : False
    
    
    
    
    
    

    Thursday, May 12, 2011 5:40 AM
  • Forget the transport rule and do this (for a 30MB maximum message size):

    New-SendConnector -Internet -AddressSpaces "SMTP:somedomain.com;1" -MaxMessageSize 30MB

    Add a smart host or other settings if you need them.  Transport will use this send connector in preference to your default one with address space * because it is a more specific match for the domain in question.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    I checked the logs, Edge Server does not use this new send connector I created
    Thursday, May 12, 2011 6:39 AM