locked
Forest Prep, LDAP server unavailable RRS feed

  • Question

  • Hello. First off I'd like to say that I am new to deployments in general. I put up a working SCCM and that's it.

    Before I state the issue, I feel like I should explain what have been done first, so here goes:

    It is not in a test lab, it is in the company's sharp environment, so the AD being used is not a lab AD.

    Now, I tried to install Lync 2010 recently on this one server and followed a guide (http://policelli.com/Files/Deploying_Lync_Server_2010_Enterprise.pdf) where I ran into troubles when I was about to publish the topology where I ran into troubles. I then uninstalled everything of the server and tried to install it again, the standard edition, not having a clue that it wasn't enough uninstalling it normally. So when I tried to follow this guide, (http://msundis.wordpress.com/2011/02/08/installing-lync-server-2010-consolidated-standard-edition-server-step-by-step-part-1/) I came to forest prep, as AD extend scheme was already done since before, and I got this error message:

    Warning: Enable-CSAdForest failed.
    Warning: Detailed results can be found at "C:\Users\administrator.LLENTAB\AppData\Local\Temp\2\Enable-CSAdForest-[2012_02_29][09_29_01].html".
    Command execution failed: Message-"The LDAP server is unavailable." LdapError-"ServerDown" "lab-bgd1.lab.se":"389"

    This is an old DC that we have removed and I am now wondering why it tries to connect to this server? I also tried to run the Disable-CsAdForest in the lync management shell but then I get the same, that the LDAP server is unavailable.

    I hope you can help me as this isn't in a test environment, which isn't clever I know, so I dare not proceed anything without proper help.

    Thanks in advance!

    Regards,
    Simon


    • Edited by Simon Borg Friday, March 2, 2012 6:59 AM
    Wednesday, February 29, 2012 8:31 AM

Answers

All replies

  • Hi Simon,

    It seems like old DC isn't decomissioned/demoted properly.

    • Delete the orphan entry if exists , http://support.microsoft.com/kb/555846 
    • Ensure that DNS and WINS entry were removed.
    • Clear the DNS cache from Lync standard edition server.
    • Run the forest prep again and let us know the result.

    Thanks

    Saleesh

    • Proposed as answer by Sharon.Shen Friday, March 2, 2012 4:17 AM
    • Marked as answer by Simon Borg Friday, March 2, 2012 10:32 AM
    Wednesday, February 29, 2012 9:20 AM
  • Hi,

    The issue may be caused by the old DC references. I suggest trying to check Event Viewer if there is any error or message after demoting DC. Please try to remove any stale data in DC as Saleesh suggested. We can also try to verify if the DC demotion is successful.

    http://technet.microsoft.com/en-us/library/cc756445%28WS.10%29.aspx

    In addition, we can check AD status using Domain Controller Diagnostic Tool to make sure the replication has been completed in AD.

    http://technet.microsoft.com/en-us/library/cc776854(WS.10).aspx

    Best Regards,

    Kent

    • Proposed as answer by Sharon.Shen Friday, March 2, 2012 4:17 AM
    • Marked as answer by Simon Borg Friday, March 2, 2012 10:32 AM
    Friday, March 2, 2012 2:46 AM
  • Thank you very much sir, it was indeed not demoted properly!

    Regards,
    Simon

    Friday, March 2, 2012 10:33 AM