locked
Turn off UAC for a Shared Drive/Directory RRS feed

  • Question

  • Hi,

    After installing a new drive for users to share virtual machine images, I am having a problem because of UAC on the drive.  Is it possible to turn off UAC for a particular drive or directory so that it is not a protected drive/directory and processes writing to the drive do not have to run elevated?

    Thanks,

    Mark

    Wednesday, March 21, 2007 9:48 PM

Answers

  • Ok let try this again

    1. you need to be Admin to install VPC2007 (or Virtal server 2006) Virtual PC 2004 will not work in Vista,

    2. Creat a Sub directory ( D:\Vitrual machines)

    3. Copy VPC into that directory (both VHD and setting file)

    4. Open Virtual PC

    5. Point to that directory and add VPC or you can create in that location

    6. NO admin privilages needed.

     

    I run VPC's every day like this.....

     

    Friday, March 23, 2007 12:28 PM
  • Mark,

     

    It sounds like a permissions problem on the drive. Have you tried opening the security tab on drive and giving the Users group read/write access?  You might need to reset the permissions on existing subdirectories you have created in order to allow access to those too.

    Tuesday, March 27, 2007 8:36 AM

All replies

  • create a subdirectory in new drive and will work (root) is protected sub directory are mostly not.

    And no to turning off UAC per drive

    Wednesday, March 21, 2007 10:49 PM
  • Thanks for the reply.

    Unfortunately, the first option didn't work.  It does for USB connected drives, but for one I placed internally, it didn't. 

    So my only options are turning of UAC entirely or running any application that writes to that drive as administrator?  There is not option to turn it off for particular folders in the same way that it is on for %ProgramFiles% but not on for %UserProfile% ?  That seems like a very limited option set that makes running with UAC challenging.

    Thanks,
    Mark

    Thursday, March 22, 2007 2:23 PM
  • If you have an internal driv create a VPC directory and then put you VPC file in it no uac issues, I do that all the time
    Thursday, March 22, 2007 9:24 PM
  • Hi,

    That would be great, but unfortunately that is not what is happening.  My VM will not work unless I run VPC 2007 as an administrator.  How do I change it so that I can write to a directory on my D drive without running as administrator?

    Thanks,
    Mark

    Friday, March 23, 2007 3:54 AM
  • Ok let try this again

    1. you need to be Admin to install VPC2007 (or Virtal server 2006) Virtual PC 2004 will not work in Vista,

    2. Creat a Sub directory ( D:\Vitrual machines)

    3. Copy VPC into that directory (both VHD and setting file)

    4. Open Virtual PC

    5. Point to that directory and add VPC or you can create in that location

    6. NO admin privilages needed.

     

    I run VPC's every day like this.....

     

    Friday, March 23, 2007 12:28 PM
  • Mark,

     

    It sounds like a permissions problem on the drive. Have you tried opening the security tab on drive and giving the Users group read/write access?  You might need to reset the permissions on existing subdirectories you have created in order to allow access to those too.

    Tuesday, March 27, 2007 8:36 AM
  • That's it!  Thanks!  I had access but only via the administrators group!

     

    Thanks,

    Mark

    Tuesday, March 27, 2007 10:36 PM