locked
Opening or editing .mpp file (MS Project file) in the SharePoint library ? RRS feed

  • Question

  • Hello,

    When opening or editing .mpp file (MS Project file) in the SharePoint library (I mean, By clicking on the item link) it opens inside the IE browser instead of in MS Project application itself. Why is that?

    Other MS Office files (e.g. Word, Excel) do not behave like that. So could you please tell me what to do in order to make .mpp file opens in MS Project application itself and not inside the IE browser ???

     

    • Moved by Mike Walsh FIN Wednesday, July 20, 2011 2:14 PM not a programming question so why post it there. Moving to admin (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Wednesday, July 20, 2011 12:59 PM

Answers

  • Hi Sam,

    You need to check and make sure the Adds-on “SharePoint OpenDocuments Class”  was enabled via the IE Tools -> Manage add-ons -> Microsoft Corporation section .
    Then the .mpp file should also be opened by MS Project application.

    Thanks,
    Daniel


    Regards, Daniel
    • Marked as answer by Wayne Fan Sunday, July 31, 2011 10:08 AM
    Friday, July 22, 2011 10:36 AM
    Moderator
  • Hi Sam,

     

    First, you should make sure you have install MS Project in the computer already.

     

    Then you need go to your document library and click settings>Document Library Setting>Advanced settings. Choosing open in the client application which under Browser-enabled Documents.

     

    If this doesn't work, please refer to the following article and use the Folder Options tool to fix it:

     

    http://support.microsoft.com/kb/162059/en-us


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Sunday, July 31, 2011 10:08 AM
    Tuesday, July 26, 2011 11:45 AM

All replies

  • Hi Sam,

    You need to check and make sure the Adds-on “SharePoint OpenDocuments Class”  was enabled via the IE Tools -> Manage add-ons -> Microsoft Corporation section .
    Then the .mpp file should also be opened by MS Project application.

    Thanks,
    Daniel


    Regards, Daniel
    • Marked as answer by Wayne Fan Sunday, July 31, 2011 10:08 AM
    Friday, July 22, 2011 10:36 AM
    Moderator
  • Hi Sam,

     

    First, you should make sure you have install MS Project in the computer already.

     

    Then you need go to your document library and click settings>Document Library Setting>Advanced settings. Choosing open in the client application which under Browser-enabled Documents.

     

    If this doesn't work, please refer to the following article and use the Folder Options tool to fix it:

     

    http://support.microsoft.com/kb/162059/en-us


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Sunday, July 31, 2011 10:08 AM
    Tuesday, July 26, 2011 11:45 AM
  • Hi Sam,

    Leaving my machine to default setting with IE8 and MS Project already installed, opens the file in application.

    Just tested.


    Regards Nikhil
    Thursday, November 17, 2011 7:42 PM