none
Unread emails disappearing after few seconds??? RRS feed

  • Question

  • I’ m facing a very strange problem. 

    I’ve been looking for a possible cause and solution on the web, but I didn’t find anyone with the same problem.

     

    I manage the network in a company with about 100 clients.

    We have an Exchange 2007 server with about 90 mailboxes.

    Everybody can read his own email using Microsoft outlook client (2003, 2007 and 2010 versions depending on when the pc has been bought) and someone has a blackberry too (managed with BES 5.0.1).

    Starting from yesterday a user told me that she was not receiving emails (in her outlook 2003 client).

    I did some standard check (I’ve been working here in the last 12 years, so I know very well that users have the ability to do weird things with PCs :-P) but I dind’t see anything particular on her outlook 2003 client: no rules or filters, no views, exchange mail delivered in exchange mailbox and not in .pst, mailbox not yet full, mails not moved into spam…

    So after asking her, I connected to her mailbox using owa, and I started to send emails to her from my gmail account. First I closed her outlook program, to be sure that the problem was not in the client.

    I saw that each email arrives to the mailbox, but after few seconds… it disappears.

    After some more tests, I noticed that if as soon as the mail arrives I open it (so it marks as read), it will not disappear. I tried sending her 3 consecutive emails, and I immediately opened only the first and third. After few seconds the second one disappeared.

    I’ve been looking around a lot, but I didn’t find any reason for this.

    If you have any idea about what I can try or check…

    Thank you in advance.

     

    Alex

    Tuesday, October 25, 2011 11:56 AM

All replies

  • Hi Alex,

    Have you gone through this one..

    http://www.msoutlook.info/question/322

     


    Thanks & Regards, Kottees R
    Tuesday, October 25, 2011 2:03 PM
  • I experienced the similar issue. The problem was user configured his outlook on HOME PC and set the delivery to PST and when in office he complained that the message are getting lost. After initial tracing found that another client was connected using his profile and turned out the IP address pointed to home PC.


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Tuesday, October 25, 2011 2:45 PM
  • Hi.

    Thanks for the reply.

    Yes, I already checked all those possibilities.

    The problem happens also when outlook is closed, so it's not related to outlook.

    The strange thing is that only email marked as "not yet read" disappear, already read emails stay there.

     

    I can add one more information... this looks like happening only with emails coming from outside our company. Mails coming from other exchange user are received normally.

    We have an anti-spam system, but it is a third party service outside the company (Websense), so when the email arrives here, it's already "clean" and it's not analyzed by other filters.

    I first checked the anti-spam and thos messages are marked as clean and accepted. And I see those messages arriving in the mailbox, even if they disappear soon.

    It's a very strange problem...

    Tuesday, October 25, 2011 2:59 PM
  • Thanks, but in this case this is not the problem.

    She can't read company email at home, she normally has owa disabled too, and nobody can read it from home using outlook without vpn connection.

    Here inside the company she has only only one pc and only her active directory account can read her messages.

     

     

    One more information. Before I wrote that messages coming from other active directory user are not affected. I notice that they are not affected even if they are sent from outside the company (for example from our technicians working at customers companies).

     

    Only "foreign" messages are deleted by the server if I don't immediately open them.

    Tuesday, October 25, 2011 3:21 PM
  • Please use the ExMON Tool to check if there is any connection from that user. http://www.msexchange.org/tutorials/microsoft-exchange-server-user-monitor.html

    It definitely sounds like a rule. Please use the tool MFCMAPI to check for any hidden or corrupted server side rule details here http://support.microsoft.com/kb/924297


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Tuesday, October 25, 2011 3:26 PM
  • Yes, it really looks like a rule, but I didn't find any.

    Now I have to do some maintenance in server rrom, tomorrow morning I will try that.

    thanks.

    Tuesday, October 25, 2011 3:37 PM
  • Hi,

    First please try to use outlook online mode.

    Please try to search messsages from outlook to see if we can find it.

    Please try to use MFCmapi to delete any hidden rules for that user.

    How to delete corrupted and hidden rules from a single mailbox in Outlook 2003

    http://support.microsoft.com/kb/924297

    Xiu

    Wednesday, October 26, 2011 8:37 AM
  • Besides, please try to check the permission on that mailbox to see if any other user has right to access this mailbox. I suspect that we may have rules on other mailbox for this user.

    Xiu

    Wednesday, October 26, 2011 8:43 AM
  • Here I am.

    ExMON looks like to be not available for exchange 2007.

    I downloaded MFCMapi and followed the instruction on how to delete hidden rules.

    The first time he told me to disble cache mode first. So I did it and retried.

    I deleted 1 rule and it worked, new emails were not disappearing anymore.

    So I re-enabled cache mode and I got the same problem.

    So I tried to delete .ost file and i let outlook re-create it.

    But the problem was still there.

    I disabled cache mode again and the problem went away.

    Cache mode is enabled on every pc and I never had issues, so I can't understand why on this pc it does like this.

    More, the problem was happening also when outlook 2003 client was closed, and I'm sure about it, I checked task manager too.

    So now it's working (without cache mode, it's a desktop, so cache mode is not really needed) but I did not understand why...

    Wednesday, October 26, 2011 9:50 AM
  • Besides, please try to check the permission on that mailbox to see if any other user has right to access this mailbox. I suspect that we may have rules on other mailbox for this user.

    Xiu

    I checked, but no one else has permission on her mailbox.

    We usually don't use that feature, only company's president has that on his mailbox, to allow his secretary to send mails on his behalf.

     

     

    I'm still thinking about that... emails were disappearing from owa, with outlook client closed. Disabling cache mode, outlook just reads the emails on the server and displays them. So I don't understand why this solved the problem. But now unopened emails are there. (only new, old are gone)

    Wednesday, October 26, 2011 10:02 AM
  • Did you made sure that outlook.exe process no more visibel in task manager ?


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Wednesday, October 26, 2011 10:59 AM
  •  Did you made sure that outlook.exe process no more visibel in task manager ?

     


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Yes, of course...
    Wednesday, October 26, 2011 11:57 AM
  • Did you already tried creating a completely new outlook profile for this user

    What if you create a new profile in cached mode on some other machine and keep it open does the email disappear then also ?


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Wednesday, October 26, 2011 12:38 PM
  •  Did you already tried creating a completely new outlook profile for this user

    What if you create a new profile in cached mode on some other machine and keep it open does the email disappear then also ?

     


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security

    I didn't try that. When I saw that emails were disappearing also with outlook closed (and outlook.exe process closed too) I thought that the problem was not client related, so I stopped doing client tests.

    But then the cache removing solution left me without words.

    I will try...

    Wednesday, October 26, 2011 1:05 PM
  • Hi,

    Then please try to create a new windows profile and then create the outlook profile there.

    After that,please try to test the issue with cache mode. I think some local cache may affect the issue.

    Xiu

    Thursday, October 27, 2011 4:08 AM
  • ok I am having the same problem with my account. I tested my account on another laptop and configured outlook client the samething is happing also happing on owa. I installed the mfcmapi app. it says:

    firstname_last@mail.com true ms exchange

    public folders - firstname_last@mail.com false ms exchange

    name.pst flast outlook data file (I just created the pst today mail is not pointing to it I am dragging emails to it so I do not lose them.

    alex how did yours turn out?

    I have websense as email filter as well and symantac as anti-virus

    any ideas on fix for this? does not seem to be  a client issue and also checked mailbox act for redirects.

     Did you already tried creating a completely new outlook profile for this user

    What if you create a new profile in cached mode on some other machine and keep it open does the email disappear then also ?


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security

    I didn't try that. When I saw that emails were disappearing also with outlook closed (and outlook.exe process closed too) I thought that the problem was not client related, so I stopped doing client tests.

    But then the cache removing solution left me without words.

    I will try...


    Tuesday, June 12, 2012 3:25 AM
  • Hello all thank you all for helping me and responding to my issue. well guess what it was the freaking add-ins I read somewhere to disable add-ins which I did now my emails are not disappearing! I disabled all of them I'll start enabling one by one to identify which one is the bad add-on. Thank you all again.
    • Proposed as answer by Neil D Smith Friday, June 15, 2012 7:03 PM
    Friday, June 15, 2012 7:03 PM