locked
ConfigMgr 2012 Client - No Actions RRS feed

  • Question

  • Hi,

    I've recently build a Configuration Manager 2012 environment but am having trouble with the client communicating with the management point.

    Within the control panel applet "Actions" tab I have the two basic user and machine policy update cycle options.

    I'm receiving the following messages in my logs:

    ClientIDManagerStartup.log

    <![LOG[[----- STARTUP -----]]LOG]!><time="11:36:32.864-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmidstore.cpp:411">
    <![LOG[Running query 'SELECT * FROM CCM_Service_HostedApplication WHERE Type="Server"' against namespace: '\\AUPERAWKS679\ROOT\CCM\Policy\Machine']LOG]!><time="11:36:32.864-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="hostingutil.cpp:312">
    <![LOG[CCMExec is currently NOT hosting a server application.]LOG]!><time="11:36:32.864-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="hostingutil.cpp:403">
    <![LOG[Machine: AUPERAWKS679]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1394">
    <![LOG[OS Version: 6.1 Service Pack 1]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1398">
    <![LOG[SCCM Client Version: 5.00.7711.0000]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1402">
    <![LOG['RDV' Identity store does not support backup.]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmidstore.cpp:369">
    <![LOG[CCM Identity is in sync with Identity stores]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1441">
    <![LOG[PopulateRegistrationHint: Client has an SMSID, certificates, and has no CCM_ClientIdentificationInformation=@ instance, setting the hint.]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1916">
    <![LOG[Retrieved Certificate options successfully]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmgencert.cpp:3535">
    <![LOG[Failed in GetCertificate(...): 0x87d00281
    ]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="3" thread="2288" file="ccmcert.cpp:2122">
    <![LOG[PopulateRegistrationHint: Using the Certificate selected by the current version of SCCM to set the hint.]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1986">
    <![LOG[Client is set to use HTTPS when available. The current state is 224.]LOG]!><time="11:36:32.880-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmutillib.cpp:362">
    <![LOG[PopulateRegistrationHint: Registration hint successfully populated.]LOG]!><time="11:36:32.926-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmid.cpp:1994">
    <![LOG[Deleted Certificate ID from registry successfully]LOG]!><time="11:36:32.926-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="2288" file="ccmgencert.cpp:3493">
    <![LOG[[RegTask] - Executing registration task synchronously.]LOG]!><time="11:36:56.966-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="regtask.cpp:915">
    <![LOG[Read SMBIOS (encoded): 3200470036003100430032005300]LOG]!><time="11:36:56.966-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="smbiosident.cpp:118">
    <![LOG[Evaluated SMBIOS (encoded): 3200470036003100430032005300]LOG]!><time="11:36:56.966-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="smbiosident.cpp:184">
    <![LOG[No SMBIOS Changed]LOG]!><time="11:36:56.966-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="smbiosident.cpp:65">
    <![LOG[SMBIOS unchanged]LOG]!><time="11:36:56.966-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="ccmid.cpp:657">
    <![LOG[SID unchanged]LOG]!><time="11:36:56.982-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="ccmid.cpp:674">
    <![LOG[HWID unchanged]LOG]!><time="11:36:58.152-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="ccmid.cpp:691">
    <![LOG[RegEndPoint: Event notification: CCM_RemoteClient_Reassigned]LOG]!><time="11:36:59.634-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="5784" file="regendpoint.cpp:205">
    <![LOG[RegEndPoint: Received notification for site assignment change from '<none>' to 'GLD'.]LOG]!><time="11:36:59.634-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="5784" file="regendpoint.cpp:233">
    <![LOG[GetSystemEnclosureChassisInfo: IsFixed=TRUE, IsLaptop=FALSE]LOG]!><time="11:37:00.632-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="ccmid.cpp:210">
    <![LOG[Computed HardwareID=2:5676EF7DB508264E16184E8FF9356184EF9C7A1F
     Win32_SystemEnclosure.SerialNumber=2G61C2S
     Win32_SystemEnclosure.SMBIOSAssetTag=<empty>
     Win32_BaseBoard.SerialNumber=/2G61C2S/CN7360419T0ADE/
     Win32_BIOS.SerialNumber=2G61C2S
     Win32_NetworkAdapterConfiguration.MACAddress=18:03:73:E7:44:26]LOG]!><time="11:37:00.663-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="ccmid.cpp:449">
    <![LOG[[RegTask] - Client is not registered. Sending registration request for GUID:D0DB8913-1C4C-4EBA-A62F-51A5CA15F678 ...]LOG]!><time="11:37:00.679-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="1" thread="4744" file="regtask.cpp:1595">
    <![LOG[RegTask: Failed to send registration request message. Error: 0x87d00309]LOG]!><time="11:37:00.788-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="3" thread="4744" file="regtask.cpp:1283">
    <![LOG[RegTask: Failed to send registration request. Error: 0x87d00309]LOG]!><time="11:37:00.788-480" date="07-18-2012" component="ClientIDManagerStartup" context="" type="3" thread="4744" file="regtask.cpp:1469">

    LocationServices.log:

    <![LOG[Lookup Management Points from AD:]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsutils.h:205">
    <![LOG[Name: 'CFM002.domain.ext' HTTPS: 'N' ForestTrust: 'N']LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsutils.h:208">
    <![LOG[Retrieved lookup MP(s) from AD]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:1955">
    <![LOG[Current AD site of machine is East-Peth]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:601">
    <![LOG[Current AD forest name is domain.ext, domain name is domain.ext]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:668">
    <![LOG[Begin checking Alternate Network Configuration]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="ccmiputil.cpp:1069">
    <![LOG[Finished checking Alternate Network Configuration]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="ccmiputil.cpp:1146">
    <![LOG[Begin checking Alternate Network Configuration]LOG]!><time="11:38:33.873-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="ccmiputil.cpp:1069">
    <![LOG[Finished checking Alternate Network Configuration]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="ccmiputil.cpp:1146">
    <![LOG[Current AD site of machine is East-Peth]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:601">
    <![LOG[LSIsSiteCompatible : Verifying Site Compatibility for <GCP>]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5103">
    <![LOG[LSGetSiteVersionFromAD : Successfully retrieved version '4.00.6487.0000' for site 'GCP']LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:4996">
    <![LOG[LSIsSiteVersionCompatible : Site Version '4.00.6487.0000' is not compatible.]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5064">
    <![LOG[LSIsSiteCompatible : Site <GCP> Version '4.00.6487.0000' is not compatible.]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5167">
    <![LOG[LSIsSiteCompatible : Verifying Site Compatibility for <GLD>]LOG]!><time="11:38:33.889-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5103">
    <![LOG[LSGetSiteVersionFromAD : Successfully retrieved version '5.00.7711.0000' for site 'GLD']LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:4996">
    <![LOG[LSIsSiteVersionCompatible : Site Version '5.00.7711.0000' is compatible.]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5069">
    <![LOG[LSIsSiteCompatible : Site <GLD> Version '5.00.7711.0000' is compatible.]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5172">
    <![LOG[This client might be within the boundaries of more than one site - AD SiteCode search matched 2 entries]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="2" thread="5216" file="lsad.cpp:1770">
    <![LOG[The client will be assigned to the first valid site]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:1771">
    <![LOG[LSGetAssignedSiteFromAD : Trying to Assign to the Site <GLD>]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:1777">
    <![LOG[LSIsSiteCompatible : Verifying Site Compatibility for <GLD>]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5103">
    <![LOG[Attempting to retrieve lookup MP(s) from AD]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:1919">
    <![LOG[The MP name retrieved is 'CFM002.domain.ext' with version '7711' and capabilities '<Capabilities SchemaVersion="1.0"><Property Name="SSLState" Value="0"/></Capabilities>']LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:2583">
    <![LOG[MP 'CFM002.domain.ext' is compatible]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:2589">
    <![LOG[Current AD forest name is domain.ext, domain name is domain.ext]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:668">
    <![LOG[Lookup Management Points from AD:]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsutils.h:205">
    <![LOG[Name: 'CFM002.domain.ext' HTTPS: 'N' ForestTrust: 'N']LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsutils.h:208">
    <![LOG[Retrieved lookup MP(s) from AD]LOG]!><time="11:38:33.904-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:1955">
    <![LOG[LSGetSiteVersionFromAD : Successfully retrieved version '5.00.7711.0000' for site 'GLD']LOG]!><time="11:38:33.920-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:4996">
    <![LOG[LSIsSiteVersionCompatible : Site Version '5.00.7711.0000' is compatible.]LOG]!><time="11:38:33.920-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5069">
    <![LOG[LSIsSiteCompatible : Site <GLD> Version '5.00.7711.0000' is compatible.]LOG]!><time="11:38:33.920-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5172">
    <![LOG[LSVerifySiteAssignment : Client can be assigned to site <GLD>.]LOG]!><time="11:38:33.920-480" date="07-18-2012" component="LocationServices" context="" type="1" thread="5216" file="lsad.cpp:5210">
    <![LOG[CCMVerifyMsgSignature failed.]LOG]!><time="11:39:00.992-480" date="07-18-2012" component="LocationServices" context="" type="3" thread="4744" file="ccmutillib.cpp:3989">
    <![LOG[Failed to verify received message 0x80090006]LOG]!><time="11:39:00.992-480" date="07-18-2012" component="LocationServices" context="" type="3" thread="4744" file="ccmutillib.cpp:3995">
    <![LOG[CCMVerify failed with 0x80090006]LOG]!><time="11:39:00.992-480" date="07-18-2012" component="LocationServices" context="" type="3" thread="4744" file="ccmutillib.cpp:4079">
    <![LOG[Failed to verify message. Could not retrieve certificate from MPCERT.]LOG]!><time="11:39:00.992-480" date="07-18-2012" component="LocationServices" context="" type="2" thread="4744" file="lssecurity.cpp:1866">
    <![LOG[MPCERT requests are throttled for 00:02:59]LOG]!><time="11:39:00.992-480" date="07-18-2012" component="LocationServices" context="" type="2" thread="4744" file="lssecurity.cpp:1867">

    From my limited understanding this seems certificate related but I've configured the site to only use HTTPS?

    Also you'll notice I have two site codes, GCP and GLD. GCP is our old 2007 environment that is still running.

    Finally, my ClientLocation.log is confirming I've connected to the correct MP:

    <![LOG[Assigned Site is GLD]LOG]!><time="12:12:34.547-480" date="07-18-2012" component="ClientLocation" context="" type="1" thread="3724" file="smsclientclass.cpp:1001">
    <![LOG[Current Assigned Management Point is CFM002.domain.ext with Version 7711 and Capabilities: <Capabilities SchemaVersion="1.0"><Property Name="SSLState" Value="0"/></Capabilities>]LOG]!><time="12:14:13.968-480" date="07-18-2012" component="ClientLocation" context="" type="1" thread="5136" file="smsclientclass.cpp:1165">

    Any help you can offer to point me in the right direction would be greatly appreciated.

    Thanks for reading!

    Wednesday, July 18, 2012 4:21 AM

Answers

  • Hi Torsten,

    Thank you very much for your reply.

    I figured it out - whilst I had deployed the clients I hadn't actually approved them. Once I did this everything started communicating perfectly.

    Thanks again for taking the time.

    Leon

    • Marked as answer by GC Leon Saturday, July 21, 2012 7:41 AM
    Saturday, July 21, 2012 7:41 AM

All replies

  • It's no problem that both sitecode are listed. You can see that the client ignores GCP and tries to contact GLD.
    0x80090006 = Invalid Signature and 0x87d00309 = A certificate request extension changed so it's really certificate related.
    "Failed to verify message. Could not retrieve certificate from MPCERT" -> does mpcert work?


    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, July 18, 2012 7:00 AM
  • Hi Torsten,

    Thank you very much for your reply.

    I figured it out - whilst I had deployed the clients I hadn't actually approved them. Once I did this everything started communicating perfectly.

    Thanks again for taking the time.

    Leon

    • Marked as answer by GC Leon Saturday, July 21, 2012 7:41 AM
    Saturday, July 21, 2012 7:41 AM