none
Forcing IE to use TLS 1.2 RRS feed

  • Question

  • Good morning,

    I am having an issue with some computers on my network not accessing a couple of external websites correctly (They are not company websites).  When trying to access it, I get the following error:..

    This page can’t be displayed

    Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to [website url] again. If this error persists, contact your site administrator.

    I have done what the error specifies, and have done every combination of TLS/SSL settings in the IE Advanced Settings tab. I have tried clearing SSL state in IE Options. I have done tracerts between two clients (one that works, and one that doesn't) and the external webserver and they are taking the same hops.  Both are up to date with Windows Updates, are same models, using the same image.  I have tried removing the antivirus with no luck.  I was finally able to use Wireshark and found that the computers that are working use TLS 1.2 (but in IE have 1.0, 1.1 and 1.2 checked), but the computers that don't work are using TLS 1.0 (even though 1.0, 1.1, and 1.2 are checked).  I have tried forcing IE to use TLS 1.2 to see if that is the issue, but I can't force IE to use TLS 1.2.  I have tried using Firefox and Google chrome to no avail.  Any suggestions on why one computer will not use TLS 1.2 while the other will? Also, would that cause the connection issue?

    Thanks.

    Wednesday, September 16, 2015 2:56 PM

Answers

  • Hi,

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    Trusted sites Icon, 'Sites' button.... remove the un-named site and any sub-domains from the list.

    Also check that the domain has not been placed in the Restiricted sites zone or the Users Compatibility View list (Tools>Compatibility View Settings).

    If possible please include full links to any websites you are having problems with your questions so that we can visit them to do some testing.

    Regards.


    Rob^_^

    • Proposed as answer by jim-xu Sunday, September 27, 2015 12:28 AM
    • Marked as answer by Michael_LSModerator Tuesday, October 13, 2015 2:22 AM
    Thursday, September 17, 2015 12:37 AM
  • Hi avTylerR,

    Thank you for your question.

    We could refer to the following path to force IE to use TLS 1.2:

    Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Explorer Control Panel > Advanced Page > Turn Off Encryption Support

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support


    • Edited by jim-xu Thursday, September 17, 2015 8:47 AM
    • Proposed as answer by jim-xu Sunday, September 27, 2015 12:28 AM
    • Marked as answer by Michael_LSModerator Tuesday, October 13, 2015 2:22 AM
    Thursday, September 17, 2015 8:47 AM

All replies

  • Hi,

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    Trusted sites Icon, 'Sites' button.... remove the un-named site and any sub-domains from the list.

    Also check that the domain has not been placed in the Restiricted sites zone or the Users Compatibility View list (Tools>Compatibility View Settings).

    If possible please include full links to any websites you are having problems with your questions so that we can visit them to do some testing.

    Regards.


    Rob^_^

    • Proposed as answer by jim-xu Sunday, September 27, 2015 12:28 AM
    • Marked as answer by Michael_LSModerator Tuesday, October 13, 2015 2:22 AM
    Thursday, September 17, 2015 12:37 AM
  • Hi avTylerR,

    Thank you for your question.

    We could refer to the following path to force IE to use TLS 1.2:

    Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Explorer Control Panel > Advanced Page > Turn Off Encryption Support

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support


    • Edited by jim-xu Thursday, September 17, 2015 8:47 AM
    • Proposed as answer by jim-xu Sunday, September 27, 2015 12:28 AM
    • Marked as answer by Michael_LSModerator Tuesday, October 13, 2015 2:22 AM
    Thursday, September 17, 2015 8:47 AM