locked
Pulling table into MS Access 2007, cannot update record! RRS feed

  • Question

  • So we use WSS3 for our timecard. I am managing a few developers and need to review time before it's billed so I created a view in WSS to do so. It works, but it's slow and getting annoying. I want to write my own app in WSS but don't have the time, so I thought MS Access 2007 would be a good shortcut for now. I've imported/linked the calendar which also imported the related lookups: customers, billing codes, projects and user information list.

    If I edit a record in table view I get the following error:

    You cannot record your changes because a value you entered violates the settings defined for field 'Billing Code' (for example, a value is less than the minimum or greater than the maximum). Correct the error and try again.

    Now the lookup/dropdown already has a value selected. If I reselect the same value, and try to save the record I get the same error for the Projects. Now, this time card entry doesn't require a project and I want it blank. So I selected a project, then deleted it and then it worked!! No errors with the Customer lookup are ever reported unless customer is blank, which is rare but OK.
     
    So any ideas? I'm hoping I can get around this to save me time, but I think this is a limitation of Access and SharePoint integraiton?
    Thanks!


    David Lozzi
    Delphi Technology Solutions
    Blog
    Tuesday, March 10, 2009 4:54 PM