locked
Exchange 2007 SMTP troubleshooting RRS feed

  • Question

  • have problems to sending mails to one specific domain in china, exchange generates NDR with:

    #550 4.4.7 QUEUE.Expired; message expired ##

    Investigate a bit and discover the MX record for this domain was not found (nslookup timeout). Our ISP reply so this domain appears on their blacklist and fix it (verified, nslookup now find this record). This happens abou 10 day a go, but mails still expiring. Trying to "telnet domain 25" from machine with exchange which work fine, that seem is prrof the problem is somewhere inside exchange SMTP part. Also trying to dump packets for given MX records address, and than send another mail for this domain, but no packets appears in Wireshark, so look like exchange did not even tried to send this message. I am also enable send connector logging, but nothing related to my mail appears. Tried to perform "ipconfig /flushdns" on given machine, but not help.

    Have no any problems with mails for other domains, everything rest traffic works fine. Anybody have idea?

    L.

    Wednesday, August 13, 2014 1:53 PM

Answers

  • Do you manage your own DNS? Have you tried clearing the cache on your DNS servers and the local resolver cache on the Exchange server(s) (I see you did the local resolver cache)? It wouldn't be the first time I've seen a bad query result stay in the cache on a DNS server. Stopping and starting the transport service wouldn't hurt, either.

    --- Rich Matheisen MCSE&I, Exchange MVP

    • Marked as answer by Amy.Wang Monday, August 25, 2014 9:52 AM
    Wednesday, August 13, 2014 6:09 PM