none
Adding virtual San Adapter to VM gives error 12804 - Cannot modify property without enabling VirtualizationBasedSecurityOptOut

    Question

  • We are setting up a windows 2016 Hyper-V cluster together with system Center VMM 2016. If we want to add an fibre channel Adapter to the VM we are getting the error. This is not only when we add the San adapter from svvmm but also when we create it from Hyper-v itself. This can be solved by entering the command Set-VMSecurity -VMName "name of the VM" -VirtualizationBasedSecurityOptOut $True but because we are creating the machines through SCVMM this is no really an option. Is there a more general way to solve this problem

    

    Thursday, February 16, 2017 9:19 AM

All replies

  • This forum is designed for questions about Hyper-V.  Your question is specific to SCVMM.  There are several SCVMM forums, such as https://social.technet.microsoft.com/Forums/en-US/home?forum=virtualmachinemanager, where you will find more experts on that product.  https://social.technet.microsoft.com/Forums/en-US/home?forum=virtualmachinemgrclustering is for SCVMM and clustering.

    . : | : . : | : . tim

    Thursday, February 16, 2017 1:28 PM
  • The Problem is not only when we create the VM from SCVMM, but also whe you create it in Hyper-v self. So it looks like that it is not scvmm related but hyper-v related
    Thursday, February 16, 2017 2:00 PM
  • Are you sure the vendor of the adapter supports this?  Not all do.

    BTW, my personal recommendation is to not use FC on the VMs.  It does not provide any performance benefits.  It doubles the management setup required for a 'normal' FC connection.  For example, in a configuration with two paths to storage, you have to configure for four WWNs on the VM instead of two like you do on a physical instance.  And, you lose some of the capabilities of a VM.  Sometimes there may be a need to FC in a VM, but generally the recommendation is to see how to NOT do it.


    . : | : . : | : . tim

    Thursday, February 16, 2017 2:17 PM
  • The servers use Qlogic adapters although they are not the newest ones I have Windows 2016 drivers installed. The whole environment is a test environment for our live production platform where the setup is the same. The VM's are database servers an that is mainly the reason that we direct attach the disk's through the Fibre channel adapters.

    I've set the VMSecurity -VirtualizationBasedSecurityOptOut to True for now but so I can continue but I believe it is something in windows 2016 which still has to be fixes by MS

    Thursday, February 16, 2017 3:03 PM
  • You still need to determine if Qlogic supports that.  That is up to Qlogic, not Microsoft.

    . : | : . : | : . tim

    Thursday, February 16, 2017 10:13 PM
  • I'll check that with Qlogic, thanks Tim

    Friday, February 17, 2017 10:30 AM
  • Hello Jeroen

    I had the same issue. In my case, it was solved by using PowerShell command

    Set-VMSecurity -VirtualizationBasedSecurityOptOut $true

    I think you are already tried that.

    Also, I downloaded OneCommand Manager to validate if NPIV is enabled for HBA adapters.

    Regards

    Hossam


    Thursday, July 20, 2017 12:29 PM
  • Unable to locate Set-VMSecurity command in powershell in server 2012 in my testing environment .some forums says you need to install Hyper-V Role.also i cannot install Hyper-v role as well,giving hardware limitations error balah balah .we have another same environment which is in production right now where i am unable to locate Set-VMSecurity in power shell but i can add fiber channel adapter..what should i do
    Wednesday, December 27, 2017 11:06 AM
  • "some forums says you need to install Hyper-V Role.also i cannot install Hyper-v role"

    Do not understand why you are responding to a Hyper-V forum post if you are not dealing with a Hyper-V issue.  If you are not running Hyper-V, any VM related command will not make any sense.  If there is notHyper-V hypervisor, there will be no VM related PowerShell commands.


    tim

    Wednesday, December 27, 2017 1:38 PM